Subject: [Int-area] WG Adoption Call: IP over Intentionally Partitioned Links

From: Wassim Haddad <[email-masked]>
Date: Thu, 19 Jan 2017 13:39:27 -0800

Dear all,

We would like to start a WG adoption call for draft-nordmark-intarea-ippl-05 ("IP over Intentionally Partitioned Links”).
Please indicate your preferences on the mailling list. The deadline is Februray 3rd.

Regards,

JC & Wassim

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 20 Jan 2017 06:32:33 +0000

Dear Wassim

I support the adoption. The problem is getting more clear and present as new technologies are introduced that include radio, mobility and multi link subnets.

Regards,

Pascal

Le 19 janv. 2017 ? 22:38, Wassim Haddad <[email-masked]<mailto:[email-masked]>> a ?crit :

Dear all,

We would like to start a WG adoption call for draft-nordmark-intarea-ippl-05 ("IP over Intentionally Partitioned Links").
Please indicate your preferences on the mailling list. The deadline is Februray 3rd.

Regards,

JC & Wassim

_______________________________________________
Int-area mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-area

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 20 Jan 2017 09:14:23 -0800

Note that the document is only 7.5 pages of content (plus references and 
boiler plate).
So if you haven't read it yet, it is a quick read.

Thanks,
    Erik

On 1/19/17 1:39 PM, Wassim Haddad wrote:
> Dear all,
>
> We would like to start a WG adoption call for 
> _draft-nordmark-intarea-ippl-05_ ("IP over Intentionally Partitioned 
> Links”).
> [email-masked]

---

From: Richard Li <[email-masked]>
Date: Thu, 26 Jan 2017 00:09:31 +0000

Authors:

Do you intend to specify a standard or provide some information about the implementation?

Another question： Assuming your router supports L2VPN or its equivalent, can L2VPN solve your problem?

Thanks,

Richard

From: Int-area [mailto:[email-masked]] On Behalf Of Wassim Haddad
Sent: Thursday, January 19, 2017 1:39 PM
To: [email-masked]
Subject: [Int-area] WG Adoption Call: IP over Intentionally Partitioned Links

Dear all,

Regards,

JC & Wassim

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 26 Jan 2017 10:19:36 -0800

> Do you intend to specify a standard or provide some information about 

Richard,

I'm not sure I understand your question.

The draft specifies constraints on an implementation (with some MUST and 
SHOULD) for both the L2 partitioning layer and for IP running over this 
partitioned L2. That makes it a standard.
Note that in general it is a bad idea to standardize specific behavior 
since we want to allow implementations to try different things.
FWIW I've been bitten by this in the past with the IPv6 NUD standard 
being far to prescriptive with retransmission behaviors so we had to 
make an additional standards-track RFC relaxing the behavior.

> Another question：Assuming your router supports L2VPN or its 
> equivalent, can L2VPN solve your problem?
>

If L2VPN is used to create a fully connected L2 network, then the L2VPN 
link would not be partitioned. Hence you wouldn't need the IPPL handling 
in that case. (But I imagine L2VPN could be used to create a partitially 
partitioned link as well.)

But that doesn't mean that L2VPN would solve the problem people set up 
to solve when they created split horizon for DSL or PVLAN for Ethernets.

We just need to make sure IPv4 and IPv6 can run reliably on such 
partitioned links.

Does that answer your question?

Thanks,
    Erik

> Thanks,
>
> Richard
>
> *From:*Int-area [mailto:[email-masked]] *On Behalf Of 
> *Wassim Haddad
> *Sent:* Thursday, January 19, 2017 1:39 PM
> *To:* [email-masked]
> *Subject:* [Int-area] WG Adoption Call: IP over Intentionally 
> Partitioned Links
>
> Dear all,
>