Subject: [Iot-onboarding] Side meeting at the IETF Montreal - call for agenda items

From: Eliot Lear <[email-masked]>
Date: Sun, 30 Jun 2019 10:54:43 +0200

With the release of the meeting agenda we are now able to book side meetings.

A number of people have contacted me about meeting in Montreal, and that they wouldn’t be available after Tuesday.  Conveniently, Monday morning is reserved for side meetings.  I propose we take advantage of this from 9:00 - 10:30 (yes, this bleeds into the 1st session).

I’ve combined MUD and IoT Onboarding, just to save time, as there is substantial community overlap.  That’s because the spaces are clearly related, one being authentication of the device the other being network authorization.

This, then, is a call for agenda items.  I have a few of my own, but would prefer to hear from others first.  Also, are you ok with the Monday morning time slot and keeping these activities together?

Eliot
Ps: reminder: side meetings are not “official” anything.  Just a gathering of people with a common interest.  However, the meeting will run under the IPR rules of the IETF, regardless.  All are invited.

---

From: Eliot Lear <[email-masked]>
Date: Sun, 30 Jun 2019 10:55:52 +0200

The meeting will be in C2 on the 21st floor.  A U-shaped room.

> On 30 Jun 2019, at 10:54, Eliot Lear <[email-masked]> wrote:
> 
> Signed PGP part

---

From: Michael Richardson <[email-masked]>
Date: Sun, 30 Jun 2019 12:49:38 -0400

Eliot Lear <[email-masked]> wrote:
    > A number of people have contacted me about meeting in Montreal, and
    > that they wouldn’t be available after Tuesday.  Conveniently, Monday
    > morning is reserved for side meetings.  I propose we take advantage of
    > this from 9:00 - 10:30 (yes, this bleeds into the 1st session).

It bleeds into teep, and I'm curious about the loops BOF, so I probably take
off at the appointed time.

    > I’ve combined MUD and IoT Onboarding, just to save time, as there is
    > substantial community overlap.  That’s because the spaces are clearly
    > related, one being authentication of the device the other being network
    > authorization.

Agreed.

    > This, then, is a call for agenda items.  I have a few of my own, but
    > would prefer to hear from others first.  Also, are you ok with the
    > Monday morning time slot and keeping these activities together?

    > Ps: reminder: side meetings are not “official” anything.  Just a
    > gathering of people with a common interest.  However, the meeting will
    > run under the IPR rules of the IETF, regardless.  All are invited.

So, I'm not sure if you are asking for BRSKI items, or IoT onboarding items in general.

1) Under BRSKI for non-ANIMA ACP uses, there is the question about open/closed
   registrars, and operational considerations of total sales channel integration
   (MASA knows the customers), vs retail integration (no knowledge of
   customers).  There are probably areas of grey in between that might be
   worth enumerating.

2) There is a similar question for MUD, which is how does the MUD controller
   arrive at trust criteria for the signatures.  This is the
   enterprise/customer side of the above story: do you know who you are
   buying from?
   This relates to the discussion we have had about controllers: I think if
   we could pin down the quality of the signatures, we could say more.

3) MUD Operational considerations for devices that can grow "skills"

Not really a topic exactly: but how do we get towards the point where we can test
MUD/BRSKI integration.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-