Subject: Re: [Iotsi] Fwd: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

From: Joaquin Prado <[email-masked]>
Date: Fri, 2 Jun 2017 14:58:59 -0700

Hi Carsten,
Is this meeting (subject above) still taken place in July?
I am discussing this topic with several people and we would like to prepare a presentation.

Thanks

Joaquin
---------------------------------------
Director of Technical Programs
Open Mobile Alliance | www.openmobilealliance.org<http://www.openmobilealliance.org/>
Cell: (+1) 858 249 8300<tel:%28%2B44%29%20%280%2977%2017%2027%2050%2024>
Desk: (+1) 858 623 0741
Skype: jpradocueva
Email: [email-masked]<mailto:[email-masked]>

From: Iotsi [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: 04 May 2017 11:03
To: [email-masked]
Cc: [email-masked]
Subject: [Iotsi] Fwd: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

The workshop announced below is somewhat of a logical continuation of what we did in Santa Clara in March 2016.
So you may be interested to contribute and to participate.
We haven’t sent out the formal call for contributions yet, but the below should give the direction of what we need.
Please register at the address given, and send the T2TRG chairs (in CC) ideas of what you want to contribute.

Grüße, Carsten

Begin forwarded message:

From: Ari Keränen <[email-masked]<mailto:[email-masked]>>
Subject: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)
Date: May 4, 2017 at 17:45:46 GMT+2
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Carsten Bormann <[email-masked]<mailto:[email-masked]>>

Save the date July 15/16, 2017 for Workshop on IoT Semantic/Hypermedia Interoperability, in Prague at IETF99.

See the description below and up to date information with registration instructions here: https://github.com/t2trg/2017-07-wishi

Cheers,
Ari & Carsten

One of the interesting questions in the IoT space is the role of hypermedia and/or semantic interoperability for reducing setup overhead and thus TCO, and, more generally, enabling interoperation in the first place.

For example, OMA and IPSO smart objects use the LWM2M object model, which defines a set of pre-structured URI templates and registry of object identifiers with semantics attached. This provides machine- readable representations of the semantics, but self description is not being used much.

OCF has a hypermedia approach with discovery using /oic/res etc., which relies on self-description via pointing to predefined resource types and interface types, which in turn use a number of specification techniques, including JSON schema and RAML.

There is also iot.schema.org<http://iot.schema.org>, which will allow us to gather further semantic interoperability information in potentially a more granular way.

W3C WoT cares a lot about self-description, with an RDF-based take on semantics and describing things.

T2TRG cares about pulling all this together.

On July 15, we will have a workshop that includes people from these organizations/groups. The focus will be on building a landscape that can benefit from the various approaches, without necessarily papering over all the holes or filling in all the rifts. On July 16, we will have additional time for follow-on work groups that want to make progress on specific issues.

The venue is the Prague Hilton, the same hotel that will host IETF99 directly after that. To further minimize travel, we chose the weekend directly after the July W3C WoT meeting in close by Düsseldorf.

Elements of the agenda:

State of the union

We will have "state of the union" talks from each of the organizations, discussing from a personal perspective where we are on interoperability in the organization and what are the next steps.

Research contributions, prototypes

We will issue a call for contributions, with a goal of getting new views and new voices into the mix. This will be research on the approaches available for building hybrid, overarching systems, as well as some practical systems that are already demonstrating how this could be made to work in practice, such as systems for converting some of the formal notations and/or self descriptions into each other.

Specific topics

The below topics (and any other that come up) could be discussed on Saturday and/or result in more detailed breakouts on Sunday.

Interops

The "device ecosystem" oriented SDOs are now increasingly using common protocols and formats (CBOR, CoAP, IPv6) which is creating one narrow waist in the system, and we can look into creating a narrow waist also around semantic interoperability and hypermedia design patterns. Ultimately, it should not matter which device ecosystem(s) you use for your application. The device ecosystems can maintain their focus on intra-op and certification while an over arching web-like layer of interoperability can add more value to all of them.

Now is a good time to start to organize cross-ecosystem interops, where we attempt to orchestrate devices and sources from these different device ecosystems. At this point we need to consider orchestration across applications as well as device to device interoperability.

We have also discussed a lot about conducting more of the actual testing over the Internet. This seems like a good concept to build in from the beginning. What are the tools we need to conduct an online hyper-semantic interop series? Is it staged, from basic to more sophisticated?

This seems to represent the canonical use case for both W3C WoT and iot.schema.org<http://iot.schema.org>, as well as the various translators and bridges being created.

Hypermedia forms

HTML has a form element that can be used to construct POST request bodies (and other request payloads, such as for PATCH). An M2M equivalent has been lacking for quite some time, although there are proposals. Now that we have FETCH and PATCH (RFC 8132), the need is even more pronounced. What are the next steps towards common Hypermedia "forms", which would help at least T2TRG, OCF, and WoT?

Hypermedia-driven applications in general

T2TRG has a number of drafts documenting how application developers use hypermedia to aid in building thing-to-thing (and thing-to-cloud) systems. Are these complete? What else do we know about that? What about documents from, say, W3C or IPSO?

Model translation

We now have multiple proposals for data modeling (YANG, CDDL, JSON Schema, JSON Content Rules) as well as ad-hoc metamodels. What are the semantic powers of these modeling approaches? Can we automatically translate between them so we can make models of one ecosystem available for the other ones? How do we tap hidden Gems such as the ZigBee Cluster Library or the Bluetooth GATT specs? What about interaction modeling (also YANG, RAML, Swagger, ...)?

________________________________

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 3 Jun 2017 08:28:42 +0200

Hi Joaquin,

> Is this meeting (subject above) still taken place in July?

Yes, please see

https://github.com/t2trg/2017-07-wishi

and

https://github.com/t2trg/2017-07-wishi/blob/master/CALL-FOR-CONTRIBUTIONS.md

(While the timeline we gave for discussing “state-of-the-union” talks with the chairs already has passed, I think we can accommodate one more if we learn about it quickly.)

> I am discussing this topic with several people and we would like to prepare a presentation.

Looking forward to a proposal!

Grüße, Carsten

---

From: Joaquin Prado <[email-masked]>
Date: Mon, 5 Jun 2017 16:18:28 -0700

Hi Carsten,
I am in discussion with Michel Kohanim, cc here, to send an brief extract of the issues that we foresee and a considerations to move forward.

You will have a first email with this extract soon and from there you can tell us if a presentation should be presented to this group.
Regards

Joaquin

From: Carsten Bormann [mailto:[email-masked]]
Sent: 02 June 2017 23:29
To: Joaquin Prado
Cc: [email-masked]; [email-masked]
Subject: Re: [Iotsi] Fwd: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

Hi Joaquin,

Yes, please see

and

Grüße, Carsten

---

From: Joaquin Prado <[email-masked]>
Date: Mon, 5 Jun 2017 18:19:02 -0700

Hi Carsten,

Please see below a brief explanation that what we would like to present to this group for consideration:

 *   Some data models represent the sensor information as a model of Objects & Resources
    *   Breaking large components into atomic subcomponents, e.g.: relays, temperature sensors, etc into temperature, Centigrade or Fahrenheit degrees, etc
    *   These subcomponents are standardized one by one e.g. as Objects and Resources and registered with a unique value.
 *   This approach of defining each possible object and resources doesn’t scale well:
    *   It requires companies from different sectors to agree what and how to standardize sensor properties.
    *   Registration, validation and verification effort cannot be underestimated if the aim is to reach out to billions of devices.
    *   Development/compile time integration is an impediment to interoperability

Criteria to consider to move forward

 *   The Data Model should describe how Things are defined rather than defining Things themselves:
    *   What you can do to the Thing (commands send to the Thing)
    *   What the Thing can do to you (commands received from the Thing … i.e. someone physically pressed a button on the Thing)
    *   What properties the Thing has

Please let us know if our contribution will be welcome and we will submit it in the next two or three days.

Thank you and kind regards
Michel & Joaquin
---------------------------------------

From: Joaquin Prado
Sent: 05 June 2017 16:18
To: 'Carsten Bormann'
Cc: [email-masked]; [email-masked]; Michel Kohanim ([email-masked])
Subject: RE: [Iotsi] Fwd: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

Hi Carsten,

Joaquin

From: Carsten Bormann [mailto:[email-masked]]
Sent: 02 June 2017 23:29
To: Joaquin Prado
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Iotsi] Fwd: Save the date: July 15/16, 2017: Workshop on IoT Semantic/Hypermedia Interoperability (at IETF99 in Prague)

Hi Joaquin,

Yes, please see

and

Grüße, Carsten