Subject: [Iotsi] Fwd: [T2TRG] Call for papers - workshop on semantic interoperability

From: Ted Hardie <[email-masked]>
Date: Fri, 5 Jan 2018 08:54:19 -0800

Seen on the t2trg list, but likely of interest here.

regards,

Ted
---------- Forwarded message ----------
From: Soumya Kanti Datta <[email-masked]>
Date: Fri, Jan 5, 2018 at 12:49 AM
Subject: [T2TRG] Call for papers - workshop on semantic interoperability
To: "[email-masked]" <[email-masked]>

Dear all,

I am chairing a workshop on semantic interoperability in IoT and WoT which
is a part of GIoTS 2018. The scope of the workshop is highly relevant to
the WoT groups. I welcome your submission. Please find below the call for
papers.

******************Call for papers************************
Internet of Things (IoT) requires not only the development of
infrastructure but also deployment of new services capable of supporting
multiple, scalable and interoperable applications. It is widely
acknowledged that interoperability is the key to achieve the full potential
of the IoT ecosystem. Due to the highly dynamic nature of the IoT, a strong
need of interoperability at data level has emerged so that it becomes
easier to combine/aggregate, process, manage and store the data/event
coming from heterogeneous data sources. Several European and international
IoT research projects have shown the semantic interoperability to address
the problem. Standard development organizations (W3C, oneM2M, AIOTI WG3)
also recognize this. The next step is to develop test methodologies and
tools that validate the semantic compliance and interoperability among
systems under test. Such tools are of urgent need to boost the acceptance
and adoption of the semantic technologies by the general IoT market. This
workshop will examine the current landscape on semantic interoperability
and create a platform for advance discussion on the same. The technical
topics of interest include, but are not limited to:

• Semantic interoperability in IoT and WoT
• IoT Platform interoperability
• Semantic interoperability testing methodology
• Semantic interoperability current state and future outlook
• Standardizing Semantic interoperability
• Performance evaluation of Semantic interoperability tools

This workshop is supported by EU project F-Interop. T*he workshop is a part
of Global IoT Summit 2018 conference which is co-located with IoT Week 2018
during 4-7 June 2018 in Bilbao, Spain.* For more info, visit -
http://globaliotsummit.org/

*Important Dates*
Paper submission deadline: February 28, 2018
Acceptance Notification: March 31, 2018
Camera-Ready Paper Submission: April 30, 2018

All final submissions should be written in English with a maximum paper
length of six (6) printed pages see web conference for instructions.
*Papers must be submitted through EDAS at the following link –
https://edas.info/newPaper.php?c=24130&track=89111
<https://edas.info/newPaper.php?c=24130&track=89111>*

*Workshop Chairs: *
Soumya Kanti Datta, EURECOM, France
Mengxuan Zhao, Easy Global Market, France
Franck Le Gall, Easy Global Market, France
Hamza Baqa, Easy Global Market, France

Best regards
Soumya

-- 
Research Engineer, EURECOM, France | @skdatta2010 | http://iot.eurecom.fr

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: Tim Coote <[email-masked]>
Date: Fri, 5 Jan 2018 17:11:24 +0000

Hi Ted

I’ve looked at this issue in some depth in the context of the design for what is now BG’s Hive Active Heating system, including a couple of relevant patents. While at the high level, the issue is no harder than enterprise integration (!), it’s not practical to get close to that level of maturity as there is so little control over the Things.  

From my experience, I found that semantic interoperability can only be achieved by:
a/ simplifying end physical real-world integration points as much as  possible (ie the sensors and actuators)
b/ focusing initially on understanding the information timing and error constraints on the compute nodes.
c/ enforcing behavioural and testability constraints on sensors/actuators.

Only when these basics are in place can anything like a reliable IoT system be deployed with sensible operational support economics. At that stage, the semantics can be implemented in the software layers, although many of the semantic issues are still to do with behavioural limitations, rather than focusing on ‘happy path’ behaviours.

Are my experience and conclusions way off the mark of the research community, or am I comparing different problem spaces?

cheers

Tim Coote
> On 5 Jan 2018, at 16:54, Ted Hardie <[email-masked]> wrote:
> 
> I am chairing a workshop on semantic interoperability in IoT and WoT which is a part of GIoTS 2018. The scope of the workshop is highly relevant to the WoT groups. I welcome your submission. Please find below the call for papers.
> Internet of Things (IoT) requires not only the development of infrastructure but also deployment of new services capable of supporting multiple, scalable and interoperable applications. It is widely acknowledged that interoperability is the key to achieve the full potential of the IoT ecosystem. Due to the highly dynamic nature of the IoT, a strong need of interoperability at data level has emerged so that it becomes easier to combine/aggregate, process, manage and store the data/event coming from heterogeneous data sources. Several European and international IoT research projects have shown the semantic interoperability to address the problem. Standard development organizations (W3C, oneM2M, AIOTI WG3) also recognize this. The next step is to develop test methodologies and tools that validate the semantic compliance and interoperability among systems under test. Such tools are of urgent need to boost the acceptance and adoption of the semantic technologies by the general IoT market. This workshop will examine the current landscape on semantic interoperability and create a platform for advance discussion on the same. The technical topics of interest include, but are not limited to: 
> 
> This workshop is supported by EU project F-Interop. The workshop is a part of Global IoT Summit 2018 conference which is co-located with IoT Week 2018 during 4-7 June 2018 in Bilbao, Spain. For more info, visit - http://globaliotsummit.org/
> 
> Important Dates
> All final submissions should be written in English with a maximum paper length of six (6) printed pages see web conference for instructions. 
> Papers must be submitted through EDAS at the following link – https://edas.info/newPaper.php?c=24130&track=89111
> 
> Workshop Chairs: 
> Research Engineer, EURECOM, France | @skdatta2010 | 
> 
> http://iot.eurecom.fr
> 
> Iotsi mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/iotsi