Subject: doubt regarding : buffer_size field of encapsulation header

From: Prashant Vedantam <[email-masked]>
Date: Tue, 13 Apr 1999 17:28:12 +0530

Can you please throw some light on my doubt regarding buffer_size .

As per  the draft it was mentioned that :

In the encapsulation header the field buffer_size indicates the size of
the buffer ,necessary for the recipient to reassemble the fragments.

My doubt is weather the buffer_size indicates the size of the fragment or
the size off the entire packet .

i.e suppose if a packet is fragmented into 3 fragments .
Now can  you please clarify wheather

buffer_size = size of the fragment
(or)
buffer_size = size of packet

P.vedantam
Design and development
TATA ELXSI LIMITED
Bangalore

---

From: Myron Hattig <[email-masked]>
Date: Tue, 13 Apr 1999 12:12:09 -0700

> buffer_size = size of packet

Buffer size = size of IP packet (including IP header).

Fragment size is extracted from 1394 packer header info.

Offset of fragment within IP packet is 0 for first fragment, and equal
to fragment_offset field in non-first fragments.

-myron