Subject: Re: fragmentation / reassembly specifications in the IP/1394 Draf t.

From: "Hattig, Myron" <[email-masked]>
Date: Wed, 27 Oct 1999 14:15:27 -0700

> From the draft:
> "buffer_size: The size of the buffer, expressed as
> buffer_size + 1 octets,
> necessary for the recipient to reassemble the entire IP
> datagram from all of
> the link fragments. The value of buffer_size SHALL be the
> same for all link
> fragments of an IP datagram. "
>
> 1) Should the buffer_size include the Encapsulation Header ?
> This may need
> to be to be clarified in the draft.

The definition says: "to reassemble the entire IP datagram from
all link fragments". What about the text makes you think the
encapsulation header would be included in that size?

> 2) Regarding the stipulation that the buffer_size shall be
> the same for ALL
> link fragments -- the LAST fragment generated during
> fragmentation may not
> have the same buffer_size as all the other fragments of an IP
> datagram. This
> may also need to be clarified in the draft.

You are incorrect. The buffer size is the same for all
fragments of a single IP packet. The offset will be different
for each fragment, but not the buf size. The same buf size per
fragment allows for the proper sized buffer to be allocated
if a middle or last fragment is received before the first
fragment. This allows for proper reassembly even when fragments
are received out of order.

-myron

---

From: "Aditya Dube (Exchange)" <[email-masked]>
Date: Wed, 27 Oct 1999 18:20:13 -0700

Myron

I stand corrected.  I was under the impression that the buffer_size was
related to the size of a fragment as opposed to the size of the entire
datagram.

Thanks
Aditya Dube

-----Original Message-----
From: Hattig, Myron [mailto:[email-masked]]
Sent: Wednesday, October 27, 1999 2:15 PM
To: 'Aditya Dube (Exchange)'; [email-masked]
Subject: RE: fragmentation / reassembly specifications in the IP/1394
Draft.

-myron

---

From: "Hattig, Myron" <[email-masked]>
Date: Thu, 28 Oct 1999 12:04:11 -0700

I just learned that we are able to make some very minor tweaks to the
draft 48 hours before it becomes an RFC. At this time, we'll plan to
modify the definition of Buffer_Size from:

   buffer_size: The size of the buffer, expressed as buffer_size + 1
   octets, necessary for the recipient to reassemble the entire IP
   datagram from all of the link fragments. The value of buffer_size
   SHALL be the same for all link fragments of an IP datagram.

To:

   buffer_size: The size of the buffer, expressed as buffer_size + 1
   octets, necessary for the recipient to reassemble the entire IP
   datagram from all of the link fragments; that is, buffer_size + 1
   equals the entire length of the IP datagram that is fragmented.
   The value of buffer_size SHALL be the same for all link fragments
   of an IP datagram.

I think this text clears up the point of confusion Aditya had as well
as another I've heard regarding the interpretation "buffer_size + 1".

-myron

> From: Hattig, Myron [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 9:25 AM
> To: [email-masked]
> Subject: Re: fragmentation / reassembly specifications in the IP/1394
> Draf t.
>
>
> Aditya sent his suggestion for a mod to the text in a private
> note. His is a
> good suggestion because it clears-up a common point of confusion about
> Buffer_Size. His suggestion is to say:
> The Buffer_size will equal the length of the IP Datagram that is to be
> fragmented.
>
> If this sentence is appended to the end of the description of
> Buffer_Size, I
> think future confusion will be less.
>
> Since the doc has already gone to the RFC editor to become an Proposed
> Standard RFC. The text cannot change in the short term. My
> understanding is
> the that we can make small editorial changes like this when
> and if the doc
> goes from Proposed Standard to Draft Standard. For now I'll
> keep a list
> changes in the doc.
>
> -myron
>

---

From: "Joseph Joy (Exchange)" <[email-masked]>
Date: Thu, 28 Oct 1999 12:19:07 -0700

Your suggestion is certainly unambiguous and clear. Here's something shorter
which also seems to work:

buffer_size: The size of the unfragmented IP datagram, expressed as
buffer_size + 1
   octets. The value of buffer_size SHALL be the same for all link fragments
of an IP datagram.

-----Original Message-----
From: Hattig, Myron [mailto:[email-masked]]
Sent: Thursday, October 28, 1999 12:04 PM
To: [email-masked]
Subject: Re: fragmentation / reassembly specifications in the IP/1394
Draf t.

To:

-myron

---

From: "Joseph Joy (Exchange)" <[email-masked]>
Date: Thu, 28 Oct 1999 12:24:55 -0700

In case there's any confusion that "unfragmented IP packet" may lead someone
to wonder if this means IP-layer (not link layer) fragmentation,
here's another suggestion:
buffer_size: The total size of the IP datagram, expressed as buffer_size + 1
   octets. The value of buffer_size SHALL be the same for all link fragments
of an IP datagram.

-----Original Message-----
From: Joseph Joy (Exchange)
Sent: Thursday, October 28, 1999 12:19 PM
To: 'Hattig, Myron'; [email-masked]
Cc: Aditya Dube (Exchange)
Subject: RE: fragmentation / reassembly specifications in the IP/1394
Draf t.

-----Original Message-----
From: Hattig, Myron [mailto:[email-masked]]
Sent: Thursday, October 28, 1999 12:04 PM
To: [email-masked]
Subject: Re: fragmentation / reassembly specifications in the IP/1394
Draf t.

To:

-myron