Subject: Re: IPv6 over IEEE1394 (dual-stack?)

From: Arvind Murching <[email-masked]>
Date: Mon, 10 Jul 2000 13:32:12 -0700

I was referring to the configuration ROM setting for the textual
descriptor
for Unit_SW_Version.  IPv4-only nodes may set this optional field to
"IPv4". Does setting this to "IPv6" mean that the node supports both
IPv4
and IPv6?

-- Arvind

-----Original Message-----
From: Hattig, Myron [mailto:[email-masked]]
Sent: Monday, July 10, 2000 10:53 AM
To: [email-masked]
Subject: Re: IPv6 over IEEE1394 (dual-stack?)

> The I-D does not say this explicitly, but does it support dual-stack
> configurations, i.e. for the host/device to run both IPv4 and IPv6?

IPv4 vs IPv6 is demuxed by the Ethertype or the first nibble of the IP
header. Is this what you are referring to? Or is there some 1394
specific
question?

-myron

---

From: "G. Nagaraj" <[email-masked]>
Date: Tue, 11 Jul 2000 08:51:20 +0530

RE: Re: IPv6 over IEEE1394 (dual-stack?)Hi Arvind,

I think the Config ROM should have two Unit directories, one for IPV4 and
one for IPV6. But the only question in this case is the Unit Spec ID and
Unit SW version.

Nagaraj
  -----Original Message-----
  From: IETF IP over 1394 Working Group
[mailto:[email-masked]]On Behalf Of Arvind Murching
  Sent: Tuesday, July 11, 2000 2:02 AM
  To: [email-masked]
  Subject: Re: IPv6 over IEEE1394 (dual-stack?)

  I was referring to the configuration ROM setting for the textual
descriptor
  for Unit_SW_Version.  IPv4-only nodes may set this optional field to
  "IPv4". Does setting this to "IPv6" mean that the node supports both IPv4
  and IPv6?

  -- Arvind

  -----Original Message-----
  From: Hattig, Myron [mailto:[email-masked]]
  Sent: Monday, July 10, 2000 10:53 AM
  To: [email-masked]
  Subject: Re: IPv6 over IEEE1394 (dual-stack?)

  IPv4 vs IPv6 is demuxed by the Ethertype or the first nibble of the IP
  header. Is this what you are referring to? Or is there some 1394 specific
  question?

  -myron

---

From: Kenji Fujisawa <[email-masked]>
Date: Tue, 11 Jul 2000 15:29:23 +0900

>one for IPV6.

Yes. It is my intent.

>But the only question in this case is the Unit Spec ID and
>Unit SW version.

I think the value of Unit_Spec_ID shall be the same value with RFC2755,
ie, 0x00005e.
The value of Unit_SW_Version should be assigned by IANA (ICANN?),
or its delegated organization.

RFC2755 "10. IANA CONSIDERATIONS"
:  The new name space is "CSR Protocol Identifiers". The values zero and
:  0xFF FFFF are reserved and SHALL NOT be allocated by IANA. The value
:  one is allocated to this document. The remaining numbers SHALL be
:  managed by IANA and allocated as necessary to identify Internet-
:  Drafts that become IESG standards track documents.
:  Regardless of the assignment method elected by IANA, a registry of
:  all assigned version numbers SHOULD be maintained at one or more
:  Internet sites and should clearly identify the relevant standard
:  identified by the combination of the RID and version number.

Best Regards,

Kenji Fujisawa