Subject: BPI vs BPI+ MIBs

From: Earl Mitchell <[email-masked]>
Date: Tue, 14 Dec 1999 17:14:38 -0800

Where are the specs for BPI (DOCSIS1.0)
and BPI+ (DOCSIS1.1) MIBs? 

There used to be a draft for BPI MIB located at 

http://www.ietf.org/internet-drafts/draft-ietf-ipcdn-mcns-bpi-mib-00.txt

But this was deleted? And I cannot find the BPI+ MIB anywhere.
The cablelabs web site does not have the correct BPI or BPI+ MIB.

I also have a question about BPI and BPI+ MIB support in CMTS.
The CMTS must be able to work in both BPI and BPI+ mode
so I am assuming it must maintain both the BPI and BPI+ 
MIBs tables. How does this work for CMTS specific counters? For 
example, there is a MIB counter to keep track of how
many AuthRejects were transmitted by the CMTS. Does this
counter get incremented for both the BPI and BPI+ MIB
counter for AuthRejects? Or do you increment the counter
for the BPI or BPI+ MIB based on whether the AuthReject
was done for a BPI or BPI+ CM? That is, activities for
BPI CMs affects BPI MIB only, and likewise for BPI+

-earl

---

From: Earl Mitchell <[email-masked]>
Date: Tue, 14 Dec 1999 19:42:43 -0800

Ok I found that the document SP-OSSIv1.1-D01-991115 has a list
of BPI+ MIB objects that must be supported for DOCSIS1.1. But
still don't have DOCSIS1.0 MIB spec for BPI? 

-earl

---

From: Kaz Ozawa <[email-masked]>
Date: Wed, 15 Dec 1999 00:02:57 -0700

> The cablelabs web site does not have the correct BPI or BPI+ MIB.

Unfortunately, bpi-mib-00.txt have already expired and the IETF does not
keep it on their web.  Instead, you can find the bpi-mib-00.txt on the
cable modem web as follows.

www.cablemodem.com --> participant entry --> vendors --> specifications 
--> interim specifications --> Operations Support System Interface (OSSI) 
--> Baseline Privacy MIB (draft-ietf-ipcdn-mcns-bpi-mib-00.txt)  

Regarding the BPI+ MIB, the next draft mib should be posted to the ipcdn
reflector very soon. 

> BPI CMs affects BPI MIB only, and likewise for BPI+

Good question.
This issue should be at least clarified in the draft.

Thanks,
kaz

> -earl 

Kaz Ozawa, Toshiba Visiting Engineer at CableLabs
Tel: 303-661-3860 (direct); 9199 (fax); 9100 (main)
Email: [email-masked] / [email-masked]

---

From: Kaz Ozawa <[email-masked]>
Date: Wed, 15 Dec 1999 00:07:19 -0700

I'm afraid the list you found in the OSSIv1.1-D01 is the table 
in Appendix A which only contains the BPI MIB objects required
in the BPI mode where the 1.1 CM is connected to the 1.0 CMTS.
This table needs clarification to specify that these BPI MIB 
objects are for BPI mode only.

Thank you for your questions.
kaz