Subject: RE: New BPI MIB: Relaxation on MandatoryRange

From: Kazuyoshi Ozawa <[email-masked]>
Date: Tue, 11 Jan 2000 15:05:17 -0700

> -----Original Message-----
> From: Bob Himlin [mailto:[email-masked]]
> Sent: Tuesday, January 11, 2000 1:55 PM
> To: [email-masked]
> Subject: RE: New BPI MIB: Relaxation on MandatoryRange
> 
> 
> I don't think they are needed.  I do note, however, as regards
> docsBpiCmTEKGraceTime, that the BPI+ spec has a range of 
> 1-18006, and the
> MIB only has a range of 1-1800.  Which one needs to be changed?

Oh, you are now talking about BPI+ instead of BPI.
Yes, there was a mistake in BPI+-I03 but it's already fixed by an ECN,
bpi-n-99100.  The maximum value is now 302399 and consistent with the
BPI+ MIB draft, draft-ietf-ipcdn-bpiplus-mib-00.txt.

Note that the TEK management requirement specified in the BPI+ spec
section 6 is different from BPI and the max value of TEK Grace time
is completely different....

Thanks,
kaz

---

From: Kazuyoshi Ozawa <[email-masked]>
Date: Fri, 14 Jan 2000 14:11:19 -0700

If we remove the "Relaxation on MandatoryRange" and if a CM or 
a CMTS responds with the value outside the range defined by
the syntax field, it's violating the MIB spec.   
On the other hand, is a CM violating the MIB spec if the CM 
cannot respond with a certain value inside the range ?
--- I supposed that the answer is no while I may be wrong.

If we need the "Relaxation on MandatoryRange", the following
objects need them, too.

  docsBpi2CmAuthWaitTimeout
  docsBpi2CmReauthWaitTimeout
  docsBpi2CmAuthRejectWaitTimeout

Thanks,
kaz

> From: Stuart Green [mailto:[email-masked]]
> Sent: Friday, January 14, 2000 9:56 AM
> To: [email-masked]
> Subject: Re: New BPI MIB: Relaxation on MandatoryRange
> 
> 
> I'm not sure.  But if we do not have a relaxation statement
> then the BPI+ MIB will not comply with the BPI+ spec.  So I 
> think it is a good idea.
> 
> Kazuyoshi Ozawa wrote:
> > 
> > Do we really need the relaxation on mandatory renge for the
> > following 4 read-only objects ?
> > 
> >   docsBpiCmAuthGraceTime
> >   docsBpiCmTEKGraceTime
> >   docsBpiCmtsAuthCmGraceTime
> >   docsBpiCmtsTEKGraceTime
> > 
> > I understand that we need the relaxation for the read-write
> > object.  However, I'm not sure regarding the read-only objects.
> > 
> > Thanks,
> > kaz
> > 
> > Kaz Ozawa
> > Toshiba Visiting Engineer at CableLabs
> > Tel: 303-661-3860 (direct); 9199 (fax); 9100 (main)
> > Email: [email-masked] / [email-masked]
> 
> -- 
> Stuart M. Green
> Arris Interactive - A Nortel Networks / Antec Venture
> 6 Riverside Drive
> Andover, MA 01810
> (978) 946-4664
> [email-masked]
>