Subject: [ipcdn] [Fwd: FW: multicast mib table question]

From: Anna Ziper <[email-masked]>
Date: Tue, 26 Sep 2000 16:22:21 -0700

Subject: FW: multicast mib table question
From: "Mitchell, Earl" <[email-masked]>
To: "Ziper, Anna" <[email-masked]>
Date: Tue, 26 Sep 2000 16:14:40 -0700

-----Original Message-----
From: Mitchell, Earl 
Sent: Monday, September 25, 2000 4:13 PM
To: [email-masked]'
Subject: multicast mib table question

The CMTS Multicast SAID Authorization Table
has a comment that states:
 
 Note: The CMTS need only track those CMs actively using
          the SAID.
 
I don't understand this comment. Is this table used by
operator to specify which CMs are authorized to used
which SAIDs? Or is it used to show which CM's are 
currently using which SAIDs? 
 
The comment implies that only CMs that are actively
using this SAID are listed in the table. This table could
be used for both if you just added another field to state
whether the CM is currently using the SAID or not. 
 
-earl

---

From: Stuart Green <[email-masked]>
Date: Tue, 26 Sep 2000 20:04:32 -0400

Folks,
  The description needs some clarification.
  For static SAIDs, you would need to track
both active and inactive CMs.  However,
dynamic SAIDs need only track active CMs.
Tracking inactive CMs would be optional.
  The goal was to re-use a 1.0/BPI table
(which only supported static SAIDs).  The
comment was not in the BPI MIB.
  I'll make a note of modifying the comment
in a future revision.

Stuart

Anna Ziper wrote:
> 
>   ------------------------------------------------------------------------
> 

-- 
Stuart M Green
Nortel Networks Corporation - Arris Venture
6 Riverside Drive, Andover, MA 01810, USA  (978) 946-4664

_______________________________________________
IPCDN mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Anna Ziper <[email-masked]>
Date: Tue, 26 Sep 2000 17:32:03 -0700

Stuart,

I want to clarify that the CMTS Multicast SAID Authorization Table is used
for provisioning, it gives you legal Saids per modem regardless Said is static
or dynamic.
And "tracking" is completely different mechanism that CMTS should provide?
You can implement "tracking" by using this table by Earl's suggestion.
If I am wrong, please, correct me.

thanks, Anna

---

From: Stuart Green <[email-masked]>
Date: Tue, 26 Sep 2000 21:19:41 -0400

Anna,
  I do not entirely agree with your statement.
  The table is meant to be general purpose.
Though other possibilities exist, I can only
imagine "provisioning" static multicast SAIDs
and "tracking" dynamic multicast SAIDs.
  The real issue is that, to my knowledge,
there has been no definition of a back-end
CMTS interface to determine dynamic multicast
SAID ownership by CMs.  The BPI+ standard needs
to clarify how dynamic multicast SAIDs are to
be discovered by the head-end.
  The BPI+ MIB table, however, can handle
either "provisioned" or "tracked" dynamic
multicast SAIDs.  It just doesn't make a lot
of sense to "provision" anything dynamic.
Likewise, it makes little sense to "track" 
something static.

Stuart

The DOCSIS BPI+ standard needs to specify

---

From: Anna Ziper <[email-masked]>
Date: Tue, 26 Sep 2000 18:51:00 -0700

Stuart,

I thought that both static and dynamic SAIDs
is provisioning information to CMTS.
And the only difference between them,
that Auth Reply contains static SAIDs.
And modem gets dynamic Saids by Sa Map Request.
If this table is not for multicast information provisioning,
how I can check if the modem authorized to use multicast group.
Do you know other tables where such information located?
Maybe some IGMP tables?

thanks, Anna

---

From: Earl Mitchell <[email-masked]>
Date: Wed, 27 Sep 2000 14:35:26 -0700

> Likewise, it makes little sense to "track"

There is a problem though. The two table mappings
define a relationship that looks like this:

multicast ip -> SAID -> CM

Now assuming the operator must use these two
tables to define which which CMs are authorized
to access which multicast groups you have to
predetermine what the SAID assignment should
be. This is also a problem if BPI is disabled
and this table must be used to determine which
multicast group a CM is authorized to access. 
If the tables were changed to represent this
relationship:

CM -> multicast group -> SAID

Then all the problems would be fixed. You could
use this table for provisioning CM authorization,
provisioning which multicast group's use which
SAIDs, and tracking which CM's are using which
SAIDs. 

Does anyone know if another MIB table exist
which can be used to provision which CMs can
access which multicast groups? 

-earl

---

From: Earl Mitchell <[email-masked]>
Date: Wed, 27 Sep 2000 14:56:11 -0700

> SAIDs, and tracking which CM's are using which

Correction: Because you are using the tables for
provisioning and tracking you still need to add
a field to keep track of which CM's are currently
using the multicast group. Without this you just 
know which CMs are provisioned to use the multicast group. 

-earl