Subject: [ipcdn] BPI+ MIB Object related to Code Download

From: "Kaz Ozawa" <[email-masked]>
Date: Mon, 16 Oct 2000 16:32:32 -0600

All,

I have a couple of comments on the BPI+ MIB objects related to
the secure software downloading. 

1) docsBpi2CodeMfgCodeDownloadStatusString

>   docsBpi2CodeMfgCodeDownloadStatusString OBJECT-TYPE
>        SYNTAX    DisplayString
>        MAX-ACCESS     read-only
>        STATUS    current
>        DESCRIPTION
>            "The value of this object indicates the additional
>        information to the status code.  The value will include
>        the error code and error description which will be defined
>        separately."
>        REFERENCE
>            "DOCSIS Baseline Privacy Plus Interface Specification,
>        Section TBD (see D.3.7)"
>        ::= { docsBpi2CodeDownloadControl 2 }

I realize that the object name is something strange....
I thinks it should be "docsBpi2CodeDownloadStatusString".
Can we change the object name from now????

2) docsBpi2CodeCoSignerOrgName

>   docsBpi2CodeCoSignerOrgName   OBJECT-TYPE
>        SYNTAX    SnmpAdminString
>        MAX-ACCESS     read-only
>        STATUS    current
>        DESCRIPTION
>            "The value of this object is the Co-Signer's
>        organizationName."
>        REFERENCE
>            "DOCSIS Baseline Privacy Plus Interface Specification,
>        Section D.3.2.2."
>        ::= { docsBpi2CodeDownloadControl 6 }

I think we should specify that the value is zero length string in 
case that the Co-signer is not specified.

3) docsBpi2CodeCoSignerCode/CvcAccessStart

>   docsBpi2CodeCoSignerCodeAccessStart     OBJECT-TYPE
>        SYNTAX    DateAndTime
>        MAX-ACCESS     read-only
>        STATUS    current
>        DESCRIPTION
>            "The value of this object is the Co-Signer's current
>        codeAccessStart value referenced to Greenwich Mean
>        Time (GMT)."
>        REFERENCE
>            "DOCSIS Baseline Privacy Plus Interface Specification,
>        Section D.3.2.2."
>        ::= { docsBpi2CodeDownloadControl 7 }
>
>   docsBpi2CodeCoSignerCvcAccessStart OBJECT-TYPE
>        SYNTAX    DateAndTime
>        MAX-ACCESS     read-only
>        STATUS    current
>        DESCRIPTION
>            "The value of this object is the Co-Signer's current
>        cvcAccessStart value referenced to Greenwich Mean
>        Time (GMT)."
>        REFERENCE
>            "DOCSIS Baseline Privacy Plus Interface Specification,
>        Section D.3.2.2."
>        ::= { docsBpi2CodeDownloadControl 8 }

If the Co-signer is not specified and co-signing is not required,
the CM need not to retain these values at all. Therefore, how about
to add "If docsBpi2CodeCoSignerOrgName is zero length string, the
value of this object is meaningless" or something like this....

Thanks,
kaz

Kaz Ozawa, Toshiba Visiting Engineer at CableLabs
(303) 661-3860 (direct); -9199 (fax); 9100 (direct) 
[email-masked] / [email-masked]

_______________________________________________
IPCDN mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Libi Hertzberg <[email-masked]>
Date: Sun, 29 Oct 2000 14:09:17 +0200

Hi all,
I have some comments about the proposed changes to:
2) docsBpi2CodeCoSignerOrgName
3) docsBpi2CodeCoSignerCode/CvcAccessStart

-- In BPI+23.1 ATP (Secure Software Download), it is written:

"1.2: Failed update of a CVC
The purpose of this test is to verify that a modem be recognize 
an invalid certificate and reject it.
Config. Files: All of the configuration 
files used in this test are based on secure_download.cfg Which
includes basic configuration parameters.
Run # Config File Name Parameters Changed
a bad_cvc.cfg
....
6 bad_cvc6.cfg Contains basic configuration defined above, 
a Co Signer CVC with a CVC organization name = Co signer name and
a Co Signer cvcAccessStart > Co signer CVC validity start time.
...."

It means that docsBpi2CodeCoSignerCvcAccessStart, and 
docsBpi2CodeCoSignerOrgName should be retained,
so it will be possible to check if the new 
co-signer CVC's validity start time > cvcAccessStart.

How does it fit with:
"If the Co-signer is not specified and co-signing is not required,
the CM need not to retain these values at all. Therefore, how about
to add "If docsBpi2CodeCoSignerOrgName is zero length string, the
value of this object is meaningless" or something like this...."

Thanks,
libi.
-----------------------------------------
Libi Hertzberg, Cable Modem Group
TI Cable Broadband Communications
E-mail: [email-masked]
Tel: +972-9-9706553 Fax: +972-9-9706500
-----------------------------------------

-----Original Message-----
From: Kaz Ozawa [mailto:[email-masked]]
Sent: Tuesday, October 17, 2000 12:33 AM
To: DOCSIS OSS Mailing List; IETF Ipcdn
Cc: DOCSIS Security Mailing List
Subject: BPI+ MIB Object related to Code Download

All,

Thanks,
kaz