Subject: RE: [ipcdn] DOCS-CABLE-DEVICE-TRAP-MIB DEFINITIONS

From: "Pirozzi, Timothy (Max Power)" <[email-masked]>
Date: Thu, 1 Mar 2001 07:27:35 -0500

Hi Kirk,

If I could obtain the IP and MAC from the DHCP server
via SNMP then that would be great. But I haven't found
any standard MIBs like that or any proprietary MIBs.
I know for a fact that right now ISPs and the like are
having to dump a file from their DHCP server with MAC 
and IP information and repopulate their NMS every 
morning with that information. If the information
is not available via SNMP then it is not a practical
solution. 
That's why I am trying to champion this request. Now
maybe the solution is the DHCP server I'm not saying it 
isn't. But it seems some vendors are already implementing
proprietary versions of such a trap. I think it would be
better for this working group to define a standard trap
or table of some sort for all to follow. 

Thanks

Tim 

>-----Original Message-----
>From: Kirk Friedman [mailto:[email-masked]]
>Sent: Wednesday, February 28, 2001 10:07 PM
>To: 'Daniel Hegglin'; [email-masked]; Pirozzi, Timothy (Max Power)
>Cc: [email-masked]
>Subject: RE: [ipcdn] DOCS-CABLE-DEVICE-TRAP-MIB DEFINITIONS
>
>
>Hi Dan,
>
>      In answer to your comments below, yes a CMTS could use 
>the IP address 
>from registration.  And if the IP address on the CM is changed 
>how would 
>that be evident to the CMTS w/out DHCP snooping?  Also, as you 
>said, it is 
>not a required TLV.
>
>     Again, traps can be lost between the CMTS and the NMS.  
>How would the 
>NMS know if a IP address to CM address association had been 
>lost if the 
>trap never arrived?  If the CMTS keeps a trap table, then this 
>is also a 
>new requirement and you run into issues of how big the table might get 
>after a power outage at the CMTS or CM side with large numbers of 
>registrations, how often does the management system check the 
>table, what 
>to do about those traps that never made it  (table continues to grow 
>because entries aren't deleted)?
>
>     I still feel that the best solution is at the source that 
>is granting 
>the IP addresses, the DHCP server.  It knows the CM mac 
>address, the CM IP 
>address, can distinguish between CM and CPE IP addresses and 
>knows that a 
>CM has actually done a REQUEST on the offered IP address.
>
>Kirk Friedman
>Correlant Communications (formerly TurboNet Communications)
>15110 Avenue Of Science
>San Diego, CA., 92128-3405
>Ph:   858-451-1061 x105
>Fax: 858-451-1061 x1775
>[email-masked]
>
>
>-----Original Message-----
>From:	Daniel Hegglin [SMTP:[email-masked]]
>Sent:	Wednesday, February 28, 2001 3:32 PM
>To:	Kirk Friedman; [email-masked]; Pirozzi, Timothy (Max Power)
>Cc:	[email-masked]
>Subject:	RE: [ipcdn] DOCS-CABLE-DEVICE-TRAP-MIB DEFINITIONS
>
>Hi,
>
>I might as well jump in here.  I'm not advocating that the 
>CMTS should be
>required to send traps on behalf of the CMs, but it would not be very
>difficult to implement.
>
>> I don't agree that a CMTS should send these traps on behalf of a
>> CM.  This
>> was discussed as a possibility in the DOCSIS Account
>> Management/OSS meeting
>> last year ( August 25 ) and rejected.  The only way I am 
>aware of for a
>> CMTS to really keep up with the CMs IP address is to keep track
>> of the DHCP
>> Acknowledgement from the DHCP server to the CM.   The DHCP
>> acknowledgments
>> have to be used because there could be multiple DHCP servers 
>sending DHCP
>> offers to a CM.  A bridging CMTS is not directly involved 
>with layer 3
>> traffic and requiring it to snoop and keep track of this in 
>order to send
>> traps to the CMTS was deemed too burdensome.
>
>A CMTS could use the IP address sent in the CM registration 
>message.  This
>is currently not a required field, but almost all modem 
>vendors send this
>information upstream.
>
>> The second reason that you would not want the CMTS, or even the
>> CM, to send
>> the trap was because the trap could be lost.  A discussion of
>> using INFORM
>> Trap type ( requires confirmation ) could eliminate the lost trap
>> issue but
>> that also lead to another discussion of what to do if the 
>INFORM is not
>> acknowledged and it also requires the CMTS (or CM) to keep a
>> state machine
>> going for the INFORM until its acknowledged.
>
>Regular traps should be fine as long as the traps are logged in a trap
>table.  A management station can destroy the row after reading 
>the data so
>the table doesn't get too big.
>
>dan
>
>
>Daniel Hegglin
>Riverstone Networks
>5200 Great America Parkway
>Santa Clara, CA  95054
>(408) 878-6526 - work
>http://www.riverstonenet.com/
>

_______________________________________________
IPCDN mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Kirk Friedman <[email-masked]>
Date: Wed, 28 Feb 2001 19:06:50 -0800

Hi Dan,

      In answer to your comments below, yes a CMTS could use the IP address 
from registration.  And if the IP address on the CM is changed how would 
that be evident to the CMTS w/out DHCP snooping?  Also, as you said, it is 
not a required TLV.

     Again, traps can be lost between the CMTS and the NMS.  How would the 
NMS know if a IP address to CM address association had been lost if the 
trap never arrived?  If the CMTS keeps a trap table, then this is also a 
new requirement and you run into issues of how big the table might get 
after a power outage at the CMTS or CM side with large numbers of 
registrations, how often does the management system check the table, what 
to do about those traps that never made it  (table continues to grow 
because entries aren't deleted)?

     I still feel that the best solution is at the source that is granting 
the IP addresses, the DHCP server.  It knows the CM mac address, the CM IP 
address, can distinguish between CM and CPE IP addresses and knows that a 
CM has actually done a REQUEST on the offered IP address.

Kirk Friedman

-----Original Message-----
From:	Daniel Hegglin [SMTP:[email-masked]]
Sent:	Wednesday, February 28, 2001 3:32 PM
To:	Kirk Friedman; [email-masked]; Pirozzi, Timothy (Max Power)
Cc:	[email-masked]
Subject:	RE: [ipcdn] DOCS-CABLE-DEVICE-TRAP-MIB DEFINITIONS

Hi,

I might as well jump in here.  I'm not advocating that the CMTS should be
required to send traps on behalf of the CMs, but it would not be very
difficult to implement.

> last year ( August 25 ) and rejected.  The only way I am aware of for a
> have to be used because there could be multiple DHCP servers sending DHCP
> offers to a CM.  A bridging CMTS is not directly involved with layer 3
> traffic and requiring it to snoop and keep track of this in order to send

A CMTS could use the IP address sent in the CM registration message.  This
is currently not a required field, but almost all modem vendors send this
information upstream.

> that also lead to another discussion of what to do if the INFORM is not

Regular traps should be fine as long as the traps are logged in a trap
table.  A management station can destroy the row after reading the data so
the table doesn't get too big.

dan

Daniel Hegglin
Riverstone Networks

---

From: "Pirozzi, Timothy (Max Power)" <[email-masked]>
Date: Thu, 1 Mar 2001 11:56:41 -0500

Hi Kirk

It was just brought to my attention there is a draft mib
in progress from the dhc working droup. It will have the 
information availible to Inform a VNM about IP changes. 
My only concern that there was a source availible to 
extract this information via SNMP. I would like to dismiss
my request for the two traps.

Thanks Everyone.
Thanks Kirk.

Tim

>From: Pirozzi, Timothy (Max Power) [mailto:[email-masked]]
>Sent: Thursday, March 01, 2001 7:28 AM
>To: 'Kirk Friedman'
>Cc: [email-masked]