Subject: RE: [ipcdn] Membership Query Interval in Passive mode IGMP

From: "Nakanishi Greg (SD-EX)" <[email-masked]>
Date: Fri, 28 Jun 2002 10:59:21 -0400

Shrini,

I think the scenario you mention should be a transient condition.  Once the
router comes up and issues a couple of MQs, the MQI will be "correct" again.

greg

> -----Original Message-----
> From: Shrinivas Samant [mailto:[email-masked]]
> Sent: Thursday, July 25, 2002 7:32 AM
> To: IETF Ipcdn
> Subject: [ipcdn] Membership Query Interval in Passive mode IGMP
> 
> 
> Folks,
> In the passive mode IGMP, the CMTS determines the Membership 
> Query Interval
> by looking at the inter-arrival times of the Membership Query 
> messages.
> Formally: If n<2, MQI = 125 else MQI = MAX(125, MQn - MQn-1) 
> where MQI is
> the Membership Query Interval in seconds, n is the number of 
> Membership
> Queries seen and MQn is the epoch time at which the nth 
> Membership Query was
> seen.
> 
> Now, if the Router goes down after MQn-1 and comes up again 
> after sometime,
> MQn - MQn-1, is not an accurately determined Membership Query 
> Interval.
> 
> Is there an upper limit on the value of MQI? How can we 
> establish the MQI in
> such a scenario?
> Any suggestions/comments will help.
> 
> Thanks,
> 
> Shrini
> 
> 
> _______________________________________________
> IPCDN mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipcdn
> 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Nakanishi Greg (SD-EX)" <[email-masked]>
Date: Fri, 28 Jun 2002 10:59:21 -0400

Shrini,

greg