Subject: [ipcdn] DEFVAL Clause

From: "Eugene Nechamkin" <[email-masked]>
Date: Thu, 3 Apr 2003 13:51:17 -0800

While reviewing the PacketCable MTA MIB IETF draft, there was a discssion of
the DEFVAL Clause. As SMIv2 states:

It is also permitted to use it for scalar objects dynamically created by an
agent, or for columnar objects of a read-write table dynamically created by
an agent. 

it's permitted to use DEFVAL clause for dynamic scalar MIB objects. In many
occasions, there is a need to be able to define default values for the
static scalar objects also. I do not seem to be able to find any explicit
permissions or prohibitions on doing that.

Any pointers in this direction will be appreciated.

Thanks,

Eugene.

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Woundy, Richard" <[email-masked]>
Date: Fri, 4 Apr 2003 07:12:19 -0700

Eugene,

I forwarded your email question to a MIB doctor, that has previously relayed
your question to other MIB doctors at last month's IETF meeting in San
Francisco (but had forgotten to get back to me). Here is his reply:

>Ahhh, yes -- I did ask about that. They could not see any reason that
>you could not or should not use a DEFVAL on a scalar. Go for it!

So I stand corrected!

-- Rich

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Thursday, April 03, 2003 4:51 PM
To: IPCDN WG (E-mail)
Subject: [ipcdn] DEFVAL Clause

Thanks,

Eugene.

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Fri, 4 Apr 2003 09:09:20 -0800

Rich,

We are using DEFVAL clause in numerous occasions in the PacketCable MIBs, so
this is really helpful.

Thanks for the clarification.

Eugene.

-----Original Message-----
From: Woundy, Richard [mailto:[email-masked]]
Sent: Friday, April 04, 2003 6:12 AM
To: Eugene Nechamkin
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] DEFVAL Clause

Eugene,

So I stand corrected!

-- Rich

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Thursday, April 03, 2003 4:51 PM
To: IPCDN WG (E-mail)
Subject: [ipcdn] DEFVAL Clause

Thanks,

Eugene.