Subject: [ipcdn] MTA MIB comment

From: "Kumar, Satish" <[email-masked]>
Date: Mon, 14 Jul 2003 20:15:38 +0530

Rich, 
 I did MTA MIB review and found some issue. Please add this to your review
list comments in IETF.

pktcMtaDevRealmUnsolicitedKeyMaxTimeout Def Value: 30 seconds
pktcMtaDevRealmUnsolicitedKeyNomTimeout Def value: 10000 milli sec
pktcMtaDevRealmUnsolicitedKeyMaxRetries Def value: 5 

As per the above default values MTA exhaust the def values in 3 retries, But
we need to either change the max timeout to 50 seconds or max retries to 3
or reduce the NomTimeout to 5000 milli sec. I am in favour of later change
like..changing the NomTimeout to 5000msec, so that MTA will retry if it
doesn't get AS reply in 5 seconds.

Thanks, 
Satish Kumar
Texas Instruments

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Woundy, Richard" <[email-masked]>
Date: Mon, 14 Jul 2003 11:31:39 -0600

Satish,

I assume that we want:

(MaxTimeout Default) == (NomTimeout Default) * (MaxRetries Default)

So shouldn't we reduce the NomTimeout to 6000 milliseconds instead of 5000
milliseconds, since 

(30 seconds) = (6000 milliseconds) * (5 retries)?

I must have also miscalculated this value relationship in our private email
earlier. Sorry about that.

I added your original comment to the PacketCable MTA MIB considerations at
<http://www.ipcdn.org/ipcdn-ids.html>.

-- Rich

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:46 AM
To: Ipcdn (E-mail); Woundy, Richard
Cc: Jean-Francois Mule
Subject: [ipcdn] MTA MIB comment

Rich, 

Thanks, 
Satish Kumar
Texas Instruments

---

From: "Kumar, Satish" <[email-masked]>
Date: Mon, 14 Jul 2003 23:05:36 +0530

Rich,
 Your caluclation is correct, and we need to change  Nomtimeout default
value to 6000msec.
-Satish

-----Original Message-----
From: Woundy, Richard [mailto:[email-masked]]
Sent: Monday, July 14, 2003 5:32 PM
To: Kumar, Satish
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

I assume that we want:

-- Rich

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:46 AM
To: Ipcdn (E-mail); Woundy, Richard
Cc: Jean-Francois Mule
Subject: [ipcdn] MTA MIB comment

Rich, 

Thanks, 
Satish Kumar
Texas Instruments

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 14 Jul 2003 10:59:32 -0700

Satish,

I am not sure if we want to have this sort of restrictive relationship between these three MIB Objects, at least this was not the intention in Security backoff and Retry and similarly in NCS backoff and Retry algorithms.

With the currently existing Default values, MTA will go through the following sequence of retries and exponential timeouts (I have used exponential factor of "2" as an example, but in any case, it should be greater than 1):

Attemp#         Timeout (sec)
================================
1               10
2               2 * 10 = 20 (< 30, so TO=20)
3               2 * 20 = 40 (> 30, so TO=30)
4               2 * 30 = 60 (> 30, so TO=30)
5               2 * 30 = 60 (> 30, so TO=30)

So, all 5 "pktcMtaDevRealmUnsolicitedKeyMaxRetries" will be exhausted, and MTA will give up after 5 retries without exceedeing the MAX timeout value of 30 secs as requred by the MIB objects.

Currently existing MTA MIB does not imply existence of any sort of relationship between these three MIB Objects, and I don't think we need to change anything in default values especially if such a change would hint to the existance of any form of formular dependencies.

Eugene.

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:36 AM
To: 'Woundy, Richard'
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Rich,

-----Original Message-----
From: Woundy, Richard [mailto:[email-masked]]
Sent: Monday, July 14, 2003 5:32 PM
To: Kumar, Satish
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

I assume that we want:

-- Rich

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:46 AM
To: Ipcdn (E-mail); Woundy, Richard
Cc: Jean-Francois Mule
Subject: [ipcdn] MTA MIB comment

Rich, 

Thanks, 
Satish Kumar
Texas Instruments

---

From: "Kumar, Satish" <[email-masked]>
Date: Tue, 15 Jul 2003 04:15:18 +0530

Eugene,
 All the three MIBs(under discussion) are inter related, and was the
intention earlier too. The exponential behavior seen with AP req/rep
scenario doesn't have this issue.  In your example MTA retries thrice at 30,
which doesn't sound like exponential.
  
I think we have to change the default value suitably for
pktcMtaDevRealmUnsolicitedKeyMaxTimeout and
pktcMtaDevRealmUnsolicitedKeyNomTimeout to follow exponential scenario. 

-Satish

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Monday, July 14, 2003 6:00 PM
To: Kumar, Satish; Woundy, Richard
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

I am not sure if we want to have this sort of restrictive relationship
between these three MIB Objects, at least this was not the intention in
Security backoff and Retry and similarly in NCS backoff and Retry
algorithms.

With the currently existing Default values, MTA will go through the
following sequence of retries and exponential timeouts (I have used
exponential factor of "2" as an example, but in any case, it should be
greater than 1):

Attemp#         Timeout (sec)

So, all 5 "pktcMtaDevRealmUnsolicitedKeyMaxRetries" will be exhausted, and
MTA will give up after 5 retries without exceedeing the MAX timeout value of
30 secs as requred by the MIB objects.

Currently existing MTA MIB does not imply existence of any sort of
relationship between these three MIB Objects, and I don't think we need to
change anything in default values especially if such a change would hint to
the existance of any form of formular dependencies.

Eugene.

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:36 AM
To: 'Woundy, Richard'
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Rich,

-----Original Message-----
From: Woundy, Richard [mailto:[email-masked]]
Sent: Monday, July 14, 2003 5:32 PM
To: Kumar, Satish
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

I assume that we want:

-- Rich

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:46 AM
To: Ipcdn (E-mail); Woundy, Richard
Cc: Jean-Francois Mule
Subject: [ipcdn] MTA MIB comment

Rich, 

Thanks, 
Satish Kumar
Texas Instruments

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 14 Jul 2003 16:48:40 -0700

Satish,

> All the three MIBs(under discussion) are inter related, 

I disagree. Neither Prov Spec, nor Security Spec, nor MTA MIB do not seem to currently suggest that there is (or there even should be) any dependences between these three MTA MIB objects. All PC Specs seem to be in agreement that such dependances should not be neccessary. Besides, if you take a look at the backoff and retry in NCS, then its exponential behavior looks very close to what I described in my hypothetical example. 

> The exponential behavior seen with AP req/rep

The fact that the max value of the timeout is restricted from the top, does not mean that exponential calcualtion has not been used. The existence of a combination of the default values such that the result of the exponential calcualtions will not "sound like exponential", to my opinion, does not grant the need to introduce the dependencies between MIB Objects.

Without arguing with your point, I'd suggest to have some more discussions on the PC Prov Reflector and then submit neccesasry changes to IPCDN WG (if needed).

Thanks,

Eugene.

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 3:45 PM
To: Eugene Nechamkin; Woundy, Richard
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Eugene,

-Satish

-----Original Message-----
From: Eugene Nechamkin [mailto:[email-masked]]
Sent: Monday, July 14, 2003 6:00 PM
To: Kumar, Satish; Woundy, Richard
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

Attemp#         Timeout (sec)

Eugene.

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:36 AM
To: 'Woundy, Richard'
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Rich,

-----Original Message-----
From: Woundy, Richard [mailto:[email-masked]]
Sent: Monday, July 14, 2003 5:32 PM
To: Kumar, Satish
Cc: IPCDN WG (E-mail)
Subject: RE: [ipcdn] MTA MIB comment

Satish,

I assume that we want:

-- Rich

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, July 14, 2003 10:46 AM
To: Ipcdn (E-mail); Woundy, Richard
Cc: Jean-Francois Mule
Subject: [ipcdn] MTA MIB comment

Rich, 

Thanks, 
Satish Kumar
Texas Instruments