Subject: [ipcdn] RE: Question on on IETF Signaling MIB

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Tue, 5 Aug 2003 12:59:30 -0700

Satish,

There are a couple of differences, but these are both ring splash objects:

pktcSigDevRsCadence:

-object is in the mandatory sig group (requires implementation by all MTAs)
-shorter duration (max duration is 6 sec)
-coarse resolution (each bit represents a duration of 100 ms)

pktcSigDevRingSplashCadence:

-object is in the international group only
-longer duration (max duration is 10.8 sec)
-finer resolution (each bit represents a duration of 50 ms)

The later object is required for International caller ID support both in terms of duration and resolution. Take a look at 300 659-1 for more on CID. Unfortunately, I don't have any history on the pktcSigDevRsCadence object.

Comments?

Gordon 

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Thursday, July 31, 2003 4:19 PM
To: 'Beacham Gordon-CGB005'
Cc: [email-masked]
Subject: Question on on IETF Signaling MIB

Gordon,
 In signaling MIB I can see TWO identical MIBS pktcSigDevRsCadence and
pktcSigDevRingSplashCadence

How does these TWO differ? Please throw some light on this.  For me both
looks same and doing same functionality!

Thanks,
Satish Kumar
Texas Instruments
=====
pktcSigDevRsCadence     OBJECT-TYPE  
       SYNTAX       PktcRingCadence  
       MAX-ACCESS   read-write  
       STATUS       current  
       DESCRIPTION  
           " This object specifies ring cadence rs (a user defined 
             field) where each bit represents a duration of 100 
             milliseconds (6 seconds total), except the LSB 4 bits 
             which are used to represent repeatable characteristics. 
             The MTA MUST reject any attempt to make this object 
             repeatable." 
       DEFVAL {{ interval1, interval2, interval3, interval4, interval5,  
                 repeat1 }} 
       -- 11111000000000000000000000000000000000000000000000000000000 
       -- 01000 
       ::= { pktcSigDevConfigObjects 22 }  

pktcSigDevRingSplashCadence    OBJECT-TYPE  
       SYNTAX       OCTET STRING (SIZE(2..28))  
       MAX-ACCESS   read-write  
       STATUS       current  
       DESCRIPTION  
           " This is the Ring Cadence Octet String for splash ring. The 
             first octet of the bit string represents the length in 
             bits of the duration of the cadence. Each Bit after the 
             first octet represents 50 ms and 1 represents ring and 0 
             represents silent. The first bit of the second octet is 
             the first bit of the ring cadence. Only 216 Bits can be 
             set total to represent 10800 ms of total cadence cycle."  
       ::= { pktcSigDevConfigObjects  34 } 
=======

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Kumar, Satish" <[email-masked]>
Date: Wed, 6 Aug 2003 02:06:26 +0530

Gordon,
 I understand the technical difference. My question is why do we need to
have TWO ring splash objects?? When both are implemented on MTA, how can MTA
know its physical presence(that whether it is in US zone or in international
zone). I feel we need to retain only one Ringsplash.

Thanks,
SatishK

-----Original Message-----
From: Beacham Gordon-CGB005 [mailto:[email-masked]]
Sent: Tuesday, August 05, 2003 8:00 PM
To: Kumar, Satish
Cc: [email-masked]
Subject: RE: Question on on IETF Signaling MIB

Satish,

pktcSigDevRsCadence:

The later object is required for International caller ID support both in
terms of duration and resolution. Take a look at 300 659-1 for more on CID.
Unfortunately, I don't have any history on the pktcSigDevRsCadence object.

Comments?

Gordon 

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Thursday, July 31, 2003 4:19 PM
To: 'Beacham Gordon-CGB005'
Cc: [email-masked]
Subject: Question on on IETF Signaling MIB

Gordon,

Thanks,
Satish Kumar
Texas Instruments
=====

---

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Tue, 5 Aug 2003 13:45:23 -0700

Satish,

The approach with the original Sig MIB was to define a series of objects suitable for the NA and International markets. Some vendors may not want to produce MTAs for the International market. The thought was not to force all MTAs to implement International objects. This is why there is a duplication of some objects such as ring splash. 

What is your proposal? Do you want to delete these duplicate objects (RsCadence, RgCadence, and perhaps more)? Do you want to combine all the R0-R5 cadences as well into one 128 row table that is large enough to handle all International ring cadences? 

Gordon

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Tuesday, August 05, 2003 1:36 PM
To: 'Beacham Gordon-CGB005'
Cc: [email-masked]
Subject: RE: Question on on IETF Signaling MIB

Gordon,

Thanks,
SatishK

-----Original Message-----
From: Beacham Gordon-CGB005 [mailto:[email-masked]]
Sent: Tuesday, August 05, 2003 8:00 PM
To: Kumar, Satish
Cc: [email-masked]
Subject: RE: Question on on IETF Signaling MIB

Satish,

pktcSigDevRsCadence:

Comments?

Gordon 

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Thursday, July 31, 2003 4:19 PM
To: 'Beacham Gordon-CGB005'
Cc: [email-masked]
Subject: Question on on IETF Signaling MIB

Gordon,

Thanks,
Satish Kumar
Texas Instruments
=====