Subject: [ipcdn] RE: [Bridge-mib] VlanID and VlanIDOrAny

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 15 Sep 2003 22:56:31 +0200

So you believe that InterfaceIndexOrZero is bad?
Oh well...

Anyway, for the one for IPCDN, we can probably do ...OrNone
and specify that zero means NONE.

Thanks,
Bert 

> -----Original Message-----
> From: Andrew Smith [mailto:[email-masked]]
> Sent: maandag 15 september 2003 21:24
> To: 'Wijnen, Bert (Bert)'
> Cc: 'Ipcdn (E-mail)'
> Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny
> 
> 
> Yes but "quite common" does not necessarily mean "good". 
> 
> In this case, I fail to see the point of defining the TC - I 
> would argue
> that it actually provides negative benefit since it gives the illusion
> that the semantics are identical for all places where the TC is used
> when, in fact, they are not.
> 
> And, as I wrote below, any TC whose name ends "...OrZero" is 
> suspect, in
> my opinion. "...OrNone" is much more helpful.
> 
> Andrew
> 
> 
> -----Original Message-----
> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Sunday, September 14, 2003 3:59 AM
> To: 'Murwin William-LWM008 '
> Cc: 'Andrew Smith '; Wijnen, Bert (Bert); 'Ipcdn (E-mail)'
> Subject: FW: [Bridge-mib] VlanID and VlanIDOrAny
> 
> 
> Some (good) feedback on the use of VLANID.
> Can we get some answers and or discussion on this?
> 
> Andrew, allowing users of a TC to spcify what one specific 
> value means is quite common, specifically for TCs that
> end in xxxOrZero or xxxOrNone, pls see the many TCs
> we have defined that way.
> 
> Thanks,
> Bert 
> 
> -----Original Message-----
> From: Andrew Smith [mailto:[email-masked]]
> Sent: zondag 7 september 2003 22:40
> To: 'Wijnen, Bert (Bert)'; 'Bridge-Mib (E-mail)'
> Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny
> 
> 
> Bert,
> 
> It seems pointless to me to define a TC where any module that uses it
> MUST (or even MAY) add special semantics to one or more of the values.
> Why then bother defining the TC at all? We should either 
> define what the
> special "none" value is, including its semantics, in the TC definition
> or else not define any such TC. I also don't think that the name
> "...OrZero" is very helpful: the name should give a hint as to the
> semantics, not the syntax, even for a TC name.
> 
> N.B. if what IPCDN wants to do is identify the 
> "priority-tagged" frames
> permitted by 802.1D/802.1Q (that is frames that carry user_priority
> information but no relevant VLAN information) then that should be
> handled in one of 2 ways: (a) add 0 as a valid value for VlanId or
> VlanIdOrAny or (b) define separate VlanIdOrPriorityOnly and/or
> VlanIdOrAnyOrPriorityOnly TCs with ranges (0 | 1..4094) and/or (0 |
> 1..4094 | 4095) respectively [but I thought in the bridge-mib list
> discussions previously, we'd decided that there was no requirement for
> the priority-tagged semantics, no?].
> 
> Andrew
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Wijnen, Bert (Bert)
> Sent: Sunday, September 07, 2003 11:14 AM
> To: 'Romascanu, Dan (Dan)'; Bridge-Mib (E-mail)
> Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny
> 
> 
> Not sure if they need it or not, but it would be to
> indicate "wildcard", not "none"
> 
> Thanks,
> Bert 
> 
> > -----Original Message-----
> > From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> > Sent: zondag 7 september 2003 10:55
> > To: Wijnen, Bert (Bert); Bridge-Mib (E-mail)
> > Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny
> > 
> > 
> > So, I guess that the IPCDN people do not need 4095. 
> > 
> > Otherwise, it looks OK to me. 
> > 
> > Dan
> > 
> > 
> > > -----Original Message-----
> > > From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> > > Sent: 07 September, 2003 10:29 AM
> > > To: Bridge-Mib (E-mail)
> > > Subject: FW: [Bridge-mib] VlanID and VlanIDOrAny
> > > 
> > > 
> > > It seems that in IPCDN, some people would like
> > > to see yet another TC, namely:
> > > 
> > >     VlanIdOrZero      ::= TEXTUAL CONVENTION
> > >         DISPLAY-HINT "d"
> > >         STATUS        current
> > >         DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
> > > 
> > >                       The value zero is NOT a valid VLAN ID. 
> > >                       
> > >                       When this textual convention is used as the
> > >                       syntax of an object, the object definition
> > >                       MUST specify in the DESCRIPTION clause what
> > >                       the value zero means.
> > >                      "
> > >         SYNTAX        Integer32 (0 | 1..4094)
> > > 
> > > Does anyone see a problem with that?
> > > 
> > > Thanks,
> > > Bert 
> > > 
> > > -----Original Message-----
> > > From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> > > Sent: vrijdag 5 september 2003 0:48
> > > To: Bridge-Mib (E-mail)
> > > Subject: [Bridge-mib] VlanID and VlanIDOrAny
> > > 
> > > 
> > > So... nobody has reacted to my request for
> > > writeup. So I am preparing to do an ID myself.
> > > 
> > > This is what I think the discussion boiled down to.
> > > 
> > >     VlanId            ::= TEXTUAL CONVENTION
> > >         DISPLAY-HINT "d"
> > >         STATUS        current
> > >         DESCRIPTION  "The VLAN ID that uniquely 
> identifies a VLAN."
> > >         SYNTAX        Integer32 (1..4094)
> > > 
> > > 
> > >     VlanIdOrAny       ::= TEXTUAL CONVENTION
> > >         DISPLAY-HINT "d"
> > >         STATUS        current
> > >         DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
> > >                       The value of 4095 is used to indicate a 
> > > wildcard,
> > >                       i.e. any value.
> > >                      "
> > >         SYNTAX        Integer32 (1..4094 | 4095)
> > > 
> > > Any comments?
> > > 
> > > Bert
> > > 
> > > _______________________________________________
> > > Bridge-mib mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/bridge-mib
> > > 
> > > _______________________________________________
> > > Bridge-mib mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/bridge-mib
> > > 
> > 
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
> 
> 
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
> 
> 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Andrew Smith" <[email-masked]>
Date: Mon, 15 Sep 2003 12:24:13 -0700

In this case, I fail to see the point of defining the TC - I would argue
that it actually provides negative benefit since it gives the illusion
that the semantics are identical for all places where the TC is used
when, in fact, they are not.

And, as I wrote below, any TC whose name ends "...OrZero" is suspect, in
my opinion. "...OrNone" is much more helpful.

Andrew

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Sunday, September 14, 2003 3:59 AM
To: 'Murwin William-LWM008 '
Cc: 'Andrew Smith '; Wijnen, Bert (Bert); 'Ipcdn (E-mail)'
Subject: FW: [Bridge-mib] VlanID and VlanIDOrAny

Thanks,
Bert 

-----Original Message-----
From: Andrew Smith [mailto:[email-masked]]
Sent: zondag 7 september 2003 22:40
To: 'Wijnen, Bert (Bert)'; 'Bridge-Mib (E-mail)'
Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny

Bert,

Why then bother defining the TC at all? We should either define what the

N.B. if what IPCDN wants to do is identify the "priority-tagged" frames

Andrew

-----Original Message-----

Thanks,
Bert 

> >         DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN."

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 8 Sep 2003 15:06:09 +0200

Thanks,
Bert 

-----Original Message-----
From: Andrew Smith [mailto:[email-masked]]
Sent: zondag 7 september 2003 22:40
To: 'Wijnen, Bert (Bert)'; 'Bridge-Mib (E-mail)'
Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny

Bert,

Andrew

-----Original Message-----

Thanks,
Bert