Subject: [ipcdn] Suggestions for Signaling MIB Changes

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Wed, 24 Sep 2003 10:33:53 -0700

fyi, I received the following suggestions for changes off the reflector that I wanted to share with the IPCDN community. I will be examining these proposed changes today. Feel free to comment.

Gordon

>From Broadcom:
Gordon, 
The following are comments to draft-02 candidate: 
1. pktcSigEndPntCapabilityIndex MIB Object has a refernce to the "pktcSigCapablityTable" in description whereas the "pktcSigCapablityTable" does not exist in the SIG MIB. I think the "pktcSigEndPntConfigTable" should be eliminated . 
2. The following object seems to be required and is currently missing: 
pktcSigDevCIDFskAfterRPAS 
SYNTAX Unsigned32 (0..1000) 
UNITS "Milliseconds" 
MAX-ACCESS read-write 
STATUS current 
DESCRIPTION 
" This object is used for ETSI systems only. This object 
specifies the delay between the end of the Ring Pulse Alert 
Signal (RP-AS) and the start of the transmission of the 
FSK containing the Caller ID information. This object is 
only used when pktcSigDevCIDMode is rpAsETS. 
pktcSigDevCIDMode pktcSigDevCIDFskAfterDTAS 
duringringingETS 0 ms (not used) 
dtAsETS 0 ms (not used)
rpAsETS 650 ms 
lrAsETS 0 ms (not used)" 
REFERENCE 
" Refer to the ETS 300 659-1 Specification." 
::= { pktcSigPulseSignalEntry ??? } 
3. "pktcSigDevCIDMode" MIB Object currently refers only to on-hook caller-ID. We do not not have the corresponding object to select the off-hook caller-id method. Proposal is to use a set of the new objects for off-hook params: 
pktcSigDevVmwiMode OBJECT-TYPE 
SYNTAX INTEGER {
dtAsETS(1),
rpAsETS(2),
lrAsETS(3)
}
MAX-ACCESS read-write
STATUS current 
DESCRIPTION 
" This object is used for ETSI systems only. For visual message
waiting indicator (VMWI), pktcSigDevVmwiMode selects the alerting signal method. 
For the dtAsETS, rpAsETS, and lrAsETS
methods, the FSK containing the VMWI information is
sent after an alerting signal. For the dtAsETS
method, the FSK is sent after the Dual Tone Alert Signal.
For the rpAsETS method, the FSK is sent after a Ring
Pulse. For the lrAsETS method, the Line Reversal occurs
first, then the Dual Tone Alert Signal, and finally the
FSK is sent."
DEFVAL { dtAsETS } 
::= {pktcSigDevConfigObjects ??? } 
pktcSigDevVmwiFskAfterDTAS OBJECT-TYPE 
SYNTAX Unsigned32 (0..500) 
UNITS "Milliseconds" 
MAX-ACCESS read-write 
STATUS current 
DESCRIPTION 
" This object is used for ETSI systems only. This object 
specifies the delay between the end of the Dual Tone Alert 
Signal (DT-AS) and the start of the transmission of the 
FSK containing the VMWI information. This object is 
only used when pktcSigDevVMWIMode is dtAsETS or lrAsETS. 
pktcSigDevVMWIMode pktcSigDevVMWIFskAfterDTAS 
dtAsETS 50 ms 
rpAsETS 0 ms (not used) 
lrAsETS 50 ms" 
REFERENCE 
" Refer to the ETS 300 659-1 Specification." 
DEFVAL { 50 } 
::= {pktcSigDevConfigObjects ?? } 
pktcSigDevVmwiFskAfterRPAS OBJECT-TYPE 
SYNTAX Unsigned32 (0..800) 
UNITS "Milliseconds" 
MAX-ACCESS read-write 
STATUS current 
DESCRIPTION 
" This object is used for ETSI systems only. This object 
specifies the delay between the end of the Ring Pulse Alert 
Signal (RP-AS) and the start of the transmission of the 
FSK containing the VMWI information. This object is 
only used when pktcSigDevVMWIMode is rpAsETS. 
pktcSigDevVMWIMode pktcSigDevVMWIFskAfterDTAS 
dtAsETS 0 ms (not used)
rpAsETS 650 ms 
lrAsETS 0 ms (not used)" 
REFERENCE 
" Refer to the ETS 300 659-1 Specification." 
DEFVAL { 50 } 
::= {pktcSigDevConfigObjects ??? } 
pktcSigDevVmwiDTASAfterLR OBJECT-TYPE 
SYNTAX Unsigned32 (0..655) 
UNITS "Milliseconds" 
MAX-ACCESS read-write 
STATUS current 
DESCRIPTION 
" This object is used for ETSI systems only. This object 
specifies the delay between the end of the Line Reversal 
and the start of the Dual Tone Alert Signal (DT-AS) for VMWI. This 
object is only used when pktcSigDevVMWIMode is lrAsETS. 
pktcSigDevVMWIMode pktcSigDevVMWIFskAfterLR 
dtAsETS 0 ms (not used) 
rpAsETS 0 ms (not used) 
lrAsETS 250 ms" 
REFERENCE 
" Refer to the ETS 300 659-1 Specification." 
DEFVAL { 250 } 
::= {pktcSigDevConfigObjects ??? } 
4. Clarification oin on "pktcSigDevToneFreqType" description for "allFrequenciesModulated" mode is required: 
It seems that it makes sense to have only two frequencies and also an implementor needs to know which frequency modulates which. The clarifying propasal looks as follows: 
allFrequenciesModulated indicates all frequencies
specified by pktcSigDevToneNumFrequencies are modulated to
form a single tone. The tone is then applied in sequence
using the number of on/off times specified in
pktcSigDevToneNumOnOffTimes. 
For this tone type pktcSigDevToneNumFrequencies MUST be equal 2, 
and the frequency in pktcSigDevToneFirstFrequency modulates the 
frequency in pktcSigDevToneSecondFrequency."
5. The following objects should be made "read-only" and configurable only from the MTA CFG File (because of the reasons similar to pktcSigPowerRingFrequency MIB Object): 
pktcNcsEndPntConfigMinHookFlash, 
pktcNcsEndPntConfigMaxHookFlash, 
pktcNcsEndPntConfigPulseDialInterDigitTime, 
pktcNcsEndPntConfigPulseDialMinMakeTime, 
pktcNcsEndPntConfigPulseDialMaxMakeTime, 
pktcNcsEndPntConfigPulseDialMinBreakTime, 
and pktcNcsEndPntConfigPulseDialMaxBreakTime 
Thanks, 
Eugene.

Gordon Beacham
Digital Core Gateways, BCS
Motorola, Inc.
858-404-2335
[email-masked]

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Harrie Hazewinkel <[email-masked]>
Date: Wed, 24 Sep 2003 23:30:43 +0200

On Wednesday, September 24, 2003, at 07:33 PM, Beacham Gordon-CGB005 
> duringringingETS 0 ms (not used)

Do I understand it correctly that you want to have a default value of
650 ms. But this value has only meaning if the pktcSigDevCIDMode
object has the value rpAsETS. What if the value is 650
and  the pktcSigDevCIDMode object is not set to the value rpAsETS??

If so use a DEF-VAL { 650 } and change the description accordingly.

> 3. "pktcSigDevCIDMode" MIB Object currently refers only to on-hook 
> caller-ID. We do not not have the corresponding object to select the 
> off-hook caller-id method. Proposal is to use a set of the new objects 
> for off-hook params:
> " This object is used for ETSI systems only.

I would say, "has only a meaning ful value in ...", but would
still first describe what the value is.

> " Refer to the ETS 300 659-1 Specification."

This DEFVAL does not seem to make sens, I guess you want 650.

Hope this helps,

Harrie