Subject: [ipcdn] draft-ietf-ipcdn-pktc-Sigmib-01.txt: MIB default values

From: "Kumar, Satish" <[email-masked]>
Date: Tue, 23 Sep 2003 03:44:39 +0530

Gordon,
 The description of the MIB "pktcSigPulseSignalType" and
"pktcSigPulseSignalDbLevel" clearly indicates a dependency. 
pktcSigPulseSignalType is a Read-Write object takes the values
intialRing(1), meterPulse(2), reversePolarity(3), noBattery(4). 

The description of the MIB  pktcSigPulseSignalDbLevel says, 
"This object only applies if pktcSigPulseSignalType =
meterPulse. This is the decibel level at which the meter
pulse could be generated. Example:
pktcSigPulseSignalType	pktcSigPulseSignalDbLevel
initialRing 				0 (not used)
meterPulse 				-135
reversePolarity 			0 (not used)
noBattery 				0 (not used)"

After the modem has come up, if the object "pktcSigPulseSignalType" is
dynamically SET to initialRing(1), should the MIB object
pktcSigPulseSignalDbLevel be automatically updated with a value of 0?

The other way round, if the pktcSigPulseSignalType=initialRing and suppose
operator SET the MIB pktcSigPulseSignalDbLevel to some value(say 100),
should the MTA reject this SET and store a value of 0? If this is not what
is expected, then, the MIB will be storing a value(the one performed by SET)
that is inconsistent with its description(0 unused). 

The following MIB's also have the same discrepancy mentioned above:
pktcSigPulseSignalFrequency
pktcSigDevCIDMode
pktcSigDevCIDFskAfterRing
pktcSigDevCIDFskAfterDTAS
pktcSigDevCIDRingAfterFSK
pktcSigDevCIDDTASAfterLR
pktcSigDevToneTable

Please clarify.

Thanks,
Satish Kumar
Texas Instruments

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Beacham Gordon-CGB005 <[email-masked]>
Date: Wed, 24 Sep 2003 10:28:02 -0700

Satish,

I'm sorry, I don't follow the issue here.

The description of the pktcSigPulseSignalDbLevel object clearly states the object only applies when pktcSigPulseSignalType is meterPulse(2). The description also states that intialRing(1) does not use pktcSigPulseSignalDbLevel.

I can remove "0" from the description example, and just leave the text "not used" if you prefer.

It seems to me it is an implementation issue as to whether the pktcSigPulseSignalDbLevel is automatically set to 0. I don't see why an implementation would even examine the pktcSigPulseSignalType unless pktcSigPulseSignalType = meterPulse.

I will look at the other objects you mentioned shortly. Thanks.

Gordon

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, September 22, 2003 3:15 PM
To: 'Beacham Gordon-CGB005'; Jean-Francois Mule
Cc: Ipcdn (E-mail); [email-masked]'
Subject: draft-ietf-ipcdn-pktc-Sigmib-01.txt: MIB default values

Gordon,

Please clarify.

Thanks,
Satish Kumar
Texas Instruments

---

From: "Kumar, Satish" <[email-masked]>
Date: Wed, 24 Sep 2003 23:17:54 +0530

Gordon,
 Thanks for the response. I suggest to remove the "0 ms" and "0" in couple
of the mibs mentioned in earlier mail. It is good just to leave the text
"not used" which avoids possible confusion.

Thanks,
Satish

-----Original Message-----
From: Beacham Gordon-CGB005 [mailto:[email-masked]]
Sent: Wednesday, September 24, 2003 5:28 PM
To: Kumar, Satish; Beacham Gordon-CGB005; Jean-Francois Mule
Cc: Ipcdn (E-mail); [email-masked]'
Subject: RE: draft-ietf-ipcdn-pktc-Sigmib-01.txt: MIB default values

Satish,

The description of the pktcSigPulseSignalDbLevel object clearly states the
object only applies when pktcSigPulseSignalType is meterPulse(2). The
description also states that intialRing(1) does not use
pktcSigPulseSignalDbLevel.

I can remove "0" from the description example, and just leave the text "not
used" if you prefer.

It seems to me it is an implementation issue as to whether the
pktcSigPulseSignalDbLevel is automatically set to 0. I don't see why an
implementation would even examine the pktcSigPulseSignalType unless
pktcSigPulseSignalType = meterPulse.

Gordon

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]]
Sent: Monday, September 22, 2003 3:15 PM
To: 'Beacham Gordon-CGB005'; Jean-Francois Mule
Cc: Ipcdn (E-mail); [email-masked]'
Subject: draft-ietf-ipcdn-pktc-Sigmib-01.txt: MIB default values

Gordon,

Please clarify.

Thanks,
Satish Kumar
Texas Instruments