Subject: [ipcdn] Comments on pktcSigEndPntConfigTable

From: "Eugene Nechamkin" <[email-masked]>
Date: Thu, 25 Sep 2003 14:43:24 -0700

Gordon,

I would like to clarify one issue I noticed in the current Signaling MIB draft. 

The "pktcSigEndPntConfigTable" now conists of two conceptual columns: "pktcSigEndPntCapabilityIndex" and "pktcSigEndPntConfigStatus". The "pktcSigEndPntCapabilityIndex" MIB Object has a reference to the "pktcSigCapablityTable" in DESCRIPTION clause, but the "pktcSigCapablityTable" does not exist in the SIG MIB. 
 
To resolve this inconsistency, there are two approaches: 1. delete the "pktcSigCapablityTable" from the MIB or 2. introduce the "pktcSigCapablityTable".

Looking at these options, I cannot see what is the purpose of the "pktcSigCapablityTable" at all. This table is described as "read-create" which means that backoffice can freely create and delete rows from the table. Having in mind that the table contains the reference to the signaling capability ("ncs" or "others") corresponding to each end-point, it seems that it's rather the responsility of the MTA to fill the table out and let the SNMP Manager to inspect the Signaling Capabilties (if needed). If this is the case, then the "pktcSigCapablityTable" must be revised and "pktcSigCapablityTable" shuold be added to the Signaling MIB to resolve the inconsistency.

On the other hand, if it is found that the intention of the "pktcSigCapablityTable" is not clearly stated, maybe it's worthwhile to delete it from the MIB for now.

I think the issue needs to be clarified before the draft-02 released.

Thanks,

Eugene.

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Thu, 25 Sep 2003 18:34:48 -0700

Gordon,

I have to withdraw my observation on the absense of the "pktcSigCapabilityTable". I was not able to find it in the Signaling MIB draft as the DESCRIPTION clause of the "pktcSigEndPntCapabilityIndex" MIB Object contains a typo in the name of the "pktcSigCapabilityTable", namely: "pktcSigCapablityTable". Based on that, please make the editorial modification in the DESCRIPTION clause of the "pktcSigEndPntCapabilityIndex" MIB Object: substitute "pktcSigCapablityTable" with "pktcSigCapabilityTable".

My comments on the necessity to clarify the intended usage of the "pktcSigCapablityTable" are still valid.

Thanks,

Eugene.

-----Original Message-----
From: Eugene Nechamkin 
Sent: Thursday, September 25, 2003 2:43 PM
To: Beacham Gordon-CGB005
Cc: Ipcdn (E-mail)
Subject: [ipcdn] Comments on pktcSigEndPntConfigTable

Gordon,

 

Thanks,

Eugene.