Subject: [ipcdn] Status of IPCDN RF MIBv2 and 3 open issues

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 1 Oct 2003 18:10:35 -0600

This note provides a status on the DOCSIS 2.0 RF MIB (aka rfmibv2).

In summary, 3 issues are still OPEN and the wg chairs would like to
have working group consensus by Friday October 10 on issues: #13, #14,
 #16. Eduardo Cardona of CableLabs has kindly accepted to help resolve
those and will be posting some text soon.

Please read this carefully and raise any concerns or objections to the
wg chairs on this action plan by Friday Oct 10.

 -- Rich Woundy and Jean-Francois Mule', ipcdn co-chairs.

--- Status of RF MIBv2
Internet-Draft Name: DOCSIS 2.0 RF MIB
                     draft-ietf-ipcdn-docs-rfmibv2-06.txt
ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipcdn-docs-rfmibv2-06.txt
soon to be
draft-ietf-ipcdn-docs-rfmibv2-07.txt

1) Follow-up on the IETF posting of rfmibv2-07
   The editor, David Raftus sent draft-07 to the internet-draft on
   9/9. The revision has not shown up yet. This is probably due to the
   fact that a zip file was attached instead of the plain text file.
   Action Item (AI): wg chair to follow up on posting.

2) Categorization of the remaining open issues
David Raftus sent a list of open issues to the ipcdn list on 9/12/03,
see attached file rfdraftv7_issues_Sept12_2003.txt
The remaining open issues not addressed in draft-07 split into 2
categories:
- a) issue is not required to be addressed ("nice to have")
  This category includes some of the improvements that were not in the
  original scope of rfmibv2. A lot of improvements has been done and
  it is time to freeze rfmibv2.
- b) issue that should be addressed in draft v8 ("must fix")
  This category includes some issues that need to be addressed.
  5 open issues are in this category.
=> Please raise any objection on the ipcdn list by COB Friday 9/10/03
if you believe this is not reflecting the correct status of the draft
or if you believe more open issues must be fixed.

3) Open issues:
The numbering is based on David Raftus status file sent on 9/12/2003
on the ipcdn list and attached to this posting.

+ Issue #7:
Status: Closed (will be in draft08)
(7) docsIfUpChannelPreEqEnable - add DEFVAL clause.
    Contributor - John Gillis ADC
David indicated that a defval is not required ("DEFVAL not appropriate
here, also too many other items in same table do not have DEFVAL").
# category: "must fix"
# Eduardo recommends to add a default value of false for this object.
# Action Item: add DEFVAL false in draft 08

+ Issue #13
Status: Open
(13) Adjust compliance statements for objects designated optional. Add
     separate augmentation table for optional objects in
     docsIfCmtsUpChannelCounterTable.
     Contributors - Will Murwin Motorola, Rich Woundy IPCDN/Comcast,
     Mike StJohns Mindspring, Eduardo Cardona Cablelabs
# category: "must fix"
# Action Item: Eduardo to summarize the discussion & a recommendation
# for the augmentation. Consensus must be reached by 10/10 or else WG
# chair will make a decision.

+ Issue #14 
Status: Open
(14) Add section explaining counter interaction between
     Docsis 1.0/1.1/2.0.
David indicated that this could be done in OSS spec but since rfmib v2
obsoletes an exising IETF MIB, the wg chairs recommendation is to
include a section in the new MIB.
# category: "must fix"
# Action Item: Eduardo to propose some text.

+ Issue #15
Status: Closed, pending ipcdn review
(15) Change docsIfCmtsServiceTable to count packets for both upstream
     and downstream flows.
David Raftus commented: "Will not do - inappropriate - table indexed
by SID, SIDs are not defined for downstream flows".
WG chairs agree with David Raftus.
# category: "nice to have", For further study.
# Action item: none, issue is closed. 

+ Issue #16
Status: Open
(16) Add 4 objects to docsIfCmtsCmStatusTable
See David Raftus' status on this open issue and associated emails.
# category: "nice to have"
# Action item: Eduardo to close on this issue on the ipcdn mailing
# list. If no consensus can be reached by Oct 10, wg chair will make a
# decision to leave it out of rf mib v2.

+ Issue #20
Status: Closed (will be in draft08)
(20) Update snmpv3 references to latest mib versions
# category: "must fix"
# Action item: edit draft 08 and include proper refs in the document

+ Issue #22
Status: Closed (pending ipcdn review)
(22) Addition of object to report received power level per channel at
CMTS
# category: "nice to have" -> out of scope
# Recommendation is that this issue will not be addressed in any
# future revision of RF MIB v2.
# Action item: none, issue is closed.

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 1 Oct 2003 18:13:27 -0600

Here is the list of open issues (the "attachment" mentioned below).

	-----Original Message-----
	From: Jean-Francois Mule 
	Sent: Wednesday, October 01, 2003 6:11 PM
	To: Ipcdn (E-mail)
	Cc: Eduardo Cardona; Jean-Francois Mule; Richard Woundy; Bert
Wijnen; Raftus, David
	Subject: [ipcdn] Status of IPCDN RF MIBv2 and 3 open issues

	This note provides a status on the DOCSIS 2.0 RF MIB (aka
rfmibv2).
	
	In summary, 3 issues are still OPEN and the wg chairs would like
to
	have working group consensus by Friday October 10 on issues:
#13, #14,
	 #16. Eduardo Cardona of CableLabs has kindly accepted to help
resolve 
	those and will be posting some text soon.
	
	Please read this carefully and raise any concerns or objections
to the
	wg chairs on this action plan by Friday Oct 10.

	--- Status of RF MIBv2
	
ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipcdn-docs-rfmibv2-06.txt
<ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipcdn-docs-rfmibv2-06.txt
	soon to be

	1) Follow-up on the IETF posting of rfmibv2-07
	   The editor, David Raftus sent draft-07 to the internet-draft
on
	   9/9. The revision has not shown up yet. This is probably due
to the
	   fact that a zip file was attached instead of the plain text
file.
	   Action Item (AI): wg chair to follow up on posting.

	2) Categorization of the remaining open issues
	David Raftus sent a list of open issues to the ipcdn list on
9/12/03,
	see attached file rfdraftv7_issues_Sept12_2003.txt
	The remaining open issues not addressed in draft-07 split into 2
	categories:
	- a) issue is not required to be addressed ("nice to have")
	  This category includes some of the improvements that were not
in the
	  original scope of rfmibv2. A lot of improvements has been done
and
	  it is time to freeze rfmibv2.
	- b) issue that should be addressed in draft v8 ("must fix")
	  This category includes some issues that need to be addressed.
	  5 open issues are in this category.
	=> Please raise any objection on the ipcdn list by COB Friday
9/10/03
	if you believe this is not reflecting the correct status of the
draft
	or if you believe more open issues must be fixed.

	3) Open issues:
	The numbering is based on David Raftus status file sent on
9/12/2003
	on the ipcdn list and attached to this posting.
	
	+ Issue #7:
	Status: Closed (will be in draft08)
	(7) docsIfUpChannelPreEqEnable - add DEFVAL clause.
	    Contributor - John Gillis ADC
	David indicated that a defval is not required ("DEFVAL not
appropriate
	here, also too many other items in same table do not have
DEFVAL").
	# category: "must fix"
	# Eduardo recommends to add a default value of false for this
object.
	# Action Item: add DEFVAL false in draft 08
	
	+ Issue #13
	Status: Open
	(13) Adjust compliance statements for objects designated
optional. Add
	     separate augmentation table for optional objects in
	     docsIfCmtsUpChannelCounterTable.
	     Contributors - Will Murwin Motorola, Rich Woundy
IPCDN/Comcast,
	     Mike StJohns Mindspring, Eduardo Cardona Cablelabs
	# category: "must fix"
	# Action Item: Eduardo to summarize the discussion & a
recommendation
	# for the augmentation. Consensus must be reached by 10/10 or
else WG
	# chair will make a decision.
	
	+ Issue #14
	Status: Open
	(14) Add section explaining counter interaction between
	     Docsis 1.0/1.1/2.0.
	David indicated that this could be done in OSS spec but since
rfmib v2
	obsoletes an exising IETF MIB, the wg chairs recommendation is
to
	include a section in the new MIB.
	# category: "must fix"
	# Action Item: Eduardo to propose some text.
	
	+ Issue #15
	Status: Closed, pending ipcdn review
	(15) Change docsIfCmtsServiceTable to count packets for both
upstream
	     and downstream flows.
	David Raftus commented: "Will not do - inappropriate - table
indexed
	by SID, SIDs are not defined for downstream flows".
	WG chairs agree with David Raftus.
	# category: "nice to have", For further study.
	# Action item: none, issue is closed.
	
	+ Issue #16
	Status: Open
	(16) Add 4 objects to docsIfCmtsCmStatusTable
	See David Raftus' status on this open issue and associated
emails.
	# category: "nice to have"
	# Action item: Eduardo to close on this issue on the ipcdn
mailing
	# list. If no consensus can be reached by Oct 10, wg chair will
make a
	# decision to leave it out of rf mib v2.
	
	+ Issue #20
	Status: Closed (will be in draft08)
	(20) Update snmpv3 references to latest mib versions
	# category: "must fix"
	# Action item: edit draft 08 and include proper refs in the
document
	
	+ Issue #22
	(22) Addition of object to report received power level per
channel at CMTS

---

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 2 Oct 2003 06:46:22 -0600

Folks,
 
Jean-Francois and I completely agree on this list below.
 
Allow me to make a small clarification. When we say:

This does *not* mean that we will never discuss the issue in IPCDN. For
example, the technology proponents can write a separate internet-draft that
extends the RF MIB (or creates a new separate MIB) with the proposed
functionality. This allows us to publish the RF MIB v2 in the short-term,
but resolve these "nice to have" issues (e.g. new MIB objects) in the
long-term.
 
Keep in mind that IPCDN has real scheduled milestones now:
http://www.ietf.org/html.charters/ipcdn-charter.html
<http://www.ietf.org/html.charters/ipcdn-charter.html> .
 
-- Rich

-----Original Message-----
From: Jean-Francois Mule [mailto:[email-masked]]
Sent: Wednesday, October 01, 2003 8:11 PM
To: Ipcdn (E-mail)
Cc: Eduardo Cardona; Jean-Francois Mule; Woundy, Richard; Bert Wijnen;
Raftus, David
Subject: Status of IPCDN RF MIBv2 and 3 open issues

--- Status of RF MIBv2
 <ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipcdn-docs-rfmibv2-06.txt>

3) Open issues:

+ Issue #7:

+ Issue #13
Status: Open

+ Issue #14
Status: Open

+ Issue #15

+ Issue #16
Status: Open

+ Issue #20

+ Issue #22
(22) Addition of object to report received power level per channel at CMTS

---

From: "Eduardo Cardona" <[email-masked]>
Date: Thu, 2 Oct 2003 09:05:54 -0600

Rich, you are correct, It is certainly an inaccurate final wording if
the recommendation note.
 
Jean-Francois and I discussed yesterday that RFC updates could be
possible in the future, specially requirements that may come out from
new projects inside CableLabs affecting any MIB. 
 
Depending of the scope ( in particular the note address item#22 ) new
OIDs may be assigned to a new OBJECT GROUP  in a further RFC update.
 
We might get later off-line guidelines from the IETF OPS group of where
updates (aka mib extensions) are desirable rather than a new MIB draft
status.
 
We will revise the statement for note #22 for October 10 final report.
 
Eduardo

	-----Original Message-----
	From: Woundy, Richard [mailto:[email-masked]] 
	Sent: Thursday, October 02, 2003 6:46 AM
	To: Ipcdn (E-mail)
	Cc: Jean-Francois Mule; Eduardo Cardona; Bert Wijnen; Raftus,
David; Woundy, Richard
	Subject: RE: Status of IPCDN RF MIBv2 and 3 open issues

	Folks,

	 
	 
	This does *not* mean that we will never discuss the issue in
IPCDN. For example, the technology proponents can write a separate
internet-draft that extends the RF MIB (or creates a new separate MIB)
with the proposed functionality. This allows us to publish the RF MIB v2
in the short-term, but resolve these "nice to have" issues (e.g. new MIB
objects) in the long-term.
	 
	Keep in mind that IPCDN has real scheduled milestones now:
http://www.ietf.org/html.charters/ipcdn-charter.html.
	 
	-- Rich

		-----Original Message-----
		From: Jean-Francois Mule [mailto:[email-masked]]
		Sent: Wednesday, October 01, 2003 8:11 PM
		To: Ipcdn (E-mail)
		Cc: Eduardo Cardona; Jean-Francois Mule; Woundy,
Richard; Bert Wijnen; Raftus, David
		Subject: Status of IPCDN RF MIBv2 and 3 open issues

		This note provides a status on the DOCSIS 2.0 RF MIB
(aka rfmibv2).
		
		In summary, 3 issues are still OPEN and the wg chairs
would like to
		have working group consensus by Friday October 10 on
issues: #13, #14,
		 #16. Eduardo Cardona of CableLabs has kindly accepted
to help resolve 
		those and will be posting some text soon.
		
		Please read this carefully and raise any concerns or
objections to the
		wg chairs on this action plan by Friday Oct 10.
		
		 -- Rich Woundy and Jean-Francois Mule', ipcdn
co-chairs.
		
		--- Status of RF MIBv2

		soon to be

		1) Follow-up on the IETF posting of rfmibv2-07
		   The editor, David Raftus sent draft-07 to the
internet-draft on
		   9/9. The revision has not shown up yet. This is
probably due to the
		   fact that a zip file was attached instead of the
plain text file.
		   Action Item (AI): wg chair to follow up on posting.

		2) Categorization of the remaining open issues
		David Raftus sent a list of open issues to the ipcdn
list on 9/12/03,
		see attached file rfdraftv7_issues_Sept12_2003.txt
		The remaining open issues not addressed in draft-07
split into 2
		categories:
		- a) issue is not required to be addressed ("nice to
have")
		  This category includes some of the improvements that
were not in the
		  original scope of rfmibv2. A lot of improvements has
been done and
		  it is time to freeze rfmibv2.
		- b) issue that should be addressed in draft v8 ("must
fix")
		  This category includes some issues that need to be
addressed.
		  5 open issues are in this category.
		=> Please raise any objection on the ipcdn list by COB
Friday 9/10/03
		if you believe this is not reflecting the correct status
of the draft
		or if you believe more open issues must be fixed.

		3) Open issues:
		The numbering is based on David Raftus status file sent
on 9/12/2003
		on the ipcdn list and attached to this posting.
		
		+ Issue #7:
		Status: Closed (will be in draft08)
		(7) docsIfUpChannelPreEqEnable - add DEFVAL clause.
		    Contributor - John Gillis ADC
		David indicated that a defval is not required ("DEFVAL
not appropriate
		here, also too many other items in same table do not
have DEFVAL").
		# category: "must fix"
		# Eduardo recommends to add a default value of false for
this object.
		# Action Item: add DEFVAL false in draft 08
		
		+ Issue #13
		Status: Open
		# for the augmentation. Consensus must be reached by
10/10 or else WG
		
		+ Issue #14
		Status: Open
		(14) Add section explaining counter interaction between
		     Docsis 1.0/1.1/2.0.
		David indicated that this could be done in OSS spec but
since rfmib v2
		obsoletes an exising IETF MIB, the wg chairs
recommendation is to
		include a section in the new MIB.
		# category: "must fix"
		# Action Item: Eduardo to propose some text.
		
		+ Issue #15
		Status: Closed, pending ipcdn review
		(15) Change docsIfCmtsServiceTable to count packets for
both upstream
		     and downstream flows.
		David Raftus commented: "Will not do - inappropriate -
table indexed
		by SID, SIDs are not defined for downstream flows".
		WG chairs agree with David Raftus.
		# category: "nice to have", For further study.
		# Action item: none, issue is closed.
		
		+ Issue #16
		Status: Open
		(16) Add 4 objects to docsIfCmtsCmStatusTable
		See David Raftus' status on this open issue and
associated emails.
		# category: "nice to have"
		# Action item: Eduardo to close on this issue on the
ipcdn mailing
		# list. If no consensus can be reached by Oct 10, wg
chair will make a
		# decision to leave it out of rf mib v2.
		
		+ Issue #20
		Status: Closed (will be in draft08)
		(20) Update snmpv3 references to latest mib versions
		# category: "must fix"
		# Action item: edit draft 08 and include proper refs in
the document
		
		+ Issue #22
		Status: Closed (pending ipcdn review)
		(22) Addition of object to report received power level
per channel at CMTS
		# category: "nice to have" -> out of scope
		# Recommendation is that this issue will not be
addressed in any
		# future revision of RF MIB v2.
		# Action item: none, issue is closed.

---

From: "Eduardo Cardona" <[email-masked]>
Date: Thu, 9 Oct 2003 14:14:42 -0600

Hi all, 
 
Just a reminder if you have comments for the open issues, listed this
week, please do so. so far only the New added comment #23 for
ChannelType has being discussed.
 
Thanks
 
Eduardo

	-----Original Message-----
	From: Jean-Francois Mule 
	Sent: Wednesday, October 01, 2003 6:11 PM
	To: Ipcdn (E-mail)
	Cc: Eduardo Cardona; Jean-Francois Mule; Richard Woundy; Bert
Wijnen; Raftus, David

	

	--- Status of RF MIBv2
	
	soon to be

	3) Open issues:
	
	+ Issue #7:
	
	+ Issue #13
	Status: Open
	
	+ Issue #14
	Status: Open
	
	+ Issue #15
	
	+ Issue #16
	Status: Open
	
	+ Issue #20
	
	+ Issue #22

---

From: "Dan Rice" <[email-masked]>
Date: Fri, 10 Oct 2003 10:39:07 -0400

I am sorry I could never find the ECR or MIB text for Issue number 6.
Sorry if I missed it, could someone post it again? - Dan
 
-----Original Message-----
From: Eduardo Cardona [mailto:[email-masked]] 
Sent: Thursday, October 09, 2003 4:15 PM
To: Jean-Francois Mule; Ipcdn (E-mail)
Cc: Richard Woundy; Bert Wijnen; Raftus, David
Subject: RE: [ipcdn] Status of IPCDN RF MIBv2 and 3 open issues
 
Hi all, 

Thanks
 
Eduardo
 
-----Original Message-----
From: Jean-Francois Mule 
Sent: Wednesday, October 01, 2003 6:11 PM
To: Ipcdn (E-mail)
Cc: Eduardo Cardona; Jean-Francois Mule; Richard Woundy; Bert Wijnen;
Raftus, David

--- Status of RF MIBv2

3) Open issues:

+ Issue #7:

+ Issue #13
Status: Open

+ Issue #14
Status: Open

+ Issue #15

+ Issue #16
Status: Open

+ Issue #20

+ Issue #22