Subject: [ipcdn] Additional comments on draft-ietf-ipcdn-device-mibv2-06.txt

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 26 Nov 2003 09:49:14 -0800

Hi -

Bert Wijnen ran SMICng on the MIB module in
draft-ietf-ipcdn-device-mibv2-06.txt and
found some items that I overlooked:

>   E: f(ipcdndevice.mi2), (1342,1) Row "docsDevFilterIpEntry" must have
>      same status as parent table "docsDevFilterIpTable"

This must be fixed.

>   E: f(ipcdndevice.mi2), (2389,12) Item "diffServMIBDataPathGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2390,12) Item "diffServMIBClfrGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2391,12) Item "diffServMIBClfrElementGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2392,12) Item "diffServMIBMultiFieldClfrGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2393,12) Item "diffServMIBActionGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2394,12) Item "diffServMIBDscpMarkActGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2395,12) Item "diffServMIBCounterGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2396,12) Item "diffServMIBAlgDropGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2399,8) Item "diffServDataPathStatus" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2406,8) Item "diffServClfrStatus" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2413,8) Item "diffServClfrElementStatus" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2420,8) Item "diffServMultiFieldClfrAddrType" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2426,8) Item "diffServMultiFieldClfrSrcAddr" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2433,8) Item "diffServMultiFieldClfrDstAddr" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2439,8) Item "diffServAlgDropStatus" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2446,8) Item "diffServDataPathStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2452,8) Item "diffServClfrStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2458,8) Item "diffServClfrElementStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2464,8) Item "diffServMultiFieldClfrStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2470,8) Item "diffServActionStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2476,8) Item "diffServCountActStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2482,8) Item "diffServAlgDropStorage" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2488,8) Item "diffServAlgDropType" should be IMPORTed

The MIB review guidelines recommend that these be imported.  This is not a
hard requirement, but the consensus of the MIB reviewer mailing list was that
having IMPORTS for these makes it easier for someone reading a module to
see the dependencies in one place.

Since this is an update to an existing specification, I'm also going to run it through
smidiff, and will post comments regarding those results in a separate message.

Randy

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Eduardo Cardona" <[email-masked]>
Date: Wed, 26 Nov 2003 11:26:05 -0700

Hi, 

I think this also affects DOCS-IETF-SUBMGT-MIB

Current DOCS-IETF-SUBMGT-MIB do not have imports for DIFFSERV-MIB, 

whishes to have something like
     * FROM DIFFSERV-MIB    -- :)

Eduardo

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, November 26, 2003 10:49 AM
To: [email-masked]
Subject: [ipcdn] Additional comments on
draft-ietf-ipcdn-device-mibv2-06.txt

Hi -

Bert Wijnen ran SMICng on the MIB module in
draft-ietf-ipcdn-device-mibv2-06.txt and found some items that I

This must be fixed.

>   E: f(ipcdndevice.mi2), (2392,12) Item
"diffServMIBMultiFieldClfrGroup" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2420,8) Item
"diffServMultiFieldClfrAddrType" should be IMPORTed
>   E: f(ipcdndevice.mi2), (2488,8) Item "diffServAlgDropType" should be

> IMPORTed

The MIB review guidelines recommend that these be imported.  This is not
a hard requirement, but the consensus of the MIB reviewer mailing list
was that having IMPORTS for these makes it easier for someone reading a
module to see the dependencies in one place.

Since this is an update to an existing specification, I'm also going to
run it through smidiff, and will post comments regarding those results
in a separate message.

Randy