Subject: [ipcdn] MTA MIB draft 03 and Standalone MTA devices

From: "Jean-Francois Mule" <[email-masked]>
Date: Fri, 9 Jan 2004 16:55:16 -0700

Folks,

Eugene and I have been working on an update to the IPCDN MTA MIB draft. In the upcoming draft 03, we have added a module compliance statement for Standalone MTA devices.

See below the proposed text, let us know if you have any comments by Monday January 26 so that we can address them before publication.

Thanks, 
Eugene & Jean-François 
---
1/
Added new section to explain why S-MTAs deal with secure software download differently, where the normative requirements are and why we need the S-MTA compliance statement

3.6 Secure Software Download
While E-MTAs have their software upgraded by the Cable Modem according to the DOCSIS requirements, S-MTAs must implement the a specific mechanism for Secure Software Download defined in the PacketCable/IPCablecom Security specification [PKT-SP-SEC-I09-030728]. 
This mechanism provides means to verify the code upgrade using Code Verification Certificates and is modeled after the DOCSIS mechanism implemented in Cable Modems. This is the reason why the MTA MIB and the S-MTA compliance modules rely on two MIB object groups (docsBpi2CodeDownloadGroup and docsDevSoftwareGroupV2) defined in the IETF BPI Plus MIB module (DOCS-IETF-BPI2-MIB [RFCyyyy]).

2/
Added formal compliance for S-MTAs, mostly to translate the actual requirements contained in the PacketCable/IPCablecom Security specs (from 2 other IPCDN docsis mibs cablevice and bpi+ mib).

pktcMtaBasicRFCyyyySmtaCompliance MODULE-COMPLIANCE 
  
    STATUS      current 
    DESCRIPTION 
        " The compliance statement for S-MTA devices
          that implement PacketCable or IPCablecom requirements. 
          
          This compliance statement applies to S-MTA implementations
          that support PacketCable 1.3 or IPCablecom requirements, 
          which are not IPv6-capable at the time of this
          RFC publication."

   -- Unconditionally Mandatory Groups for S-MTA devices
    MODULE 
        MANDATORY-GROUPS {  
            pktcMtaGroup, 
            pktcMtaNotificationGroup
        }
    MODULE DOCS-CABLE-DEVICE-MIB
        MANDATORY-GROUPS {  
            docsDevSoftwareGroupV2  
        }
    MODULE DOCS-IETF-BPI2-MIB
        MANDATORY-GROUPS {  
            docsBpi2CodeDownloadGroup
        }
     ::= { pktcMtaCompliances 2 }  

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 11 Jan 2004 21:39:17 +0100

W.r.t.
> pktcMtaBasicRFCyyyySmtaCompliance MODULE-COMPLIANCE 
I think this is a bad name. If this module gets updated/clarified
and advances to DS later, then it becomes another RFC number.
Better to use a name without RFC number.
What is wrong with:

  pktcMtaBasicSmtaCompliance MODULE-COMPLIANCE

Same fo course for the current 
  pktcMtaBasicRFCyyyyCompliance MODULE-COMPLIANCE 
in revision 02.

Bert

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Mon, 12 Jan 2004 13:07:46 -0700

Bert,

Understood, we'll correct that.
Thanks for your comments. 

Jean-François 

Bert wrote:
> I think this is a bad name. If this module gets 
> updated/clarified and advances to DS later, then it becomes 
> another RFC number. Better to use a name without RFC number. 
> What is wrong with:
>

---

From: "Eugene Nechamkin" <[email-masked]>
Date: Wed, 14 Jan 2004 17:03:03 -0800

Colleagues,

The MTA MIB draft-03 work in progress was revised to incorporate the number of changes resulted from the discussions on the MIBs review group of PacketCable.

Particularly: 

1. "pktcMtaDevEnabled" description clause has been updated in accordance with PacketCable ECN "prov-n-03120":

       DESCRIPTION
            " This object contains the MTA Admin Status of this device.
              If this object is set to 'true', the MTA is
              administratively enabled and the MTA MUST be able to
              interact with the PacketCable entities such as CMS,
              Provisioning Server, KDC, and other MTAs and MGs on all
              PacketCable interfaces.
              If this object is set to 'false', the MTA is
              administratively disabled and the MTA MUST perform the
              following actions for all endpoints:
                  - shutdown all media sessions if present,
                  - shutdown NCS signaling by following the Restart in
                  Progress procedures in the PacketCable NCS
                  specification.
              Additionally, the MTA MUST maintain the SNMP Interface
              For management and also SNMP Key management interface.
              Also the MTA MUST NOT continue Kerberized key management
              with CMSes until this object is set to 'true'.
              Note: MTAs MUST renew the CMS kerberos tickets according
              to the PacketCable Security Specification."

2. "pktcMtaBasicRFCyyyyCompliance" name has been substitued with "pktcMtaBasicCompliance":

  pktcMtaBasicCompliance MODULE-COMPLIANCE

3. "pktcMtaBasicRFCyyyySmtaCompliance"  name has been substitued with "pktcMtaBasicSmtaCompliance":

4. Copyright dates have been updated for 2004.

5. References to the Provisioning, Security and MTA MIB PacketCable Specifications have also been brought up to date.

6. "LAST-UPDATED" and "REVISION" clauses have been updated.

Thanks,

Jean-François & Eugene.

-----Original Message-----
From: Jean-Francois Mule [mailto:[email-masked]] 
Sent: Friday, January 09, 2004 3:55 PM
To: [email-masked]
Cc: Eugene Nechamkin
Subject: [ipcdn] MTA MIB draft 03 and Standalone MTA devices

Folks,

Thanks, 
Eugene & Jean-François 
---
1/

2/

    STATUS      current 
    DESCRIPTION