Subject: [ipcdn] wg review of draft-ietf-ipcdn-docsisevent-mib-03.txt

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 7 Apr 2004 16:15:08 -0600

Folks,

Draft03 of the DOCSIS event notif mgmt mib was published on Feb 3rd 2004. It's been 2 months already and no comments have been received on this ID update. This draft was first published in May 2001.

The wg chairs would like to ask for volunteers to review this draft before issuing WGLC soon. Let Rich or myself know if you would like to review this draft.

Thank you in advance,
Rich Woundy & Jean-François Mule
IPCDN co-chairs.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, February 03, 2004 1:49 PM
> Cc: [email-masked]
> Subject: [ipcdn] I-D ACTION:draft-ietf-ipcdn-docsisevent-mib-03.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories. This draft is a work item of the 
> IP over Cable Data Network Working Group of the IETF.
> 
> 	Title		: Event Notification Management 
> Information Base for 
> 			  DOCSIS Compliant Cable Modems and Cable Modem 
> 			  Termination Systems
> 	Author(s)	: A. Ahmad
> 	Filename	: draft-ietf-ipcdn-docsisevent-mib-03.txt
> 	Pages		: 30
> 	Date		: 2004-2-3
> 	
> This memo defines a portion of the Management Information Base (MIB)
>    for use with network management protocols in the Internet 
> community.
>    In particular, it defines a basic set of managed objects for SNMP-
>    based event notification management of DOCSIS compliant 
> Cable Modems
>    and Cable Modem Termination Systems. This MIB is defined as an
>    extension to the DOCSIS Cable Device MIB, RFC 2669 [5].
> 
>    This memo specifies a MIB module in a manner that is 
> compliant to the
>    SMIv2.  The set of objects is consistent with the SNMP 
> framework and
>    existing SNMP standards.
> 
> A URL for this Internet-Draft is: 
> http://www.ietf.org/internet-drafts/draft-ietf-ipcdn-docsiseve
nt-mib-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username "anonymous" and a password of your e-mail address. After logging in, type "cd internet-drafts" and then
	"get draft-ietf-ipcdn-docsisevent-mib-03.txt".

A list of Internet-Drafts directories can be found in http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ipcdn-docsisevent-mib-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Raftus, David" <[email-masked]>
Date: Thu, 29 Apr 2004 11:15:06 -0700

Hi,

Forwarding event mib review comments to the list.

Thanks,
Dave

-----Original Message-----
From: Jean-Francois Mule [mailto:[email-masked]]
Sent: Thursday, April 29, 2004 12:24 PM
To: Raftus, David
Cc: Greg Nakanishi (E-mail); Azlina Ahmad (E-mail)
Subject: RE: [ipcdn] wg review of draft-ietf-ipcdn-docsisevent-mib-03.txt

Hi David,

Thank for your DOCSIS review, this is the most important. Can you still send
your DOCSIS review comments to the list? This was requested by Bert as it is
standard ietf process...

Thanks again, 
Jean-François

> From: Raftus, David [mailto:[email-masked]]
> Sent: Thursday, April 29, 2004 8:30 AM
> To: Jean-Francois Mule
> Cc: Greg Nakanishi (E-mail); Azlina Ahmad (E-mail); Raftus, David
> Subject: RE: [ipcdn] wg review of
> draft-ietf-ipcdn-docsisevent-mib-03.txt
>
>
> Hi Jean-Francois,
> 
> This event mib draft is actually not too different from the
> v2 version created in Jan/03.
> 
> I'm afraid I don't have the necessary background to evaluate
> the mib according to compliance with the mib guidelines and
> conformance with ID-nits. Sorry for that. Therefore, I didn't
> CC my comments to the IPCDN list.
> 
> I did examine the mib from a Docsis perspective though, and
> have the following comments:
> 
> 1) Not sure if the default value of NULL is appropriate for
> the BITs defval for object docsDevCmTrapControl. This doesn't
> give any real guidance as to whether the traps should be
> enabled or disabled. The original value of 0x00, while
> perhaps not strictly conforming to the octet string nature of
> BITs, did signal that all traps default to off.
> 
> 2) The intention of keeping the deprecated mib objects within
> the trap definitions was to maintain back-compatibility with
> existing 1.1 applications that implemented the trap defs
> using the original docs-if ext mib. With the deprecated
> objects removed, it is possible that these pre-rf mib v2
> draft 1.1 applications may not be compatible with the new trap defs.
> 
> 3) The event mib is not in sync with the MTA event mgmt mib.
> It is not really fair to compare them. The MTA event mgmt mib
> uses a generic definition for all informs and traps
> pertaining to MTA events. The Docsis event mib creates
> individual trap defs for each event. It may be a nice idea to
> add inform defs in the Docsis event mib though.
> 
> Again, sorry for not commenting on mib guidelines, etc.
> 
> Regards,
> Dave
> 
> 
> From: Jean-Francois Mule [mailto:[email-masked]]
> Sent: Thursday, April 08, 2004 1:05 PM
> To: Raftus, David
> Cc: Richard Woundy @ Comcast
> Subject: RE: [ipcdn] wg review of
> draft-ietf-ipcdn-docsisevent-mib-03.txt
> 
> Dave,
> 
> Thanks a lot.
> For your review, please consider the following:
>   - compliance with mib guidelines check-list
>   - conformance with ID-nits,
>   - is this MIB in sync with the other ipcdn ID on event mgmt
> for MTAs:
>    
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipcdn-pktc-event
> mess-03.txt
>   - etc.
> 
> Also, please send your comments to the ipcdn list.
> thx,
> jean-francois.