Subject: RE: [ipcdn] FW: DISCUSS: draft-ietf-ipcdn-bpiplus-mib-14

From: "Jean-Francois Mule" <[email-masked]>
Date: Thu, 7 Oct 2004 15:28:23 -0600

Russ wrote:
> I seriously doubt that t3DES128EdeMode is useful in this 
> context.  ECB had 
            ^^^ 
you mean EDE here
> some properties that are probably bad in this environment.

Okay, we can remove it, no pb.
Just fyi, 3DES EDE was also proposed because it is already used in the
BPI+ spec for the traffic encryption key (TEK). See page 21 of BPI+ at
http://www.cablemodem.com/downloads/specs/BPI+_I11-040407.pdf :
"The traffic encryption key (TEK) in the Key Reply is triple DES
(encrypt-decrypt-encrypt or EDE mode) encrypted, using a two-key, triple
DES key encryption key (KEK) derived from the Authorization Key."

This should close the threads on your comment - thank you again for the
review. 
Jean-Francois

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Russ Housley <[email-masked]>
Date: Fri, 08 Oct 2004 01:15:27 -0400

>Okay, we can remove it, no pb.

Okay.

>DES key encryption key (KEK) derived from the Authorization Key."

This is still a poor choice.  See RFC 3217 and RFC 3394 for better solutions.

Russ