Subject: [ipcdn] RE: Ev MIB pktcDevEvEndpointName description

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 22 Nov 2004 19:22:09 -0800

Satish,

The IP format of the endpoint name is coming from the requirements of
the PacketCable NCS Spec (section 4.1.1):

"Endpoint names will be of the form local-endpoint-name@domain-name 
where domain-name is an absolute domain-name as defined in [24] and
includes a host portion, thus an
example domain-name could be:

MyEmbeddedClient.cablelabs.com

Also, domain-name may be an IPv4 address in dotted decimal form
represented as a text-string and
surrounded by a left and a right square bracket ("[" and "]") as in
"[128.96.41.1]" - please consult [22] for
details. However, use of IP addresses is generally discouraged."

Eugene.

-----Original Message-----
From: Kumar, Satish [mailto:[email-masked]] 
Sent: Monday, November 22, 2004 2:22 PM
To: Eugene Nechamkin; [email-masked]
Subject: Ev MIB pktcDevEvEndpointName description

Hi,
  The current Ev MIB has below description.

pktcDevEvEndpointName OBJECT-TYPE
    SYNTAX      SnmpAdminString
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
            "This is the endpoint identifier followed by the FQDN/IP
            Address of the device. This is in the form - AALN/X:FQDN/IP
            Address. If the event is not specific to an endpoint, then
            the contents is just the FQDN/IP address."
    ::= { pktcDevEventEntry 8 }

In Packetcable FQDN(only) is allowed for MTA during NCS message
exchange. Why do we need IP address be referred here?

Comments please..

Thx, Satish

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 22 Nov 2004 22:49:54 -0800

Hi -

> From: "Eugene Nechamkin" <[email-masked]>
> To: "Kumar, Satish" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, November 22, 2004 7:22 PM
> Subject: [ipcdn] RE: Ev MIB pktcDevEvEndpointName description
...
> the PacketCable NCS Spec (section 4.1.1):
...
> pktcDevEvEndpointName OBJECT-TYPE
...

This would be a good place to use the REFERENCE construct.

Randy