Subject: [ipcdn] AD review: draft-ietf-ipcdn-docsisevent-mib-04.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 4 Nov 2004 15:57:42 +0100

Not a final review, just a question first that came up
when I did a quick initial browse:

I do not understand:

       MODULE -- docsDevNotif
       --mandatory groups

           GROUP docsDevCmNotifControlGroup
           DESCRIPTION
               "Mandatory in CM."
  
           GROUP docsDevCmNotificationGroup
           DESCRIPTION
               "Mandatory in CM."

       ::= { docsDevNotifCompliances 1 }

Why would you not specify instead:

   docsDevCmNotifCompliance MODULE-COMPLIANCE
       STATUS current
       DESCRIPTION
       "The compliance statement for CM Notifications and Control"

       MODULE --docsDevNotif
         MANDATORY-GROUPS {
             docsDevCmNotifControlGroup,
             docsDevCmNotificationGroup
         }

After all, it is the compliance for CM, and for a CM, both groups
are mandatory. So using my alternate method makes that a spec
that is machine readable.

Same for the Cmts compliance of course.

Bert

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Nakanishi Greg-MGI8179 <[email-masked]>
Date: Thu, 4 Nov 2004 08:33:01 -0800

Burt,

OK with me.  I'll get the update into the next revision.

Thanks, greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Wijnen, Bert (Bert)
Sent: Thursday, November 04, 2004 6:58 AM
To: Ipcdn (E-mail)
Subject: [ipcdn] AD review: draft-ietf-ipcdn-docsisevent-mib-04.txt

I do not understand:

       MODULE -- docsDevNotif
       --mandatory groups

       MODULE --docsDevNotif
         MANDATORY-GROUPS {

After all, it is the compliance for CM, and for a CM, both groups are mandatory. So using my alternate method makes that a spec that is machine readable.

Bert