Subject: RE: [ipcdn] [pkt-prov] MTA MIB Error OID table - a number of questions

From: "Eugene Nechamkin" <[email-masked]>
Date: Wed, 12 Jan 2005 19:50:22 -0800

How about the following:

|           pktcMtaDevErrorOidsTable. In this case, the value of the
|           pktcMtaDevErrorOid, pktcMtaDevErrorValue, and
|           pktcMtaDevErrorReason objects for the 1024-th table entry
must 
|           all contain the string 'TOO MANY ERRORS IN THE CONFIGURATION
FILE' 
|           or its semantic equivalent."

Eugene.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Randy Presuhn
Sent: Wednesday, January 12, 2005 6:45 PM
To: [email-masked]
Subject: Re: [ipcdn] [pkt-prov] MTA MIB Error OID table - a number of
questions

Hi -

> From: "Eugene Nechamkin" <[email-masked]>
> To: "Dave Thaler" <[email-masked]>; "Jean-Francois 
> Mule" <[email-masked]>; <[email-masked]>
> Cc: "Leandro Rzezak" <[email-masked]>; "PacketCable
Provisioning and OSS Majordomo List"
<[email-masked]>
> Sent: Wednesday, January 12, 2005 3:34 PM
> Subject: RE: [ipcdn] [pkt-prov] MTA MIB Error OID table - a number of 
> questions
>
> As the "must" is not a normative requirement in this particular case,

That's not what the proposed text says.  The proposal says

|           pktcMtaDevErrorOidsTable. In this case, the value of the
|           pktcMtaDevErrorOid, pktcMtaDevErrorValue, and
|           pktcMtaDevErrorReason objects for the 1024-th table entry
|           must all be equal to
|           'TOO MANY ERRORS IN THE CONFIGURATION FILE'."

I see no way to read those words as non-normative.
An implementation that used any other string would not be conformant.

>  the string mentioned in the decsription clause does not seem to be 
> too restrictive and should not pose problems in localized
environments.
...

These objects worry me.   Has someone looked at them from
the perspective of RFC 2130?  Also, is the fact that all the examples
are all in English and all in capital letters somehow significant?

Randy

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 12 Jan 2005 20:25:14 -0800

Hi -

> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, January 12, 2005 7:50 PM
> Subject: RE: [ipcdn] [pkt-prov] MTA MIB Error OID table - a number of questions
>

> |           pktcMtaDevErrorReason objects for the 1024-th table entry must
> |           all contain the string 'TOO MANY ERRORS IN THE CONFIGURATION FILE'
...

This worries me even more.  I don't see how this change to the change
could possibly help interoperability.

Randy