Subject: [ipcdn] RE: The prefix for the DOCSIS-IEFT-QOS-MIB

From: "Jean-Francois Mule" <[email-masked]>
Date: Mon, 24 Jan 2005 14:01:22 -0700

> Please respond if you feel strongly either way.
Please provide your input to Will and the ipcdn list by COB Wednesday
January 26 before 10am ET.

Jean-Francois 

> -----Original Message-----
> From: Murwin William-LWM008 [mailto:[email-masked]] 
> Sent: Monday, January 24, 2005 8:57 AM
> To: IPCDN (E-mail) (E-mail)
> Cc: Jean-Francois Mule; Richard Woundy @ Comcast; Patrick 
> Michael-LZZ007
> Subject: The prefix for the DOCSIS-IEFT-QOS-MIB
> 
> 
> I am currently in the process of updating the 
> draft-ietf-ipcdn-qos-mib-11.txt, in-order to address the 
> rooting issue of this MIB.
> 
> There has been significant discussion about how this version 
> and version 4 will exist together in SNMP manager and agents. 
> IPCDN even went as far as changing this mib MODULE-IDENTIER 
> in order to be able to support both mibs within the same SNMP 
> manager. However, from my own personal experience this seems 
> not to be enough for some SNMP managers, and usually only one 
> of the version can only be installed. 
> 
> With this update I am willing on change the the MIB Module 
> Descriptor from "docsQosMIB" to "docsIetfQosMIB" and changing 
> all the MIB objects prefix from "docsQos" to "docsIetfQos".
> 
> Please respond if you feel strongly either way.
> 
> Sincerely,
> Will
> 
> ______________________________
> William Murwin
> Broadband Communications Sector
> Motorola Inc.
> Email: [email-masked]
> Tel: (508) 786-7594
> 
> 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Fred Oko" <[email-masked]>
Date: Tue, 25 Jan 2005 19:54:02 -0500

Arguably, the QOS-MIB needs this distinguisher the most across the
current IPCDN drafts as a given short name may actually map to a
different OID. So even if both versions could be installed, the matching
algorithm for finding the OID to use may vary (though clearly
fully-qualified (or at least MODULE::leaf style) requests are best
practice to lock down the desired namespace at the client so this is
only corner case). Would we consider whether this should be done for the
other pre-RFC draft MIBs awaiting re-root on a case by case basis or
select this as policy moving forward (or assume this is the only one as
this is the only one for which the MODULE-IDENTITY has changed due to
object renumbers)? I do not know of any precedence of such a rename in
working-implementation draft MIBs (anyone else?) and definitely am not
aware of 'Ietf' being placed into the object names by any other WG
though it seems as good a choice as any except for the growing prefix
length (granted, of no real operational concern). If nothing else, the
suggested change improves consistency between the object prefix and the
already agreed upon MODULE-IDENTITY.
 
-----Original Message-----
From: Murwin William-LWM008 [mailto:[email-masked]] 
Sent: Monday, January 24, 2005 10:57 AM
To: IPCDN (E-mail) (E-mail)
Cc: Jean-Francois Mule; Patrick Michael-LZZ007;
[email-masked]
Subject: [ipcdn] The prefix for the DOCSIS-IEFT-QOS-MIB
 
I am currently in the process of updating the
draft-ietf-ipcdn-qos-mib-11.txt, in-order to address the rooting issue
of this MIB.
There has been significant discussion about how this version and version
4 will exist together in SNMP manager and agents. IPCDN even went as far
as changing this mib MODULE-IDENTIER in order to be able to support both
mibs within the same SNMP manager. However, from my own personal
experience this seems not to be enough for some SNMP managers, and
usually only one of the version can only be installed. 
With this update I am willing on change the the MIB Module Descriptor
from "docsQosMIB" to "docsIetfQosMIB" and changing all the MIB objects
prefix from "docsQos" to "docsIetfQos".
Please respond if you feel strongly either way. 
Sincerely, 
Will 
______________________________ 
William Murwin 
Broadband Communications Sector 
Motorola Inc. 
Email: [email-masked] 
Tel: (508) 786-7594 
_______________________________________________ 
IPCDN mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ipcdn 
_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn