Subject: RE: [ipcdn] Questions on SIG draft-08

From: "Eugene Nechamkin" <[email-masked]>
Date: Tue, 14 Jun 2005 08:21:48 -0700

> This was also the case in previous 
> versions of the draft, and did not seem to cause trouble? 
Correct, execept that the previous version (draft-07) had this object as a
part of the PktcSigDevToneEntry as an index, which is "not-accessable". The
value of INDEX is provided with the PDU as a part an index part of the OID
being quiried by the particular PDU.

> ...this would be a pre-configured value to indicate the MTA's 
> capabilities, i.e. to tell the NMS how many frequencies 
> the MTA supports at a maximum. If this is indeed the case, 
> then the object should not be read-write, but read-only instead.
If this is the intention, then it's not aligned clearly with the decsription
clause. I think the intention of the object requires further clarification.

Eugene.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
David De Reu
Sent: Tuesday, June 14, 2005 12:37 AM
To: [email-masked]
Subject: RE: [ipcdn] Questions on SIG draft-08

> 1. pktcSigDevToneType currently defined as follows:
> 
>    pktcSigDevToneType        OBJECT-TYPE   
>        SYNTAX       INTEGER {   
>                     busy(1),   
>                     ........
>                     userDefined3(20),  
>                     userDefined4(21)  
>                     }   
>        MAX-ACCESS   not-accessible  
>        STATUS       current   
...
> The object is defined as being "not-accessable".

This was also the case in previous versions of the draft, and did not seem to
cause trouble?

> 2.  pktcSigDevToneNumFrequencies currently defined as
> follows:
> 
> pktcSigDevToneNumFrequencies    OBJECT-TYPE   
>     SYNTAX       INTEGER(5..16)  
>     MAX-ACCESS   read-write   
>     STATUS       current   
>     DESCRIPTION   
>       "This MIB Object specifies the number of frequencies 
>        supported by the PacketCable MTA for each tone type."   
>     ::={ pktcSigDevConfigObjects 33}   
> 
> As there are multiple tone types defined in the SIG MIB
> draft-08 for MTAs, which one is being referred to in this object's 
> description ?  For exmaple, which tone type the value being set would 
> correspond to ?  Also, what if NMS tries to set the value of the 
> number of frequencies NOT supported by the MTA ?

Although I'm not one of the authors of these objects, I suppose that they
meant that this would be a pre-configured value to indicate the MTA's
capabilities, i.e. to tell the NMS how many frequencies the MTA supports at a
maximum. If this is indeed the case, then the object should not be
read-write, but read-only instead.

Regards,

David

_____________________________________________________
David De Reu
tComLabs
Stapelplein 70 - 9000 Ghent - Belgium
Tel: +32 9 269 22 91 - Fax: +32 9 329 31 74 www.tComLabs.com
_____________________________________________________ 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Sumanth Channabasappa" <[email-masked]>
Date: Wed, 22 Jun 2005 15:42:51 -0600

Eugene,

Comments inline.

> versions of the draft, and did not seem to cause trouble? 
Correct, execept that the previous version (draft-07) had this object as
a part of the PktcSigDevToneEntry as an index, which is
"not-accessable". The value of INDEX is provided with the PDU as a part
an index part of the OID being quiried by the particular PDU.
[sumanth] 'pktcSigDevToneType' is an index into 'pktcSigDevToneTable'.
So it is still used as an index, no?

> capabilities, i.e. to tell the NMS how many frequencies the MTA 
> supports at a maximum. If this is indeed the case, then the object 
> should not be read-write, but read-only instead.
If this is the intention, then it's not aligned clearly with the
decsription clause. I think the intention of the object requires further
clarification.
[sumanth] This should have read 'maximum number of frequencies' and this
should probably be 'read-only' unless it can be changed at run-time.

Regards
Sumanth