Subject: [ipcdn] Questions on SIG draft-08

From: "Eugene Nechamkin" <[email-masked]>
Date: Mon, 13 Jun 2005 16:00:21 -0700

The following are the questions on SIG draft-08.

1. pktcSigDevToneType currently defined as follows:

   pktcSigDevToneType        OBJECT-TYPE   
       SYNTAX       INTEGER {   
                    busy(1),   
                    ........
                    userDefined3(20),  
                    userDefined4(21)  
                    }   
       MAX-ACCESS   not-accessible  
       STATUS       current   
       DESCRIPTION   
           "Unique value ranging from 1 to 21 that will correspond   
            to the different tone types. These tones can be  
            provisioned based on country specific needs. This  
            object defines the type of tone being accessed.  
            The alertingSignal, specialDial, specialInfo, release, 
            congestion and userDefined1-4 tone types are used in  
            the E line package."  
       ::= { pktcSigDevConfigObjects 32 }   

The object is defined as being "not-accessable". The description clause does
not have clear pointers on how "not-accessable" object is supposed to be used
by the MTA and/or NMS. What is the value this object is supposed to have in
various scenarios ? How this value is supposed to be set to the MTA ? 

2.  pktcSigDevToneNumFrequencies currently defined as follows:

   pktcSigDevToneNumFrequencies    OBJECT-TYPE   
       SYNTAX       INTEGER(5..16)  
       MAX-ACCESS   read-write   
       STATUS       current   
       DESCRIPTION   
         "This MIB Object specifies the number of frequencies 
          supported by the PacketCable MTA for each tone type."   
       ::={ pktcSigDevConfigObjects 33}   

As there are multiple tone types defined in the SIG MIB draft-08 for MTAs,
which one is being referred to in this object's description ? For exmaple,
which tone type the value being set would correspond to ? Also, what if NMS
tries to set the value of the number of frequencies NOT supported by the MTA
? 

Thanks,

Eugene Nechamkin,
Broadcom Corp.

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "David De Reu" <[email-masked]>
Date: Tue, 14 Jun 2005 09:36:45 +0200

>        MAX-ACCESS   not-accessible  
...
> The object is defined as being "not-accessable".

This was also the case in previous versions of the draft,
and did not seem to cause trouble?

> As there are multiple tone types defined in the SIG MIB
> draft-08 for MTAs, which one is being referred to in this
> object's description ?  For exmaple, which tone type the
> value being set would correspond to ?  Also, what if NMS
> tries to set the value of the number of frequencies NOT
> supported by the MTA ? 

Although I'm not one of the authors of these objects, I
suppose that they meant that this would be a pre-configured
value to indicate the MTA's capabilities, i.e. to tell the
NMS how many frequencies the MTA supports at a maximum. If
this is indeed the case, then the object should not be
read-write, but read-only instead.

Regards,

David

_____________________________________________________  
David De Reu
tComLabs
Stapelplein 70 - 9000 Ghent - Belgium
Tel: +32 9 269 22 91 - Fax: +32 9 329 31 74
www.tComLabs.com
_____________________________________________________