Subject: RE: [ipcdn] idnits and smilint on Cable Device MIB Draft 09

From: "Woundy, Richard" <[email-masked]>
Date: Sun, 24 Jul 2005 22:15:37 -0400

Randy,

Kevin Marez and I had an offline discussion about these deprecated
groups. We concluded that if CableLabs needs to specify the
implementation of these deprecated groups for interim compliance
testing, then that can be handled outside of the IETF standardization
process. So we have modified the current compliance statements so that
they do not include deprecated groups.

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Randy Presuhn
Sent: Monday, June 27, 2005 5:07 PM
To: Ipcdn (E-mail)
Subject: Re: [ipcdn] idnits and smilint on Cable Device MIB Draft 09 

Hi -

> From: "Marez Kevin-MGI1375" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Ipcdn \(E-mail\)"

> <[email-masked]>
> Sent: Monday, June 27, 2005 12:26 PM
> Subject: RE: [ipcdn] idnits and smilint on Cable Device MIB Draft 09
...
> Randy,
>
> Thanks very much for the speedy review!  Regarding your 'not-so-good 
> news',
>
>     I think what you wanted to say was that the old
docsDevCmCompliance
>     should be deprecated, and that there will be a
docDevCmComplianceRev1
>     (or whatever a good name would be) that has only the "current" 
> stuff from docsDevCmCompliance.  Alternatively, you could keep
the old compliance
>     stuff as-is, and just add a docDevCmComplianceRev1.  It depends on
the
>     message you want to send.
>
> we had actually discussed this previously and reached the following 
> conclusion (this was per an "internal" discussion with Rich
Woundy and others in response to the question of having compliance
statements contain deprecated objects):
>
> Hopefully the MIB doctors are OK with these compliance statements 
> as-is. Note the following text from the MIB guidelines, page 30 of 
> <http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guideli
> nes-03
> .txt>:
>
>    - The status of a compliance statement is independent of the status
>      of its members.  Thus, a current compliance statement MAY refer
to
>      deprecated object groups or notification groups.  This may be
>      desirable in certain cases, e.g., a set of widely-deployed object
>      or notification groups may be deprecated when they are replaced
by
>      a more up-to-date set of definitions, but compliance statements
>      that refer to them may remain current in order to encourage
>      continued implementation of the deprecated groups.
>
> Please let me know if this is acceptable.  Thanks very much,
...

It's ok with me if it's really the case that the WG wants to "encourage
continued implementation of the deprecated groups".  When I look at what
has actaully been deprecated, it's seems to me that that is not the
intent.

Randy

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 26 Jul 2005 11:41:37 -0700

Hi -

I'm happy with this approach.

Randy

----- Original Message ----- 
From: "Woundy, Richard" <[email-masked]>
To: "Randy Presuhn" <[email-masked]>
Cc: "Ipcdn (E-mail)" <[email-masked]>; "Woundy, Richard" <[email-masked]>
Sent: Sunday, July 24, 2005 7:15 PM
Subject: RE: [ipcdn] idnits and smilint on Cable Device MIB Draft 09

Randy,

-- Rich

-----Original Message-----

Hi -

...
docsDevCmCompliance
docDevCmComplianceRev1
the old compliance
the
to
by
...

Randy