Subject: RE: [ipcdn] RE: AD re-review:draft-ietf-ipcdn-docs-rfmibv2-13.txtTopic:docsIfCmtsQosProfilePermissions

From: "Eduardo Cardona" <[email-masked]>
Date: Thu, 25 Aug 2005 10:32:57 -0600

Randy, 

Just checking: is the intent of this to prohibit setting both bits?
Yes it is, as I interpret the text 

I believe is correct based on the meaning of either that refers to
select one of two options (http://en.wikipedia.org/wiki/Either)

Perhaps just following the link examples, adding a 'comma' would make
that more precise rather that changing the whole text?

           Either createByManagement(0), or updateByManagement(1)
           MUST be set when writing to this object.

I will be fine with "Either one option, or the other"  -:)

- Other technical questions might come up of this XOR exclusive issues
like :
If 'createByManagement' means that you can create entries but not delete
(*update), that could lead to undesired cases of exhausting the possible
entries and potential denial of service (?)  

In my impression that object should've been deprecated long time ago as
way to provide access to another table such docsIfQosProfileTable, but
we didn't.
Keep in mind that for DOCSIS 1.0, RFC 2670 (more, DOCSIS 1.0 ) didn't
contemplate SNMPv3 as DOCSIS 1.1 and 2.0 does, so those kind of access
control issues are now handled under the SNMPv3 framework, plus DOCSIS
1.1 and 2.0 does not use docIfQosProfileTable more than for backward
compatibility with DOCSIS 1.0 CMs. RFIv2 deals with extensions to
support DOCSIS 2.0 and not touching the DOCSIS 1.0 type of behaviors as
possible. We understand also the need to keep clear requirements as RFC
revision come and correct the previous non-clear definitions.

Thanks

Eduardo

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, August 24, 2005 10:12 PM
To: Ipcdn (E-mail)
Subject: Re: [ipcdn] RE: AD
re-review:draft-ietf-ipcdn-docs-rfmibv2-13.txtTopic:docsIfCmtsQosProfile
Permissions 

Hi -

> From: "Eduardo Cardona" <[email-masked]>
> To: "Wijnen, Bert (Bert)" <[email-masked]>; <[email-masked]>
> Cc: "Ipcdn (E-mail)" <[email-masked]>
> Sent: Wednesday, August 24, 2005 4:04 PM
> Subject: RE: [ipcdn] RE: AD re-review:
draft-ietf-ipcdn-docs-rfmibv2-13.txtTopic:
docsIfCmtsQosProfilePermissions
>
> Will update :
>
>           Either createByManagement(0) or updateByManagement(1)
>           MUST be set when writing to this object.
...

Just checking: is the intent of this to prohibit setting both bits?
If it is permissible to set both bits, then this language isn't quite
right,
an it might be better to say:
   Attempts to set both createByManagement(0) and updateByManagement(1)
   to zero MUST be rejected.

Randy

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 25 Aug 2005 10:53:53 -0700

Hi -

Ok, if XOR really is what is intended, there are two "legal" ways to
punctuate it:

 either
           Either createByManagement(0) or updateByManagement(1)
           MUST be set when writing to this object.
 or
           Either createByManagement(0), or updateByManagement(1),
           MUST be set when writing to this object.

That is, either no commas or two commas.  A single comma won't work
in this case.

I suggest changing "be set" to "be set to one", just to be painfully clear.

But the XOR itself sounds like an error,
though that's largely a moot point if the object is deprecated.

Randy

----- Original Message ----- 
From: "Eduardo Cardona" <[email-masked]>
To: "Randy Presuhn" <[email-masked]>; "Ipcdn (E-mail)" <[email-masked]>
Sent: Thursday, August 25, 2005 9:32 AM
Subject: RE: [ipcdn] RE: ADre-review:draft-ietf-ipcdn-docs-rfmibv2-13.txtTopic:docsIfCmtsQosProfilePermissions

Randy,

Thanks

Eduardo

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]]
Sent: Wednesday, August 24, 2005 10:12 PM
To: Ipcdn (E-mail)
Subject: Re: [ipcdn] RE: AD

Hi -

...

Randy