Subject: RE: [ipcdn] MTA MIB draft06 - pktcMtaDevProvKerbRealmName - objec t SYNTAX - AD Comment 31

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 12 Sep 2005 17:38:49 +0200

Not sure where you are with this, but... see inline

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Eugene Nechamkin
> Sent: Friday, September 09, 2005 02:17
> To: Thomas Anders; [email-masked]
> Subject: RE: [ipcdn] MTA MIB draft06 - pktcMtaDevProvKerbRealmName -
> object SYNTAX - AD Comment 31
> 
> 
> 
> Thomas, 
> 
> The sentence you pointed out must not be the part of 
> description as the
> RealmTable is not indexed by the pktcMtaDevRealmTable but by the
> pktcMtaDevRealmIndex instead (as you mentioned).
> 
> This sentence must be deleted from the DESCRIPTION clause of the
> pktcMtaDevProvKerbRealmName MIB Object.
> 
> Eugene.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of
> Thomas Anders
> Sent: Thursday, September 08, 2005 7:49 AM
> To: [email-masked]
> Subject: Re: [ipcdn] MTA MIB draft06 - 
> pktcMtaDevProvKerbRealmName - object
> SYNTAX - AD Comment 31
> 
> Jean-Francois Mule wrote:
> >>Proposed New MIB object def:
> >>pktcMtaDevProvKerbRealmName  OBJECT-TYPE
> >>       SYNTAX      SnmpAdminString (SIZE(1..255))
> >>       MAX-ACCESS  read-only
> >>       STATUS      current
> >>       DESCRIPTION
> >>           " This object contains the name of the associated
> >>             provisioning Kerberos realm acquired during the MTA4
> >>             provisioning step (DHCP Ack) for SNMPv3 provisioning.
> >>             This object value is used as an index into the
>                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> >>             pktcMtaDevRealmTable.
>                 ^^^^^^^^^^^^^^^^^^^^
> Isn't pktcMtaDevRealmTable now indexed with 
> pktcMtaDevRealmIndex instead??
> 

I hope the last sentence is true.
Because usning an SnmpAdminString that can be up to 255 octets
is problematic because an OID (including the index) can not
be more than 128 subIDs

Bert
>     pktcMtaDevRealmEntry  OBJECT-TYPE
>         SYNTAX      PktcMtaDevRealmEntry
>         MAX-ACCESS  not-accessible
>         STATUS      current
>         DESCRIPTION
>             " This table entry object lists the MTA security 
> parameters
>               for a single Kerberos realm. The conceptual 
> rows MUST NOT
>               persist across MTA reboots."
>         INDEX { pktcMtaDevRealmIndex }
> 
> 
> +Thomas
> 
> --
> Thomas Anders (thomas.anders at blue-cable.de)
> 
> _______________________________________________
> IPCDN mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipcdn
> 
> 
> 
> _______________________________________________
> IPCDN mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipcdn
> 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: Thomas Anders <[email-masked]>
Date: Mon, 12 Sep 2005 17:52:26 +0200

> Not sure where you are with this, but... see inline
[...]
> is problematic because an OID (including the index) can not

Eugene already agreed to remove the sentence "This object value is used 
as an index into the pktcMtaDevRealmTable." from the 
pktcMtaDevProvKerbRealmName DESCRIPTION. Looks like a leftover from the 
initial CableLabs version of PKTC-MTA-MIB.

+Thomas