Subject: [ipcdn] [Technical Errata Reported] RFC3083 (4048)

From: RFC Errata System <[email-masked]>
Date: Fri, 11 Jul 2014 08:02:59 -0700 (PDT)

The following errata report has been submitted for RFC3083,
"Baseline Privacy Interface Management Information Base for DOCSIS Compliant Cable Modems and Cable Modem Termination Systems".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3083&eid=4048

--------------------------------------
Type: Technical
Reported by: Mark Ellison <[email-masked]>

Section: 4

Original Text
-------------
start(1)

Corrected Text
--------------
start(1),

Notes
-----
errata # 334 for RFC3083 omits the necessary comma at the end of the inserted line 'start(1)'

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3083 (draft-ietf-ipcdn-mcns-bpi-mib-02)
--------------------------------------
Title               : Baseline Privacy Interface Management Information Base for DOCSIS Compliant Cable Modems and Cable Modem Termination Systems
Publication Date    : March 2001
Author(s)           : R. Woundy
Category            : INFORMATIONAL
Source              : IP over Cable Data Network
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Michael StJohns <[email-masked]>
Date: Fri, 11 Jul 2014 19:34:58 -0400

What a blast from the past.  

This is "not an error" , at least as reported.  Three are two places this error might have been reported from - the definition of  docsBpiCmAuthState and  the definition o fdocsBpiCmTEKState.  The former -  I believe correctly -does not include "start (1)" as one of its states.  The latter has "start (1),"  - e.g. including the comma.  So I'm not sure where he's actually seeing the error.

The  MIB  was verified at submission.  I would be surprised if there are any obvious syntactic errors like this in the body of the MIB.

If I remember correctly, the reason the "start" state was excluded from the docsBpiCmAuthState enums is that its never a visible state - the state machine doesn't actually exist until docsIfCmStatusValue is at least todEstablished - (RFC4546) and the state would always be later than "start" so any query about baseline privacy will not necessarily give you valid information prior to todEstablished.

Mike

At 11:02 AM 7/11/2014, RFC Errata System wrote:
>_______________________________________________
>IPCDN mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ipcdn

---

From: Mark Ellison <[email-masked]>
Date: Sat, 12 Jul 2014 07:55:50 -0400

Hi Guys,

Thanks for your reply.

My submission is in regard to the docsBpiCmAuthState object.  If you look
at the technical errata submitted here:
http://www.rfc-editor.org/errata_search.php?rfc=3083  then you will see the
comma is clearly omitted from the 'fixed' text:

It should say:
>
>    docsBpiCmAuthState      OBJECT-TYPE
>    SYNTAX                  INTEGER {
>
>                                    start(1)
>                                    authWait(2),
>                                    authorized(3),
>                                    reauthWait(4),
>                                    authRejectWait(5)
>

Maybe what you are saying is that the above fix is not required?  If so, it
is misleading...and either way, syntactically incorrect!

Regards,

Mark

On Fri, Jul 11, 2014 at 7:34 PM, Michael StJohns <[email-masked]>
wrote:

> This is "not an error" , at least as reported.  Three are two places this
> error might have been reported from - the definition of  docsBpiCmAuthState
> and  the definition o fdocsBpiCmTEKState.  The former -  I believe
> correctly -does not include "start (1)" as one of its states.  The latter
> has "start (1),"  - e.g. including the comma.  So I'm not sure where he's
> actually seeing the error.
>
> The  MIB  was verified at submission.  I would be surprised if there are
> any obvious syntactic errors like this in the body of the MIB.
>
> If I remember correctly, the reason the "start" state was excluded from
> the docsBpiCmAuthState enums is that its never a visible state - the state
> machine doesn't actually exist until docsIfCmStatusValue is at least
> todEstablished - (RFC4546) and the state would always be later than "start"
> so any query about baseline privacy will not necessarily give you valid
> information prior to todEstablished.
>
> Mike
>
>
>
> >"Baseline Privacy Interface Management Information Base for DOCSIS
> Compliant Cable Modems and Cable Modem Termination Systems".
> >
> >Title               : Baseline Privacy Interface Management Information
> Base for DOCSIS Compliant Cable Modems and Cable Modem Termination Systems

---

From: Michael StJohns <[email-masked]>
Date: Sat, 12 Jul 2014 09:29:19 -0400

Ok.  That makes sense.  I didn't realize Rich had posted an errata.  The "start" is extraneous but harmless, but does need the comma if present.  Mike

Sent from my iPad

> On Jul 12, 2014, at 7:55, Mark Ellison <[email-masked]> wrote:
> 
> Hi Guys,
> 
> Thanks for your reply.
> 
> My submission is in regard to the docsBpiCmAuthState object.  If you look at the technical errata submitted here: http://www.rfc-editor.org/errata_search.php?rfc=3083  then you will see the comma is clearly omitted from the 'fixed' text:
> 
>> It should say:
>> 
> Maybe what you are saying is that the above fix is not required?  If so, it is misleading...and either way, syntactically incorrect!
> 
> Regards,
> 
> Mark
> 
> 
>> On Fri, Jul 11, 2014 at 7:34 PM, Michael StJohns <[email-masked]> wrote:

---

From: "Woundy, Richard" <[email-masked]>
Date: Sat, 12 Jul 2014 14:44:29 +0000

Wow. I don't even remember why I submitted that errata, 13 years ago. And I left Cisco ([email-masked]<mailto:[email-masked]>) 12 years ago.

In any case, I agree with this submission.

-- Rich

On Jul 12, 2014, at 9:29 AM, "Michael StJohns" <[email-masked]<mailto:[email-masked]>> wrote:

Sent from my iPad

On Jul 12, 2014, at 7:55, Mark Ellison <[email-masked]<mailto:[email-masked]>> wrote:

Hi Guys,

Thanks for your reply.

It should say:

                                   start(1)
                                   authWait(2),
                                   authorized(3),
                                   reauthWait(4),
                                   authRejectWait(5)

Regards,

Mark

On Fri, Jul 11, 2014 at 7:34 PM, Michael StJohns <[email-masked]<mailto:[email-masked]>> wrote:
What a blast from the past.

Mike

At 11:02 AM 7/11/2014, RFC Errata System wrote:
>Reported by: Mark Ellison <[email-masked]<mailto:[email-masked]>>
>
>Section: 4
>
>Original Text
>-------------
>start(1)
>
>Corrected Text
>--------------
>start(1),
>
>Notes
>-----
>[email-masked]<mailto:[email-masked]>

---

From: Alice Russo <[email-masked]>
Date: Mon, 14 Jul 2014 10:01:14 -0400

Greetings,

With AD approval, Errata ID 334 has been corrected as indicated: 
http://www.rfc-editor.org/errata_search.php?eid=334

Errata ID 4048 has been removed from the system because it was an erratum for an erratum. (In the future, please direct corrections to existing errata to [email-masked].)

Thank you.
RFC Editor/ar

On Jul 12, 2014, at 10:44 AM, Woundy, Richard <[email-masked]> wrote:

> Wow. I don't even remember why I submitted that errata, 13 years ago. And I left Cisco ([email-masked]) 12 years ago.
> 
> On Jul 12, 2014, at 9:29 AM, "Michael StJohns" <[email-masked]> wrote:
>