Subject: RE: Question about WW_NN and RFC 2625

From: "Murali Rajagopal" <[email-masked]>
Date: Mon, 12 Feb 2001 13:30:47 -0800

Jon:

I have to agree that the document does not spell it out.

I also agree that there no reason not to allow other NAA types for WW_NN.

But when you consider FARP, there is an implication that the WW_PN and WW_NN
use the same NAA Type. (Nobody said anything about a different NAA type
during FARP discussions!)

Hope this clarifes what I said.

-Murali
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Infante, Jon
Sent: Thursday, January 11, 2001 4:28 PM
To: Murali Rajagopal
Cc: Weber, William L; IPFC Mailing List (E-mail)
Subject: Re: Question about WW_NN and RFC 2625

Murali,

I disagree. The Fibre Channel Network header ONLY contains the
WWPN. That is the main reason the NAA for the WWPN must
be 1 (mapping MAC addresses to WWPNs).

Correct me if I'm wrong. however, I don't see any  technical reason
for the WWNN NAA to be 1 nor did I infer that was the intent of
the many discussions the group had on this topic???

Jon

Murali Rajagopal wrote:

> The intent was NAA=1 for both.
> If it did not get reflected, then it was an oversight.
>
> -Murali
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Infante, Jon
> Sent: Thursday, January 11, 2001 8:13 AM
> To: Weber, William L
> Cc: IPFC Mailing List (E-mail)
> Subject: Re: Question about WW_NN and RFC 2625
>
> Bill,
>
> My understanding is that only the World Wide Port Name requires NAA = 1.
> It is not a requirement for the World Wide Node Name to have NAA = 1;
>
> Jon Infante
> Emulex
>
> "Weber, William L" wrote:
>
> > I have a question concerning RFC 2625, IP and ARP over Fibre Channel,
and
> > Network_Address_Authority (NAA) of World Wide Names (WWN).  I thought
this
> > would be the proper forum to present the question.
> > The question is:
> >    Can the Node WWN (WW_NN) use NAA=5 for IEEE registered format and
still
> > be
> >    compliant/compatible with RFC 2625?
> >
> > I understand that the RFC 2625 requires the Port WWN (WW_PN) to use NAA
=
> 1
> > for IEEE 48-bit addresses.  RFC 2625 does not explicitly state the NAA
for
> > the WW_NN, however the examples in Appendix E (i.e. E.4.2) show the
WW_NN
> > with NAA=1.
> >
> > Thanks,
> > // Bill Weber               Phone: +1-610-648-7022
> > // Unisys Corporation       Fax:   +1-610-648-4010
> > // 2476 Swedesford Rd.      mailto:[email-masked]
> > // Malvern, PA 19355-9700

---

From: "Infante, Jon" <[email-masked]>
Date: Mon, 12 Feb 2001 14:56:13 -0800

Murali,

I agree that the document does not spell it out and that there no reason not to
allow other NAA types for WWNN.

With regards to FARP, I thought special consideration was given to make FARP a
generic ELS command and not specifically tie it to our IP Profile. Thus the WWPN
and WWNN in the FARP payload specifies the full 8 byte WWN and not just the last
6 bytes as in a IEEE address.

Considering you can specify  the full 8 byte WWNN, the full 8 byte WWPN and the
Match Address Code Points specify match on just the WWNN, just the WWPN, or
both, I don't feel there is any implication that the WWPN and WWNN use the same
NAA Type. In fact, I don't think the FARP chapter mentions NAA at all.

Jon

---

From: "Murali Rajagopal" <[email-masked]>
Date: Mon, 12 Feb 2001 15:42:36 -0800

Jon:

I fully agree with your statements. They are technically accurate.

A guess it helps to assert that a different NAA type for the WW_NN
should be allowed. This should put to rest any subjective interpretations
such as mine and others (we would not be having a email discussion on this
at this time).

Regards,

Murali

-----Original Message-----
Sent: Monday, February 12, 2001 2:56 PM

Murali,

I agree that the document does not spell it out and that there no reason not
to
allow other NAA types for WWNN.

With regards to FARP, I thought special consideration was given to make FARP
a
generic ELS command and not specifically tie it to our IP Profile. Thus the
WWPN
and WWNN in the FARP payload specifies the full 8 byte WWN and not just the
last
6 bytes as in a IEEE address.

Considering you can specify  the full 8 byte WWNN, the full 8 byte WWPN and
the
Match Address Code Points specify match on just the WWNN, just the WWPN, or
both, I don't feel there is any implication that the WWPN and WWNN use the
same
NAA Type. In fact, I don't think the FARP chapter mentions NAA at all.

Jon