Subject: RE: [ipfix] No uint128 and double types in Info Model

From: "Thomas Dietz" <[email-masked]>
Date: Fri, 21 Oct 2005 09:02:10 +0200

Dear Carsten,

Do you have any IE that needs double precision floats or 128 bit ints then
it is ok to insert the data type. But since there is currently not even the
need for single precision float I think also defining those data types just
introduces unneeded complexity and programming effort.

Regards,

Thomas

-- 
Thomas Dietz                       E-mail: [email-masked]
Network Laboratories               Phone:  +49 6221 90511-28
NEC Europe Ltd.                    Fax:    +49 6221 90511-55
Kurfuersten-Anlage 36
69115 Heidelberg, Germany          http://www.netlab.nec.de

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of Carsten Schmoll
> Sent: Thursday, October 20, 2005 12:17 PM
> To: [email-masked]
> Subject: [ipfix] No uint128 and double types in Info Model
> 
> 
> Dear all,
> 
> I'd like to suggest for completeness to also include
> unsigned int and double precision float types into the
> info model draft. I have attached a suggested text for this.
> 
> Also I would like to change
>    The type "macAddress" represents a string of 6 octets.
> to
>    The type "macAddress" represents a set of 6 octets.
> to avoid confusion (MAC address is not a string)
> 
> What do you think?
> 
> Kind regards,
> Carsten.
> 
> PS: what about 'signed' integer types, will they never be needed?
> 
> -- 
> "The difference between theory and practice is that in theory 
>  theory and practice are the same but in practice they are not."
> 
> Dipl.Ing. Carsten Schmoll                Fraunhofer Institute FOKUS
> [email-masked]      National Research Institute
> Fraunhofer FOKUS / dept. METEOR          for Open 
> Communication Systems
> Tel: +49-30-3463-7136                    Kaiserin-Augusta-Allee 31
> Fax: +49-30-3463-8000                    D-10589 Berlin, Germany
> 
>

---

From: Carsten Schmoll <[email-masked]>
Date: Fri, 21 Oct 2005 10:35:49 +0200

Dear Thomas, all,

I'm currently working in a project where we will make use of float type
within our prototypes which uses IPFIX for measurement data results transfer
including various QoS related values, among them percentage values.

In out case this includes definition of some Enterprise-specific IEs, 
one of
which is a float (and a double would be even better).

So I think in light of Enterprises which might need to have to transfer 
IEs of
those types I think we should have them clearly stated in the standard 
even if
we no non-Enterprise IEs will make use of them.

The extension of an implementation with those two extra types is IMHO
quite straightforward.

Best regards,
Carsten.

Fraunhofer FOKUS / dept. METEOR          for Open Communication Systems