Subject: [ipfix-info] IPFIX and PSMAP information model: applicability field

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 12:37:54 +0100

Dear all,

The IPFIX IE's have a property that's not directly displayed in the 
draft, except in the XML: "applicability".

The history behind this "applicability" field is that it should have 
been used as a guideline, expressing whether a specific Information 
Element should be used in a data record, an option record or both of 
them. However, the property is used in [IPFIX-INFO] without any 
definition - except the values are "option", "data" and "all".

While working on the PSAMP information elements, we concluded that this 
"applicability" field doesn't make sense anymore.
1. It's a guideline anyway, not a specification
2. It's present in the XML text only, while the non-XML text is the 
authoritative source
3. There are no definitions

So the proposal is to remove this "applicability" field from both 
[IPFIX-INFO] and [PSAMP-INFO].
Feedback?

Regards, Benoit.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 03 Mar 2006 14:02:16 +0100

Benoit,

I fully agree to your proposal.

    Juergen

--On 3/3/06 12:37 PM +0100 Benoit Claise wrote:

> Dear all,
>
> The IPFIX IE's have a property that's not directly displayed in the draft, except in the XML: "applicability".
>
> The history behind this "applicability" field is that it should have been used as a guideline, expressing whether a specific Information Element should be used in a data record, an option record or both of them. However, the property is used in
> [IPFIX-INFO] without any definition - except the values are "option", "data" and "all".
>
> While working on the PSAMP information elements, we concluded that this "applicability" field doesn't make sense anymore.
> 2. It's present in the XML text only, while the non-XML text is the authoritative source
> So the proposal is to remove this "applicability" field from both [IPFIX-INFO] and [PSAMP-INFO].
> Feedback?
>
> Regards, Benoit.
>
>
>
>
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/psamp/>

---

From: Falko Dressler <[email-masked]>
Date: Fri, 03 Mar 2006 14:05:37 +0100

Dear Benoit, dear all,

I agree to remove it from the *-info documents. Nevertheless, I think it
should be moved to the forthcoming guidelines.

Cheers,
Falko

-- 
Dr.-Ing. Falko Dressler
Computer Networks and Communication Systems
University of Erlangen-Nuremberg, Germany
Phone: +49 9131 85-27914 / Fax: +49 9131 85-27409
EMail: [email-masked] / [email-masked]
WWW: http://www7.informatik.uni-erlangen.de/~dressler/

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 16:02:08 +0100

Dear Falko,
> should be moved to the forthcoming guidelines.
That would make sense for the I.Es. that clearly belong to a category.

Regards, Benoit.