Subject: [IPFIX] ipfix reducing redundancy

From: Ma Yuzhi <[email-masked]>
Date: Mon, 18 Sep 2006 19:30:03 +0800

Here are  two questions about the ipfix reducing redundancy draft:

Section 5.1 SCTP - The Common Properties Flow Records MUST be sent on a
reliable SCTP stream.
Does this  mean PR-SCTP is not one of the transport protocol choice?  
Is there need some description of how to use PR-SCTP in this draft?

Thanks
Yuzhi

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: "Boschi, Elisa" <[email-masked]>
Date: Tue, 19 Sep 2006 18:24:27 +0200

Yuzhi,

guidelines on how to use SCTP streams are out of scope in this draft. They're addressed in the Implementation Guidelines 

Regards,
Elisa

-----Original Message-----
From: Ma Yuzhi [mailto:[email-masked]]
Sent: Tue 9/19/2006 1:12 PM
To: 'Benoit Claise'
Cc: [email-masked]
Subject: RE: [IPFIX] ipfix reducing redundancy
 
Hi Benoit,
 
The below changes are fine to me.
But how to get/keep a realiable stream of PR-SCTP?   
I'm not sure whether it need further description in this draft.
 
Yuzhi

  _____  

From: Benoit Claise [mailto:[email-masked]] 
Sent: Tuesday, September 19, 2006 5:36 PM
To: Ma Yuzhi
Cc: [email-masked]
Subject: Re: [IPFIX] ipfix reducing redundancy

Hi Yuzhi,

reliable SCTP stream.

Yes it is.  But I agree that the draft is not explicit about it. It will be
changed.
I have a pile of editorial changes to be applied:
For example, section 4.1.1

As explained in Figure 8, the information is split into two parts, using two
different Data Records.  Common Properties MUST be exported via Data Records
defined by an Option Template Record and MUST be sent only once with SCTP or
TCP. 

Based on your comment, it should even be: 

As explained in Figure 8, the information is split into two parts, using two
different Data Records.  Common Properties MUST be exported via Data Records
defined by an Option Template Record and MUST be sent only once with the
reliable stream of PR-SCTP association or within the  TCP connection.

Section 5.1 PR-SCTP (it's only SCTP right now)

	OLD: If SCTP is selected as the IPFIX protocol, the SCTP sub-section

   specifications MUST be respected.

	New: If PR-SCTP is selected as the IPFIX protocol, the SCTP
sub-section 

   specifications MUST be respected.

Then the following sentence would make sense in section 5.1:

   "The Common Properties Flow Records MUST be sent on a reliable SCTP 

   stream. "

Regards, Benoit. 

Thanks

Yuzhi

IPFIX mailing list

[email-masked]

---

From: "Boschi, Elisa" <[email-masked]>
Date: Tue, 19 Sep 2006 18:24:27 +0200

Yuzhi,

Regards,
Elisa

-----Original Message-----
From: Ma Yuzhi [mailto:[email-masked]]
Sent: Tue 9/19/2006 1:12 PM
To: 'Benoit Claise'
Cc: [email-masked]
Subject: RE: [IPFIX] ipfix reducing redundancy
 
Hi Benoit,

Yuzhi

  _____  

Hi Yuzhi,

reliable SCTP stream.

   stream. "

Regards, Benoit. 

Thanks

Yuzhi

IPFIX mailing list

[email-masked]