Subject: [IPFIX] Re: Specific Properties

From: "Boschi, Elisa" <[email-masked]>
Date: Fri, 8 Dec 2006 10:55:47 -0000

Andrew Johnson wrote:

>> ...
>
>> "...The rows are then referenced by the Specific Properties by using the appropriate value for the Common Properties identifier."
>> and
>>  "... The rows are then referenced by Data Records by using the appropriate value for the Common Properties identifier."
>>
>> do not mean the same thing and can be confusing.
>>
>> Specific Properties are just a subset of the Data Record's fields, a subset which is complementary to the Common Properties
>
>
> OK, this is where I have a problem.  As I keep explaining, a Data
> Record has a very specific definition.  It is defined by an IPFIX
> Template and is sent by and Exporting Process to a Collecting Process.
>
> The Reducing Redundancy feature is applied to a Flow (or packet data)
> BEFORE it is exported.  Therefore you don't have a Data Record at
> this point.

but when you start exporting you have two different ones: one Data Record for the Common Properties and one Data Record for the Specific Properties. So using "Data Record" in:

"... The rows are then referenced by Data Records by using the appropriate value for the Common Properties identifier."

doesn't help people understanding that the rows are referenced by the Data Records exporting the Specific Properties by....

>>
>> I think it makes the whole draft clearer and easier to understand. Specific Properties are complementary to Common Properties, everything has a name...
>> we will not have to use things like "fileds of the Data Record which are not Part of the Common Properties"...
>
>
> Why does it need a name, or more specifically a Name?  The terminology
> section of the draft already runs to 6 pages!  That's about 25% of the
> whole document, including boilerplate and detailed examples.

this is not a reason for removing a (one!) useful definition.

Elisa

**************************************************************************************************
 
 E-mail Confidentiality Notice and Disclaimer.
 
  This email and any files transmitted with it are confidential and are intended solely for 
the use of the individual or entity to which they are addressed. Access to this e-mail by 
anyone else is unauthorised. If you are not the intended recipient, any disclosure, 
copying, distribution or any action taken or omitted to be taken in reliance on it, is 
prohibited. 
  E-mail messages are not necessarily secure.  Hitachi does not accept responsibility 
for any changes made to this message after it was sent. 
  Please note that Hitachi checks outgoing e-mail messages for the presence of 
computer viruses.

**************************************************************************************************
_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Andrew Johnson <[email-masked]>
Date: Fri, 08 Dec 2006 12:08:50 +0000

Boschi, Elisa wrote:
[SNIP]
> but when you start exporting you have two different ones: one Data 
> Record for the Common Properties and one Data Record for the Specific 
> Properties. So using "Data Record" in:
> 
> "... The rows are then referenced by Data Records by using the 
> appropriate value for the Common Properties identifier."
> 
> doesn't help people understanding that the rows are referenced by the 
> Data Records exporting the Specific Properties by....

On a side note, with Cascading Common Properties we can see that
a Data Record with either Flow data or option data can contain a
cpID.

I know this isn't really what we're discussing here though.  My point
is that you keep referring to the Data Record as something that exists
before export.

I really don't mind how you describe the Data Records that are being
used to export the specific properties of the Flow data, as long as
it is clear and accurate.

>  >> I think it makes the whole draft clearer and easier to understand. 
> Specific Properties are complementary to Common Properties, everything 
> has a name...
>  >> we will not have to use things like "fileds of the Data Record which 
> are not Part of the Common Properties"...
>  >
>  >

I just don't think it is a useful definition, but I don't feel that
strongly.

Andrew

---

From: Andrew Johnson <[email-masked]>
Date: Fri, 08 Dec 2006 12:08:50 +0000

Boschi, Elisa wrote:
[SNIP]

Andrew