Subject: [IPFIX] Specific Properties

From: "Boschi, Elisa" <[email-masked]>
Date: Fri, 8 Dec 2006 09:26:52 -0000

Andrew,

I've changed the subject to help us keeping track of the different threads...

>
>
>>  >>> Is there any need to define a new term for "Specific
>>  >>> Properties"? These are just part of a normal Data Record.
>>  >>> For example:
>>  >>> "... The rows are then referenced by the Specific Properties
>>  >>> by using the appropriate value for the Common Properties
>>  >>> identifier."
>>  >>>
>>  >>> could simply be:
>>  >>> "... The rows are then referenced by Data Records by
>>  >>> using the appropriate value for the Common Properties
>>  >>> identifier."
>>  >>
>>  >>
>>  >> In your example, the "Data Records" doesn't mean the full data
>>  >> records before applying the redundancy reduction mechanism but only  >> a part of it.
>>  >> So it might be confusing... That's the trick we found.
>>  >
>>
>> The Specific Properties are "what is left" of the Data Record when the Common Properties have been defined. In your example above using Data Records is wrong...
>
> Wrong?  It wouldn't be the first time, but perhaps you would like to
> explain your reasoning for saying so.

"...The rows are then referenced by the Specific Properties by using the appropriate value for the Common Properties identifier."
and
 "... The rows are then referenced by Data Records by using the appropriate value for the Common Properties identifier."

do not mean the same thing and can be confusing.

Specific Properties are just a subset of the Data Record's fields, a subset which is complementary to the Common Properties

Of course then both Common Properties and Specific Properties will eventually be exported in Data Records, but it is not too clear which Data Records you are referring to in the text above...

(ok so maybe instead of "wrong" it is just "confusing")

>
> A Flow is handed from the Metering Process to the Exporting Process.
> The Exporting Process performs some magic, possibly including some
> reducing redundancy type stuff and produces and IPFIX export stream.
>
>> From IPFIX-PROTO:
> Data Record   A Data Record is a record that contains values of the parameters   corresponding to a Template Record...
>
> The Data Records are something that the Exporting Process produces,
> it is not right to talk about Data Records before something is
> exported.
>
>
>> Using the term Specific Properties seems clearer... (and it seemed intuitive after the term Common Properties had been used)
>
> By all means say that the Data Record that is sent contains properties
> specific to the Flow.  I'm not complaining about calling them specific
> properties, but I don't think there is any need to have a new definition
> of "Specific Properties".

I think it makes the whole draft clearer and easier to understand. Specific Properties are complementary to Common Properties, everything has a name...
we will not have to use things like "fileds of the Data Record which are not Part of the Common Properties"...

Regards,
Elisa

**************************************************************************************************
 
 E-mail Confidentiality Notice and Disclaimer.
 
  This email and any files transmitted with it are confidential and are intended solely for 
the use of the individual or entity to which they are addressed. Access to this e-mail by 
anyone else is unauthorised. If you are not the intended recipient, any disclosure, 
copying, distribution or any action taken or omitted to be taken in reliance on it, is 
prohibited. 
  E-mail messages are not necessarily secure.  Hitachi does not accept responsibility 
for any changes made to this message after it was sent. 
  Please note that Hitachi checks outgoing e-mail messages for the presence of 
computer viruses.

**************************************************************************************************
_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Andrew Johnson <[email-masked]>
Date: Fri, 08 Dec 2006 10:42:21 +0000

Boschi, Elisa wrote:
>  >> The Specific Properties are "what is left" of the Data Record when 
> the Common Properties have been defined. In your example above using 
> Data Records is wrong...
>  >
> "...The rows are then referenced by the Specific Properties by using the 
> appropriate value for the Common Properties identifier."
> and
>  "... The rows are then referenced by Data Records by using the 
> appropriate value for the Common Properties identifier."
> 
> Specific Properties are just a subset of the Data Record's fields, a 
> subset which is complementary to the Common Properties

OK, this is where I have a problem.  As I keep explaining, a Data
Record has a very specific definition.  It is defined by an IPFIX
Template and is sent by and Exporting Process to a Collecting Process.

The Reducing Redundancy feature is applied to a Flow (or packet data)
BEFORE it is exported.  Therefore you don't have a Data Record at
this point.

Get your terminology straight!

> Of course then both Common Properties and Specific Properties will 
> eventually be exported in Data Records, but it is not too clear which 
> Data Records you are referring to in the text above...
> 
>  > Data Record   A Data Record is a record that contains values of the 
> parameters   corresponding to a Template Record...
>  >
>  >> Using the term Specific Properties seems clearer... (and it seemed 
> intuitive after the term Common Properties had been used)
>  >
> I think it makes the whole draft clearer and easier to understand. 
> Specific Properties are complementary to Common Properties, everything 
> has a name...

Why does it need a name, or more specifically a Name?  The terminology
section of the draft already runs to 6 pages!  That's about 25% of the
whole document, including boilerplate and detailed examples.

Call them specific properties by all means, but you don't need a formal
definition of the name.

Andrew

---

From: Andrew Johnson <[email-masked]>
Date: Fri, 08 Dec 2006 10:42:21 +0000

Andrew