Subject: [IPFIX] IPfix implementation

From: Jonas Arnsmann <[email-masked]>
Date: Tue, 12 Dec 2006 18:50:13 +0100

Hi,

I am currently implementing an IPfix simulation using the Reliable
Server Pooling Framework [1] using the discrete event simulation system
Omnet++ [2]
During my research on the internet I was unable to find an opensource
implementation of the IPfix protocol. Does someone on this list know of
such a project? I would like to perform some general IPfix tests with
a working "prototype"...

Thank you so much in advance!

Regards,

Jonas Arnsmann
Bsc. Network Systems Engineering
University of Duisburg-Essen, Germany

[1] http://tdrwww.exp-math.uni-essen.de/dreibholz/rserpool/
[2] http://www.omnetpp.org

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Wed, 13 Dec 2006 11:13:01 +0100

Dear Jonas,

you may want to try one of the following software packages:

LIBIPFIX
http://libipfix.sourceforge.net/
    Organisation: Fraunhofer FOKUS
    Description: C library, distributed under the BSD license. Full
support for SCTP, UDP, TCP, IPv4 and IPv6. Runs on Linux, FreeBSD, and
Solaris.

NTOP
http://www.ntop.org/
    Organisation: ntop.org
    Description: distributed under the GPL2 license. Runs on Linux.

FIXBUF
http://tools.netsa.cert.org/fixbuf/
    Organisation: CERT / NetSA
    Description: C library, distributed under the LGPL license. Includes
a Metering/Exporting process (http://tools.netsa.cert.org/yaf/) that can
be used for testing purposes. Runs on MacOS.

VERMONT
http://vermont.berlios.de/
    Organisations: Universities of Erlangen-Nuremberg and Tuebingen
    Description: Runs over Linux and BSD, released under the GPL license

Good luck with your simulation and let us know what you found out.
(or just post the link to the paper you write afterwards on the results
;)

On the respective web pages you'll also find out on how to contact the 
tool's authors in case of any questions.

Hope this helps,
Carsten.

> -----Original Message-----
> From: Jonas Arnsmann [mailto:[email-masked]]
> Sent: Tuesday, December 12, 2006 6:50 PM
> To: [email-masked]
> Subject: [IPFIX] IPfix implementation
>
> Hi,
>

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Wed, 13 Dec 2006 11:13:01 +0100

Dear Jonas,

LIBIPFIX

NTOP
http://www.ntop.org/
    Organisation: ntop.org

FIXBUF

VERMONT

Hope this helps,
Carsten.