Subject: Re: [IPFIX] Fwd: Template Set padding issue

From: Benoit Claise <[email-masked]>
Date: Mon, 11 Dec 2006 21:18:59 +0100

Brian, all,

At the time of this post, the last protocol draft, which is now in the 
RFC-editor queue, was submitted already.
After inquiring with the WG chairs and area director, we could still 
apply the change during the 48-hours review.

The change is simple, and consistent throughout the document. It doesn't 
change the protocol, it's just a terminology clarification:
   "Template Withdrawal Message" should be replaced by "Template 
Withdrawal Set"
   "Template Withdraw Message" should be replaced by "Template 
Withdrawal Set"  (*)

(*) required because I just realized that we still have two terms in the 
current draft: Template Withdrawal Message and Template Withdraw 
Message. This should be corrected.

Note that the protocol draft is the only document impacted by those changes.
Does someone object these changes?

Regards, Benoit.
>
> On Nov 8, 2006, at 10:38 AM, Paul Aitken wrote:
>
>> Actually, it seems to me that "Template Withdrawal Message" is a 
>> misnomer: it's really a Template Withdrawal *Set*, and what's 
>> important is that you don't try to define new templates in the same 
>> set - else you might end up in the situation Brian described earlier.
>>
>> I don't see a problem with sending both Template withdrawals and 
>> Option Template withdrawals as two sets in the same IPFIX message, 
>> nor with sending a mixture of templates and withdrawals in different 
>> sets in the same message.
>>
>> I think it'd be a lot clearer if the "Template Withdrawal Message" 
>> was renamed to "Template Withdrawal Set" and this text:
>>
>>    The Template Withdraw Message MUST NOT contain new Template or
>>    Options Template Records.
>>
>> was changed to:
>>
>>    The Template Withdraw Set MUST NOT contain new Template or
>>    Options Template Records.
>
> Absolutely. Benoit: are we at a state with the protocol now (sorry!) 
> that we could make this change?
>
> - Brian

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Benoit Claise <[email-masked]>
Date: Mon, 11 Dec 2006 21:18:59 +0100

Brian, all,

Regards, Benoit.

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Dec 2006 22:08:31 +0100

Hi Benoit and all,

Now that I have read the concerned section 8 of IPFIX-PROTO again,
I found some more beautifications that seem to be desirable.

1. Section 8, paragraph 11: A Template Withdrawal Message/Set is NOT
   a Template Record.
OLD:
   A Template Withdraw Message is a Template Record for that Template
   ID with a Field Count of 0. The format of the Template Withdrawal
   Message is shown in figure T.
NEW:
   A Template Withdrawal Set contains a Template Record for that Template
   ID with a Field Count of 0. The format of the Template Withdrawal Set
   is shown in figure T.

2. Section 8, paragraph 12: not a Template Set is withdrawn, but
   Templates themselves are.
OLD:
   The Set ID field MUST contain the value 2 for Template Set withdrawal
   and the value 3 for Options Template Set withdrawal.  Multiple
   Template IDs MAY be withdrawn with a single Template Withdrawal
   Message: in that case, padding MAY be used.
NEW:
   The Set ID field MUST contain the value 2 for a Template Withdrawal
   Set and the value 3 for an Option Template Withdrawal Set.  Multiple
   Template IDs MAY be withdrawn with a single Template Withdrawal
   Set: in that case, padding MAY be used.

3. Section 8, paragraph 15: If we replaced Message with Set here, we
   would change the protocol. Therefore I'd suggest the following change.
OLD:
   The Template Withdraw Message MUST NOT contain new Template or
   Options Template Records.
NEW:
   An IPFIX Message containing any Template Withdrawal MUST not contain
   new Templates or Option Templates and it MUST NOT contain Option
   Template Records.

Thanks,

    Juergen

--On 11.12.06 21:18 +0100 Benoit Claise wrote:

> Brian, all,
>
> At the time of this post, the last protocol draft, which is now in the RFC-editor queue, was submitted already.
> After inquiring with the WG chairs and area director, we could still apply the change during the 48-hours review.
>
> The change is simple, and consistent throughout the document. It doesn't change the protocol, it's just a terminology clarification:
>    "Template Withdrawal Message" should be replaced by "Template Withdrawal Set"
>    "Template Withdraw Message" should be replaced by "Template Withdrawal Set"  (*)
>
> (*) required because I just realized that we still have two terms in the current draft: Template Withdrawal Message and Template Withdraw Message. This should be corrected.
>

-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 4342-115
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 4342-155
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Dec 2006 22:08:31 +0100

Hi Benoit and all,

Thanks,

    Juergen

---

From: Paul Aitken <[email-masked]>
Date: Mon, 11 Dec 2006 21:13:18 +0000

Seconded.

Brian Trammell wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> All,
> 
> Looks good to me.
> 
> Thanks,
> 
> Brian
> 
> Benoit Claise wrote:
>> Brian, all,
>>

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Paul Aitken <[email-masked]>
Date: Mon, 11 Dec 2006 21:13:18 +0000

Seconded.

---

From: Brian Trammell <[email-masked]>
Date: Mon, 11 Dec 2006 16:01:29 -0500

All,

Looks good to me.

Thanks,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Mon, 11 Dec 2006 16:01:29 -0500

All,

Looks good to me.

Thanks,

Brian