Subject: [IPFIX] Sending export packet

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Wed, 13 Dec 2006 10:14:58 +0530

Hello All,

 Need clarification in below quote from RFC 3954:

"Two approaches are taken to make sure
that Templates get refreshed at the Collector:
    * Every N number of Export Packets.
    * On a time basis, so every N number of minutes. "

Any specific reason for having two approaches to send export packet?

Regards,

Bhuvaneswari.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Paul Aitken <[email-masked]>
Date: Wed, 13 Dec 2006 10:43:35 +0000

Bhuvaneswari,

> “Two approaches are taken to make sure
> 
>     * On a time basis, so every N number of minutes. ”
> 
>  
> 

This is only needed when you're exporting over an unreliable transport.

You need to refresh the template regularly, else it will time out on the 
collector and be expired. Thus the requirement for time based refresh.

However, it's possible that the template was lost in transmission or the 
collector was configured with a shorter timeout than the exporter.

So exporting the template every N packets gives you greater assurance 
that your data isn't simply being discarded by the collector because it 
doesn't have the necessary template. This is especially important as 
your export rate grows.

N represents the number of export packets that you care to have 
discarded for this reason - though there's no guarantee, because the 
N'th packet carrying the template could be lost itself.

The worst case would be to send the template in every message - but 
that's terribly inefficient;at that point you would be better to 
consider a reliable export transport.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Paul Aitken <[email-masked]>
Date: Wed, 13 Dec 2006 10:43:35 +0000

Bhuvaneswari,