Subject: [IPFIX] Sending export packet

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Wed, 13 Dec 2006 10:14:58 +0530

Hello All,

 Need clarification in below quote from RFC 3954:

"Two approaches are taken to make sure
that Templates get refreshed at the Collector:
    * Every N number of Export Packets.
    * On a time basis, so every N number of minutes. "

Any specific reason for having two approaches to send export packet?

Regards,

Bhuvaneswari.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Thu, 14 Dec 2006 09:53:24 +0530

My question was why don't we go ahead with just one approach. Time based
or packet based ? why do we need to implement both approaches.

-----Original Message-----
From: Paul Aitken [mailto:[email-masked]] 
Sent: Wednesday, December 13, 2006 4:14 PM
To: Bhuvaneswari R P - TLS ,Chennai
Cc: [email-masked]
Subject: Re: [IPFIX] Sending export packet

Bhuvaneswari,

> Any specific reason for having two approaches to send export packet?

This is only needed when you're exporting over an unreliable transport.

You need to refresh the template regularly, else it will time out on the

collector and be expired. Thus the requirement for time based refresh.

However, it's possible that the template was lost in transmission or the

collector was configured with a shorter timeout than the exporter.

So exporting the template every N packets gives you greater assurance 
that your data isn't simply being discarded by the collector because it 
doesn't have the necessary template. This is especially important as 
your export rate grows.

N represents the number of export packets that you care to have 
discarded for this reason - though there's no guarantee, because the 
N'th packet carrying the template could be lost itself.

The worst case would be to send the template in every message - but 
that's terribly inefficient;at that point you would be better to 
consider a reliable export transport.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

DISCLAIMER:

---

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Thu, 14 Dec 2006 13:56:42 +0530

Thanks Thomas.
I got confused by the below statement in the RFC.

"Both options MUST be configurable by the user on the Exporter"

I assumed we need to implement both approaches. OK. Now I understand
that I can implement one of the approaches for that approach, the
packet/time should be configurable. Hope my understanding I right.

Regards,
Bhuvana.

-----Original Message-----
From: Thomas Dietz [mailto:[email-masked]] 
Sent: Thursday, December 14, 2006 1:50 PM
To: Bhuvaneswari R P - TLS ,Chennai; Paul Aitken
Cc: [email-masked]
Subject: RE: [IPFIX] Sending export packet

Bhuvaneswari,

As an exporter you just need to implement one of the two approaches. We
have
those two approaches because it may be convenient for one expoter to do
it
time based an for the other one to do it based on the number of packets.
If
you have a rather low volume of flows to export the packet approach is
better. But if you export a high number of flows the time based approach
may
be more feasable.

As a generic collector you must be prepared for both. (If you just build
a
special collector knowing to receive only flows with one approach you
just
need to implement that.)

Best Regards,

Thomas

-- 
Thomas Dietz
Network Laboratories, NEC Europe Ltd., 69115 Heidelberg, Germany

> From: Bhuvaneswari R P - TLS ,Chennai [mailto:[email-masked]] 
> Sent: Thursday, December 14, 2006 5:23 AM
> To: Paul Aitken
> Cc: [email-masked]
> Subject: RE: [IPFIX] Sending export packet
> 
> 
> --------------------------------------------------------------
> ---------------------------------------------------------
> 
> The contents of this e-mail and any attachment(s) are 
> confidential and intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or 
> its affiliates. Any views or opinions presented in 
> this email are solely those of the author and may not 
> necessarily reflect the opinions of HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure, 
> modification, distribution and / or publication of 
> this message without the prior written consent of the author 
> of this e-mail is strictly prohibited. If you have
> received this email in error please delete it and notify the 
> sender immediately. Before opening any mail and 
> --------------------------------------------------------------
> ---------------------------------------------------------
>

---

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Thu, 14 Dec 2006 13:56:42 +0530

Thanks Thomas.

Regards,
Bhuvana.

-----Original Message-----
From: Thomas Dietz [mailto:[email-masked]] 
Sent: Thursday, December 14, 2006 1:50 PM
To: Bhuvaneswari R P - TLS ,Chennai; Paul Aitken
Cc: [email-masked]
Subject: RE: [IPFIX] Sending export packet

Bhuvaneswari,

Best Regards,

Thomas