Subject: Re: [IPFIX] An advanced for Reducing Redundancy

From: "Boschi, Elisa" <[email-masked]>
Date: Wed, 6 Dec 2006 10:58:28 -0000

Paul, Andrew,

>> One more that might be a bit obtuse.  The technique for
>> defining separate cpIds for source and destination Common
>> Properties is mentioned in the draft.  For common combinations
>> a third category of cpId could be used which maps to two other
>> cpIds.
>>
>> i.e.:
>>  cpID C -> cpID A + cpID B
>>  cpID A -> source address A, source port A
>>  cpID B -> destination address B, source port B
>
>
> Which raises the question of what duplicate cpID means, eg:
>
>   cpID D -> cpID C + cpID A
>
>
> Also, we need to be careful to avoid circular definitions, eg:
>
>   cpID E -> cpID F [ + cpID ... ]
>   cpID F -> cpID E [ + cpID ... ]
>
>
> Probably an exporter SHOULD NOT send these, and a collector MUST detect and discard them, and log.
>
Agree, but I propose a SHOULD instead of a MUST:

"An Exporter SHOULD NOT send Common Properties defined in terms of other Common Properties (i.e. when one of the properties is a CommonPropertiesID), and a Collector SHOULD detect and discard them and log."

Regards,
Elisa

**************************************************************************************************
 
 E-mail Confidentiality Notice and Disclaimer.
 
  This email and any files transmitted with it are confidential and are intended solely for 
the use of the individual or entity to which they are addressed. Access to this e-mail by 
anyone else is unauthorised. If you are not the intended recipient, any disclosure, 
copying, distribution or any action taken or omitted to be taken in reliance on it, is 
prohibited. 
  E-mail messages are not necessarily secure.  Hitachi does not accept responsibility 
for any changes made to this message after it was sent. 
  Please note that Hitachi checks outgoing e-mail messages for the presence of 
computer viruses.

**************************************************************************************************
_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Andrew Johnson <[email-masked]>
Date: Wed, 06 Dec 2006 15:07:09 +0000

Boschi, Elisa wrote:
> "An Exporter SHOULD NOT send Common Properties defined in terms of other 
> Common Properties (i.e. when one of the properties is a 
> CommonPropertiesID), and a Collector SHOULD detect and discard them and 
> log."

I think you misunderstand Paul's position.  I believe Paul thinks that
the collector should catch circular definitions.  The idea of defining
common Properties in terms of other common properties seems completely
valid to me.

regards

Andrew

---

From: Andrew Johnson <[email-masked]>
Date: Wed, 06 Dec 2006 15:07:09 +0000

regards

Andrew

---

From: Paul Aitken <[email-masked]>
Date: Wed, 06 Dec 2006 17:06:47 +0000

Elisa,

>> "An Exporter SHOULD NOT send Common Properties defined in terms of 
>> other Common Properties (i.e. when one of the properties is a 
>> CommonPropertiesID), and a Collector SHOULD detect and discard them 
>> and log."

Awww man, nooooo!

I want to be able to build CP ID trees without having to create 
CommonCommonProperties or CommonCommonPropertiesProperties!

> common Properties in terms of other common properties seems completely

Exactly.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Paul Aitken <[email-masked]>
Date: Wed, 06 Dec 2006 17:06:47 +0000

Elisa,

Awww man, nooooo!

Exactly.