Subject: Re: [IPFIX] WG next steps, take two

From: "Boschi, Elisa" <[email-masked]>
Date: Thu, 6 Sep 2007 15:35:56 +0100

Nevil, all,

> 
> On 8 August I posted a summary of the list activity on "new work items."
> That prompted lots more activity, and a host of people offering to review
> the proposed new drafts.
> 
> Here's my summary of what IPFIX should do next:
> 
> 0: SCTP changes to proto
>    This is now in process, with protocol-26 about to start its IETF LC.
> 
> 1: Config data model
>    This has five reviewers,
>    its clearly a WG work item, for an Informational RFC.
> 
> 2: SCTP per-stream
>    This has three reviewers,
>    I believe it should be a WG work item, for an Informational RFC.
> 
> 3: File Format
>    Again, three reviewers, should be a WG work item.
>    Points to discuss:
>    a) Since it doesn't describe 'bits on the wire,' it ought to be
>       Informational.  But does the WG think it should really be
>       Standards Track, so as to guarantee interopability?

I believe it should be standards track. It is true that the File Format doesn't describe bits on the wire, but it can be used as input for analysis tools or for testing. It should be standards track to guarantee interoperability.

>    b) Does it need to have the 'exporting-types' draft as a normative
>       reference?
> 

yes it does. Exporting Types was initially part of the File specification, and it is needed to address the self-description requirement for the file format.

> 4: Exporting Types (was Extended Types)
>    Three reviewers, lots of discussion, overall consensus that it
>    should be a WG work item.
> 
> 5: Mediators
>    Three reviewers, continuing discussion, consensus that it needs
>    to be split into smaller parts.
> 
> Recommendation:
> 
> 1 and 2 are well advanced, i.e. items which seem achievable in six months
> or so.  I'd like to adopt them as new WG work items.
> 
> 3 is also well advanced, and 4 is tending that way, but there are open
> issues as I mentioned for (3) above.  I guess that these could take six
> to 12 months to complete, but I propse that we adopt them as WG work items.
> 

I think that the File Format is almost complete. It is definitely achievable in six months. Exporting type _might_ take a bit longer but not much...

> 5 is clearly going to need lots more work, but there is considerable
> support for it.  I suggest that those interested in it work on a 'problem
> statement' document which would provide a framework for specific drafts
> on some of the component parts, starting with Aggregation and (maybe)
> Anonymisation.
> 
> Does anyone have any further feedback at this stage, please?
> 

Cheers,
Elisa

> Cheers, Nevil
> 
> PS: Looking at our Milestones, the only one we're behind on if the
>     IPFIX MIB.  What's the current status of that, please?
> 
> ---------------------------------------------------------------------
>  Nevil Brownlee                    Computer Science Department | ITS
>  Phone: +64 9 373 7599 x88941             The University of Auckland
>  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand
> 
> 
> 
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipfix
> 

************************************************************************************************** 
E-mail Confidentiality Notice and Disclaimer. 

This e-mail and any files transmitted with it are confidential and are intended solely for the use 
of the individual or entity to which they are addressed. Access to this e-mail by anyone else is 
unauthorised. If you are not the intended recipient, any disclosure, copying, distribution or any
action taken or omitted to be taken in reliance on it, is prohibited. E-mail messages are not 
necessarily secure. Hitachi does not accept responsibility for any changes made to this message 
after it was sent. 
Hitachi checks outgoing e-mail messages for the presence of computer viruses. 
**************************************************************************************************
_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Brian Trammell <[email-masked]>
Date: Thu, 6 Sep 2007 11:16:09 -0400

Elisa, Nevil, all,

These next steps look good; I have a few comments, inline...

On Sep 6, 2007, at 10:35 AM, Boschi, Elisa wrote:
> I believe it should be standards track. It is true that the File  
> Format doesn't describe bits on the wire, but it can be used as  
> input for analysis tools or for testing. It should be standards  
> track to guarantee interoperability.
Seconded. There's an implicit guideline here: things which impact  
interoperability (that is, that require both the EP and the CP to  
follow the draft in order to work) should be Standards Track (as with  
e.g. the core documents, and the biflow draft), while things which  
will interoperate fine without such cooperation need not be. Much of  
the file draft consists of optional IPFIX Options Templates which may  
be used to note information about the contents of the file (or,  
indeed, safely ignored). However, the core of the document lays out  
those things which must be done by EPs (file writers) and CPs (file  
readers) in order to use the "file" transport for IPFIX; this is why  
this draft needs to be Standards Track, in my opinion.
> yes it does. Exporting Types was initially part of the File  
> specification, and it is needed to address the self-description  
> requirement for the file format.
Also seconded.
> I think that the File Format is almost complete. It is definitely  
> achievable in six months. Exporting type _might_ take a bit longer  
> but not much...
The file draft is very nearly complete, save some editorial changes  
and a couple of additional sections. Most of the new content is  
already in our working copy of the draft, so we intend to finish the  
rest of the changes and submit a new revision toward the beginning of  
October. Agreed that six months to IESG submission is a readily  
achievable milestone here.

Cheers,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Thu, 6 Sep 2007 11:16:09 -0400

Elisa, Nevil, all,

Also seconded.

Cheers,

Brian

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 21 Sep 2007 08:48:26 +0200

>> requirement for the file format.

To be precise: it does for the file format as it is defined now.

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 4342-115
NEC Europe Limited,    Network Laboratories        Fax: +49 6221 4342-155
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de
Registered Office: NEC House, 1 Victoria Road, London W3 6BL, UK
Registered in England 2832014

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 21 Sep 2007 08:48:26 +0200

Thanks,

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 21 Sep 2007 17:00:54 +0200

> this draft needs to be Standards Track, in my opinion.

I am not 100% convinced, but I think we should try to put it on
standards track.  I am not sure that the rest of the IETF will share
this view.  Since there are some doubts left we could plan to touch
this point once more when we have the document in WGLC.

Thanks,

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 21 Sep 2007 17:00:54 +0200

Thanks,

    Juergen