Subject: Re: [IPFIX] New version of IPFIX configuration draft

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 22:09:39 +0900

Hi Gerhard, Benoit and all,

This draft is almost complete and great work.
I think that such XML configuration enhances efficiency of the use of
flexibility of IPFIX.

IMHO, I am afraid that the filtering method is different than current ACL
implemented in several routers. Therefore, the IPFIX XML cfg might not
be implemented, because of the gap between current ACL filter and IPFIX
XML cfg, even if psamp mention "AND" operation only.  

I propose the following XML schema added the ACL elements to -03 draft.
I am not familiar with YANG yet, sorry.

http://www3.plala.or.jp/akoba/ipfix-cfg-acl.txt
http://www3.plala.or.jp/akoba/ipfix-cfg-acl.html

The following Complex/Simple type elements are added.
- Complex Type: accessListMatch_type
- Complex Type: sequenceList_type
- Simple Type: action_type 

In addition, it allows "selectionProcess_type" to include
"AccessListMatch" element. 

What do you think about that? I think that it enhances flexibility as
optional.

Regards,
Atsushi KOBAYASHI

On Mon, 25 Feb 2008 17:50:21 +0100
Gerhard Muenz <muenz@informatiFrom [email-masked]  Sat Mar  8 06:31:19 2008
Date: Sat, 08 Mar 2008 22:09:39 +0900
From: Kobayashi Atsushi <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: [IPFIX] New version of IPFIX configuration draft
Sender: [email-masked]

Hi Gerhard, Benoit and all,

This draft is almost complete and great work.
I think that such XML configuration enhances efficiency of the use of
flexibility of IPFIX.

IMHO, I am afraid that the filtering method is different than current ACL
implemented in several routers. Therefore, the IPFIX XML cfg might not
be implemented, because of the gap between current ACL filter and IPFIX
XML cfg, even if psamp mention "AND" operation only.  

I propose the following XML schema added the ACL elements to -03 draft.
I am not familiar with YANG yet, sorry.

http://www3.plala.or.jp/akoba/ipfix-cfg-acl.txt
http://www3.plala.or.jp/akoba/ipfix-cfg-acl.html

The following Complex/Simple type elements are added.
- Complex Type: accessListMatch_type
- Complex Type: sequenceList_type
- Simple Type: action_type 

In addition, it allows "selectionProcess_type" to include
"AccessListMatch" element. 

What do you think about that? I think that it enhances flexibility as
optional.

Regards,
Atsushi KOBAYASHI

On Mon, 25 Feb 2008 17:50:21 +0100
Gerhard Muenz <[email-masked]> wrote:

> 
> Dear all,
> 
> A new revision of the IPFIX/PSAMP configuration data model has been
> published:
> http://www.ietf.org/internet-drafts/draft-muenz-ipfix-configuration-04.txt
> 
> Apart from smaller changes in the model itself, the big change compared
> to the previous version concerns the specification language: instead of
> XML Schema, we now use YANG, a new language for modelling Netconf data
> models. As a consequence, conformance to Netconf can be guaranteed.
> 
> We received a lot of valuable feedback and support from Martin Bjorklund
> who is a Netconf expert and author of the YANG draft. We will try to get
> some additional feedback from other Netconf experts as well.
> 
> Regards,
> Gerhard
> 
> -- 
> Dipl.-Ing. Gerhard M〓z
> Computer Networks and Internet
> Wilhelm Schickard Institute for Computer Science
> University of Tuebingen
> Sand 13 (Room B309), D-72076 Tuebingen, Germany
> Phone:  +49 7071 29-70534       Fax: +49 7071 29-5220
> E-mail: [email-masked]
> WWW:    http://net.informatik.uni-tuebingen.de/~muenz
> 

Atsushi KOBAYASHI  <[email-masked]>
NTT Information Sharing Platform Lab.
tel:+81-(0)422-59-3978 fax:+81-(0)422-59-5637

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

k.uni-tuebingen.de> wrote:

> 
> Dear all,
> 
> A new revision of the IPFIX/PSAMP configuration data model has been
> published:
> http://www.ietf.org/internet-drafts/draft-muenz-ipfix-configuration-04.txt
> 
> Apart from smaller changes in the model itself, the big change compared
> to the previous version concerns the specification language: instead of
> XML Schema, we now use YANG, a new language for modelling Netconf data
> models. As a consequence, conformance to Netconf can be guaranteed.
> 
> We received a lot of valuable feedback and support from Martin Bjorklund
> who is a Netconf expert and author of the YANG draft. We will try to get
> some additional feedback from other Netconf experts as well.
> 
> Regards,
> Gerhard
> 
> -- 
> Dipl.-Ing. Gerhard M〓z
> Computer Networks and Internet
> Wilhelm Schickard Institute for Computer Science
> University of Tuebingen
> Sand 13 (Room B309), D-72076 Tuebingen, Germany
> Phone:  +49 7071 29-70534       Fax: +49 7071 29-5220
> E-mail: [email-masked]
> WWW:    http://net.informatik.uni-tuebingen.de/~muenz
> 

Atsushi KOBAYASHI  <[email-masked]>
NTT Information Sharing Platform Lab.
tel:+81-(0)422-59-3978 fax:+81-(0)422-59-5637

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 22:16:12 +0900

Regards,
Atsushi KOBAYASHI

On Mon, 25 Feb 2008 17:50:21 +0100
Gerhard Muenz <[email-masked] [email-masked]  Sat Mar  8 06:31:20 2008
Date: Sat, 08 Mar 2008 22:16:12 +0900
From: Kobayashi Atsushi <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: [IPFIX] New version of IPFIX configuration draft
Sender: [email-masked]

Regards,
Atsushi KOBAYASHI

On Mon, 25 Feb 2008 17:50:21 +0100
Gerhard Muenz <[email-masked]> wrote:

> Dipl.-Ing. Gerhard Mz

ni-tuebingen.de> wrote:

> Dipl.-Ing. Gerhard Mz

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:28:44 +0900

Regards,
Atsushi KOBAYASHI

On Mon, 25 Feb 2008 17:50:21 +0100
Gerhard Muenz <[email-masked]> wrote:

> Dipl.-Ing. Gerhard Münz

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:28:44 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:57:46 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:57:46 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:53:47 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:53:47 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:30:32 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sat, 08 Mar 2008 21:30:32 +0900

Regards,
Atsushi KOBAYASHI

---

---

From: Kobayashi Atsushi <[email-masked]>
Date: Sun, 09 Mar 2008 17:49:11 +0900

Sorry for sending duplicate same messages. 
I tryed to send same message until it updates. It took about 30 minutes.

On Sat, 08 Mar 2008 21:30:32 +0900
Kobayashi Atsushi <[email-masked]> wrote:

> - SFrom [email-masked]  Sun Mar  9 00:51:59 2008
Date: Sun, 09 Mar 2008 17:49:11 +0900
From: Kobayashi Atsushi <[email-masked]>
To: Kobayashi Atsushi <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [IPFIX] New version of IPFIX configuration draft
Sender: [email-masked]

Sorry for sending duplicate same messages. 
I tryed to send same message until it updates. It took about 30 minutes.

On Sat, 08 Mar 2008 21:30:32 +0900

imple Type: action_type