Subject: Re: [IPFIX] IPFIX-MIB: TemplateRefreshPackets?

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Jun 2008 15:29:53 +0200

Gerhard,
> Dear all,
>
> The IPFIX-MIB specifies:
>
>   ipfixTransportSessionTemplateRefreshPacket OBJECT-TYPE
>       SYNTAX      Unsigned32
>       MAX-ACCESS  read-only
>       STATUS      current
>       DESCRIPTION
>           "On Exporters this object contains the number of packets
>           after which IPFIX Templates MUST be resent by the
>           Exporter.
>
>           On Collectors this object contains the lifetime in number
>           of packets after which a Template becomes invalid when it
>           is not received again within this lifetime.
>
>           This object is only valid if ipfixTransportSessionProtocol
>           has the value 17 (UDP). In all other cases the value MUST
>           be 0."
>       DEFVAL      { 0 }
>       ::= { ipfixTransportSessionEntry 11 }
>
>
> (similarly for ipfixTransportSessionOptionTemplateRefreshPacket)
>
> Isn't the description ambiguous?
> "On Exporters this object contains the number of packets after which
> IPFIX Templates MUST be resent by the Exporter."
> What is meant by "packets" in this context?
> - packets observed?
> - packets accounted?
>
> I assume it is the number of IPFIX Messages exported, right?
>   
On the Exporter, correct.
On the collector side, this is "exported" as well (just for the case of 
UDP loses some packets). So we must look at the "Sequence Number"

Regards, Benoit.
> Then, the description should be changed accordingly.
>
> Regards,
> Gerhard
>
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>   

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Jun 2008 15:29:53 +0200

Gerhard,

Regards, Benoit.

---

From: Gerhard Muenz <[email-masked]>
Date: Thu, 12 Jun 2008 15:45:50 +0200

Benoit,

I do not know if you got my point.

I wanted to say that  "number of packets"  should be replaced by
"number of IPFIX Messages"  because packets could be interpreted as
packets observed at the OP.

Regards,
Gerhard

Benoit Claise wrote:
>> (similarly for ipfixTransportSessionOptioFrom [email-masked]  Thu Jun 12 06:45:32 2008
Date: Thu, 12 Jun 2008 15:45:50 +0200
From: Gerhard Muenz <[email-masked]>
To: Benoit Claise <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [IPFIX] IPFIX-MIB: TemplateRefreshPackets?
Sender: [email-masked]

This is a cryptographically signed message in MIME format.

Benoit,

I do not know if you got my point.

I wanted to say that  "number of packets"  should be replaced by
"number of IPFIX Messages"  because packets could be interpreted as
packets observed at the OP.

Regards,
Gerhard

Benoit Claise wrote:
>> (similarly for ipfixTransportSessionOptionTnTemplateRefreshPacket)
>>

-- 
Dipl.-Ing. Gerhard Münz
Computer Networks and Internet
Wilhelm Schickard Institute for Computer Science
University of Tuebingen
Sand 13 (Room B309), D-72076 Tuebingen, Germany
Phone:  +49 7071 29-70534       Fax: +49 7071 29-5220
E-mail: [email-masked]
WWW:    http://net.informatik.uni-tuebingen.de/~muenz

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Jun 2008 17:10:04 +0200

Gerhard,

I think I got your point, but took a shortcut in the answer. My fault.
I see two issues in this email.
First, "number of packets" should be replaced by "number of IPFIX 
Messages". Yes, definitively
Second, which IPFIX Messages: observed? accounted? exported? And this 
answer is "exported", both in the Exporters and Collector sentences

So it should become something such as

          "On Exporters this object contains the number of exported IPFIX Messages
          after which IPFIX Templates MUST be resent by the
          Exporter.

          On Collectors this object contains the lifetime in number
          of exported IPFIX Messages after which a Template becomes invalid when it
          is not received again within this lifetime. 

Do we agree?

Regards, Benoit.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 Jun 2008 17:10:04 +0200

Gerhard,

Do we agree?

Regards, Benoit.

---

From: "Gerhard Muenz" <[email-masked]>
Date: Thu, 12 Jun 2008 21:46:29 +0200 (CEST)

>           has the value 17 (UDP). In all other cases the value MUST

Yes, that's fine.

Regards,
Gerhard

---

From: "Gerhard Muenz" <[email-masked]>
Date: Thu, 12 Jun 2008 21:46:29 +0200 (CEST)

Yes, that's fine.

Regards,
Gerhard