Subject: Re: [IPFIX] [IANA #144572] request for new IPFIX information elements - It's start to be really ridiculous...

From: Benoit Claise <[email-masked]>
Date: Tue, 26 Aug 2008 12:29:36 +0200

Michelle,

It's start to be really ridiculous...

We understood that this IPFIX registry might be a little special and 
difficult due to
    - the history of NetFlow version 9, already implemented for years.
    - the fact that RFC5102 doesn't have a clear procedure for IANA 
("MUST be published using a well-established and persistent publication 
medium")

So, during IETF 71, we (Dan Romascanu, Nevil Brownlee, Brian Trammell, 
and I) came to you in person to explain everything.
And again, during IETF 72, we (Juergen Quittek, Paul Aitken, Brian 
Trammel, and I) came to you in person to explain everything.
It was supposed to be fixed within a week. And still no news.

I'm not sure if you realize the mess in which my company is: we invented 
NetFlow, pushed through standardization via IPFIX, published all our 
information elements to the world, and now we're paying a big price for 
that. Because, obviously we kept implementing new Information Elements 
since we started this IPFIX effort at the IETF in 2001... So we have 
many groups within the company wanteFrom [email-masked]  Tue Aug 26 03:36:05 2008
Date: Tue, 26 Aug 2008 12:29:36 +0200
From: Benoit Claise <[email-masked]>
To: [email-masked], Michelle Cotton <[email-masked]>,
	"[email-masked]" <[email-masked]>
Cc: Juergen Quittek <[email-masked]>, [email-masked]
Subject: Re: [IPFIX] [IANA #144572] request for new IPFIX information
 elements - It's start to be really ridiculous...
Sender: [email-masked]

Michelle,

It's start to be really ridiculous...

We understood that this IPFIX registry might be a little special and 
difficult due to
    - the history of NetFlow version 9, already implemented for years.
    - the fact that RFC5102 doesn't have a clear procedure for IANA 
("MUST be published using a well-established and persistent publication 
medium")

So, during IETF 71, we (Dan Romascanu, Nevil Brownlee, Brian Trammell, 
and I) came to you in person to explain everything.
And again, during IETF 72, we (Juergen Quittek, Paul Aitken, Brian 
Trammel, and I) came to you in person to explain everything.
It was supposed to be fixed within a week. And still no news.

I'm not sure if you realize the mess in which my company is: we invented 
NetFlow, pushed through standardization via IPFIX, published all our 
information elements to the world, and now we're paying a big price for 
that. Because, obviously we kept implementing new Information Elements 
since we started this IPFIX effort at the IETF in 2001... So we have 
many groups within the company wand new information element 
assignments. What should we tell them?
 - the IANA procedure is almost in place? We've been telling that for 
too long now...
 - assign the next one available but that may change? Great from an 
interoperability point of view...
 - wait? we can't anymore... The last time you assign an I.E. (239, 
biflowDirection), that forced the IPFIX WG to change the already agreed 
upon I.E. assignments ... which is the reason why we had to produce 
http://tools.ietf.org/id/draft-aitken-ipfix-new-infos-03.txt

Regards, Benoit.

> Benoit,
>
> It was great meeting with you all at this IETF.
>
> I have spoken with my XML folks.  We are already working on it.
> It should be done by the end of the week but I can't promise.
> I'll send you all something as soon as it is ready as well as send you questions
> if anything comes up.
>
> Patience :)
>
> This is one of my highest priorities....
>
> Thanks,
>
> Michelle
>
>
>
> On Wed Jul 30 17:07:16 2008, [email-masked] wrote:
>   
>> Michelle,
>>
>> Good talking to you the other day.
>> Have you received some feedback from your XML expert?
>> Do you have something to show us while we're still at the IETF?
>>
>> Regards, Benoit.
>>     
>>>> Dear all,
>>>>
>>>> Tuesday 11h30 is fine for Paul and myself.
>>>> What about you?
>>>>
>>>> Regards, Benoit.
>>>>         
>>>>> Dear Michelle,
>>>>>
>>>>> I will be in Dublin from Monday to Wednesday morning.
>>>>> When would be a good time for you to meet?
>>>>>
>>>>> Thanks,
>>>>>
>>>>>     Juergen
>   

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

ted new information element 
assignments. What should we tell them?
 - the IANA procedure is almost in place? We've been telling that for 
too long now...
 - assign the next one available but that may change? Great from an 
interoperability point of view...
 - wait? we can't anymore... The last time you assign an I.E. (239, 
biflowDirection), that forced the IPFIX WG to change the already agreed 
upon I.E. assignments ... which is the reason why we had to produce 
http://tools.ietf.org/id/draft-aitken-ipfix-new-infos-03.txt

Regards, Benoit.

> Benoit,
>
> It was great meeting with you all at this IETF.
>
> I have spoken with my XML folks.  We are already working on it.
> It should be done by the end of the week but I can't promise.
> I'll send you all something as soon as it is ready as well as send you questions
> if anything comes up.
>
> Patience :)
>
> This is one of my highest priorities....
>
> Thanks,
>
> Michelle
>
>
>
> On Wed Jul 30 17:07:16 2008, [email-masked] wrote:
>   
>> Michelle,
>>
>> Good talking to you the other day.
>> Have you received some feedback from your XML expert?
>> Do you have something to show us while we're still at the IETF?
>>
>> Regards, Benoit.
>>     
>>>> Dear all,
>>>>
>>>> Tuesday 11h30 is fine for Paul and myself.
>>>> What about you?
>>>>
>>>> Regards, Benoit.
>>>>         
>>>>> Dear Michelle,
>>>>>
>>>>> I will be in Dublin from Monday to Wednesday morning.
>>>>> When would be a good time for you to meet?
>>>>>
>>>>> Thanks,
>>>>>
>>>>>     Juergen
>   

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 26 Aug 2008 08:05:44 -0700

We have the XML registry, I'm going to send you all something to look at and make sure that it is sufficient.
Look for it later today.

Apologies, I have been on some unexpected personal travel in the last 2 weeks but it is now finished.

Michelle

On 8/26/08 3:29 AM, "Benoit Claise" <[email-masked]> wrote:

Michelle,

So, during IETF 71, we (Dan Romascanu, Nevil Brownlee, Brian Trammell,
and I) came to you in person to explain everything.
And again, during IETF 72, we (Juergen Quittek, Paul Aitken, Brian
Trammel, and I) came to you in person to explain everything.
It was supFrom [email-masked]  Tue Aug 26 10:35:08 2008
From: Michelle Cotton <[email-masked]>
To: Benoit Claise <[email-masked]>, "[email-masked]"
	<[email-masked]>, "[email-masked]" <[email-masked]>
Date: Tue, 26 Aug 2008 08:05:44 -0700
Accept-Language: en-US
acceptlanguage: en-US
Cc: "[email-masked]" <[email-masked]>,
	Juergen Quittek <[email-masked]>
Subject: Re: [IPFIX] [IANA #144572] request for new IPFIX information
 elements - It's start to be really ridiculous...
Sender: [email-masked]
We have the XML registry, I'm going to send you all something to look at and make sure that it is sufficient.
Look for it later today.

Apologies, I have been on some unexpected personal travel in the last 2 weeks but it is now finished.

Michelle

On 8/26/08 3:29 AM, "Benoit Claise" <[email-masked]> wrote:

Michelle,

It was suppoposed to be fixed within a week. And still no news.

many groups within the company wanted new information element

Regards, Benoit.