Subject: Re: [IPFIX] I-D Action:draft-ietf-tsvwg-sctp-strrst-00.txt

From: Benoit Claise <[email-masked]>
Date: Wed, 21 Oct 2009 02:11:01 +0200

Randy, Peter, Michael,

As you know, we have this draft 
http://tools.ietf.org/html/draft-ietf-ipfix-export-per-sctp-stream-03 
that depends on the your draft below.
With the latest version 04, which will be posted before the end of the 
week, we move your draft from an informative to a normative reference 
... as discussed with the IESG.
So, this message is a friendly reminder that we'll like to see some 
progress on this draft ;-)

Regards, Benoit.
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Transport Area Working Group Working Group of the IETF.
>
>
> 	Title           : Stream Control Transmission Protocol (SCTP) Stream Reconfiguration
> 	Author(s)       : R. Stewart, et al.
> 	Filename        : draft-ietf-tsvwg-sctp-strrst-00.txt
> 	Pages           : 20
> 	Date            : 2009-07-05
>
> Many applications that desire to use SCTP have requested the ability
> to "reset" a stream.  The intention of resetting a stream is to start
> the numbering sequence of the stream back at 'zero' with a
> corresponding notification to the upper layer that this act as been
> performed.  The applications that have requested this feature
> normally desire it so that they can "re-use" streams for different
> purposes but still utilize the stream sequence number for the
> application to track the message flows.  Thus, without this feature,
> a new use on an old stream would result in message numbers larger
> than expected without a protocol mechanism to "start the streams back
> at zero".  This documents presents also a method for resetting the
> transport sequence numbers and all stream sequence numbers.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctp-strrst-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Randall Stewart <[email-masked]>
Date: Wed, 21 Oct 2009 10:59:12 +0530

Benoit:

-00 is the current version.

As to what needs done in the document I think:

1) We need to add a socket-api section (Michael and I were going to  
work on that at
    EuroBSD but I think we got distracted by the vnet stuff .. opps ;-D)

2) We probably need to touch up the IANA section, it looks to me that  
it needs a bit
    of polishing.

3) We need to go back through and make sure the rest of the rules are  
clear.

and finally

4) We need to get a bit more working group review.

As to implementation state, I believe the FreeBSD implementation and  
the IOS implementation are the
only two I know that implement this feature. Not sure if IOS has added  
the "add stream" feature yet, Peter
might be able to tell ;-)

When we add the socket-api section, I am sure the FreeBSD  
implementation will also need to "adjust" its
current socket API to match the draft... which we will most likely do  
in real time.

Michael, do you have any other things to list here?

Note: I don't think either Michael or I will be in Japan, we will both  
attend Anaheim though (at least
       we currently intend to)

R
On Oct 21, 2009, at 5:41 AM, Benoit Claise wrote:

> Randy, Peter, Michael,
>
> As you know, we have this draft http://tools.ietf.org/html/draft-ietf-ipfix-export-per-sctp-stream-03 
> With the latest version 04, which will be posted before the end of  
> the week, we move your draft from an informative to a normative  
> reference ... as discussed with the IESG.
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

------------------------------
Randall Stewart
803-317-4952 (cell)
803-345-0391(direct)