Subject: Re: [IPFIX] IE for Reliability Extension

From: Nevil Brownlee <[email-masked]>
Date: Tue, 04 May 2010 17:17:28 +1200

Hi Sujay:

Sorry it's taken me a while to get back onto IPFIX things.

I see that Juergen sent you an email on 21 April, suggesting that
you simply request IANA to add some new IE definitions to their
IPFIX IE Registry.

Reading your draft now, I agree with Juergen.  The draft simply
says "we need a new information element to say whether or not
the counter fields in the Reliability Statistics and Exporting
Process Statistics Option Templates are valid, or not."

It doesn't seem to me that you need more than the new IE, your
'reliabilityReasonCode.'  However, I'd like to see some discussion
of that on the IPFIX list.  For example, does the name tell us
what it actually means?  Would 'reliabilityCountersValid' be
any better?  Can it be implemented effectively?  Do others agree
that it would be useful?

Concerning the draft itself, I have a few editorial comments:
- MAYBE isn't an RFC 2119, that should be in lower case
- IE 239 is already allocated, the next free number is 277

I'm copying this to the list to see what others think of this.

Cheers, Nevil

sujay gupta wrote:
> Hi Nevil,
> 
> My apologies for sending multiple emails.
> 
> I am keen to propose for IANA the IE as described in;
> 
> http://tools.ietf.org/html/draft-gupta-ipfix-reliability-template-ext-00,
> which I had
> presented at Anaheim.
> 
> What is your opinion on it?
> 
> Looking forward to your reply.
> 
> Thanking you,
> -Sujay

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: sujay gupta <[email-masked]>
Date: Tue, 4 May 2010 23:29:16 -0400

Thanks Nevil for the feedback.

Yes, I would agree for a more appropriate name change.

Sometime, when I last floated an email asking for responses as to who
has implemented Reliability Optional Template , there was IMO no
response, (??)

On the reason for the new IE, I do not see any disagreement from the list.

Whether it can be resolved without using a new IE is the question, and
I would welcome any proposals in the list.

Best Regards,
-Sujay