Subject: [IPFIX] WG LC for IPFIX structured data

From: "Rahul Patel (rahulp)" <[email-masked]>
Date: Thu, 22 Jul 2010 10:34:00 -0500

Resending it.

-Rahul

From: Rahul Patel (rahulp) 
Sent: Monday, July 19, 2010 11:49 AM
To: [email-masked]'
Subject: WG LC for IPFIX structured data

Few comments on Rev2

comment #1:

===========

Page 45-46:

"       Selection Sequence 7 (Filter->Sampling):  

         observation point: subTemplateMultiList.  

                              Router 1, (interface 1)  

                              Router 2, (line card A)  

                              Router 3, (line card B) 

                              Router 4, (line card C, interface 2)  

         selectorId: 5 (Filter, match IPV4SourceAddress 192.0.2.1)  

         selectorId: 10 (Sampler, Random 1 out-of ten) 

      The following Templates are defined to represent the PSAMP SSRI: 

      Template for representing PSAMP SSRI: 262 

      Template for representing interface: 263 

"

Rahul# Wouldn't it be better to include RouterID in addition to 

Interface and/or linecard in the example. Without router id interface

has no meaning unless interfaces are unique across routers which is 

unlikely.

comment #2

==========

Page 46

"      Note that the Data Record above contains multiple instances of 

      Template 264 to represent Observation Point 2 (line card A) and 

      Observation Point 3 (line card B).  Instead, if a single 

      Observation Point had both line card A and line card B, a 

      basicList would be used to represent the list of line cards. 

"

Rahul# There is an implicit assumption that each record belongs to a

different router. That is why you would have to use basicList if line

card A and line card B were to be on OB Point 2.

Comment #3

==========

Page 46

Rahul# In the same example (above), instead of 'allof" if "ordered" is

used then does it imply that there is order in template 264 (line card
A,

line card B) even though it is just a regular template?

Comment #4

===========

Page 16

"     Another example is a router that monitors some specific BGP AS-

     PATHs and reports if a Flow belongs to any of them.  If the router 

     wants to export that a Flow does not belong to any of the 

     monitored BGP AS-PATHs, the router reports a Data Record with a 

     basicList composed of (BGP AS-PATH 1, BGP AS-PATH 2, BGP AS-PATH 

     3) and the respective Structured Data type semantic of "noneOf".

"

Rahul# If there are many flows which are exported with "noneOf" then
that

would not be efficient because each flow is carring path1, path2 and
path3.

Can you do following? How?

List of flows that didn't

match monitored AS paths -> AS_PATH { path1, path2, path3}

                        -> Flows

                               - Flow1

                               - Flow2

                               - Flow3

                               - Flow4

-Rahul

---

From: Benoit Claise <[email-masked]>
Date: Wed, 28 Jul 2010 22:35:56 +0200

Rahul,

Thank you very much for your review.
See my replies in line.
>
> Resending it.
>
> -Rahul
>
> *From:* Rahul Patel (rahulp)
> *Sent:* Monday, July 19, 2010 11:49 AM
> *To:* [email-masked]'
> *Subject:* WG LC for IPFIX structured data
>
> Few comments on Rev2
>
> comment #1:
>
> ===========
>
> Page 45-46:
>

OLD:

            PSAMP SSRI (262)
               | (SelectionSequenceId)
               |
               +--- Observation Point 1 (263)
               |      (Interface Id)
               |
               +--- Observation Point 2 and 3 (264)
               |      (line card)
               |
               +--- Observation Point 4 (265)
               |      (line card)
               |      (Interface Id)
               |
               | (selectorId 1)
               | (selectorId 2)

NEW:

            PSAMP SSRI (262)
               | (SelectionSequenceId)
               |
               +--- Observation Point 1 (263)
               |      (exporterIPv4Address)
               |      (Interface Id)
               |
               +--- Observation Point 2 and 3 (264)
               |      (exporterIPv4Address)
               |      (line card)
               |
               +--- Observation Point 4 (265)
               |      (exporterIPv4Address)
               |      (line card)
               |      (Interface Id)
               |
               | (selectorId 1)
               | (selectorId 2)

This would good enough?
Or you want the full example,  with (subTemplateMultiList, exactlyOneOf, 
exporterIPv4Address, exporterIPv6Address)?
This would be:

            PSAMP SSRI (262)
               | (SelectionSequenceId)
               |
               +--- Exporter IPv4 address (262)
               |      (exporterIPv4Address)
               |
               +--- Exporter IPv6 address (263)
               |      (exporterIPv6Address)
               |
               +--- Observation Point 1 (264)
               |      (Interface Id)
               |
               +--- Observation Point 2 and 3 (265)
               |      (line card)
               |
               +--- Observation Point 4 (266)
               |      (line card)
               |      (Interface Id)
               |
               | (selectorId 1)
               | (selectorId 2)

> different router.
You're right, the example shows so.
>
> That is why you would have to use basicList if line
>
Right.
Alternatively, the proposals above would solve this by repeating the 
exporterIPv4Address
> used then does it imply that there is order in template 264 (line card A,
>
Yes.
> Rahul# If there are many flows which are exported with "noneOf" then that
>
How would you express this semantically?
     (allOf, Flows) allOf (noOff, BGP AS)
     (allOf, Flows) none (allOf, BGP AS)
 From there, we could map it with a basicList of subTemplateMultiList.

Regards, Benoit.

---

From: Gerhard Muenz <[email-masked]>
Date: Thu, 29 Jul 2010 10:33:41 +0200

Benoit,

> Thank you very much for your review.

[...]

>> line card B) even though it is just a regular template?

I'm confused. As far as I understand the current semantic (see my
review), linecard A and B would not be ordered. The order would only
concern the relationship between groups of Data Records belonging to
different Templates, i.e.
   ingressInterface 1 <=> {linecards A and B} <=> linecard C

Gerhard

---

From: "Rahul Patel (rahulp)" <[email-masked]>
Date: Thu, 29 Jul 2010 09:16:40 -0500

Hi Benoit,

Comment inline ..[RP]

From: Benoit Claise (bclaise) 
Sent: Wednesday, July 28, 2010 4:36 PM
To: Rahul Patel (rahulp)
Cc: [email-masked]
Subject: Re: WG LC for IPFIX structured data

Rahul,

Resending it.

-Rahul

Few comments on Rev2

comment #1:

===========

Page 45-46:

                              Router 1, (interface 1)  

                              Router 2, (line card A)  

                              Router 3, (line card B) 

"

unlikely.

OLD:

           PSAMP SSRI (262)
              | (SelectionSequenceId)
              |

NEW:

           PSAMP SSRI (262)
              | (SelectionSequenceId)
              |

This would good enough?

[RP] This is fine.

           PSAMP SSRI (262)
              | (SelectionSequenceId)
              |

comment #2

==========

Page 46

"

different router. 

Right.

Comment #3

==========

Page 46

Yes.

Comment #4

===========

Page 16

"

                        -> Flows

                               - Flow1

                               - Flow2

                               - Flow3

                               - Flow4

>From there, we could map it with a basicList of subTemplateMultiList.

[RP] 

(basicList, allOf,  

                (subTemplateList, noneOff, AS1, AS2, AS3)

                (subTemplateList, allOf, Flow1, Flow2, Flow3, Flow4)

-Rahul

Regards, Benoit.

-Rahul