Subject: [IPFIX] exporting decimal places in IPFIX

From: Paul Aitken <[email-masked]>
Date: Wed, 20 Oct 2010 12:24:46 +0100

Dear IPFIX experts,

We would like to export a field which is measured to two decimal places.
Internally we store this as an integer of (value x 100).

So eg, if the value is 35.01% then we store 3501. Similarly, if it is
-10.90 then we store -1090. So floating point isn't used or required.

How should we export that in IPFIX?

* Create a new type of "percentage" which is expressed as "integer x100"?

* Or more generically, type = integer, units = 1/100'ths ?

* Should we define "deci", "centi", "micro" and "milli" types as 
integers with 1, 2, 3 and 6 decimal places respectively?

* Converted to floating point? Though clearly arbitrary floating point 
precision isn't needed in this case.

Feedback appreciated...

Thanks,
P.

---

From: Brian Trammell <[email-masked]>
Date: Wed, 20 Oct 2010 14:59:35 +0200

Hi, Paul,

I'd go with the SI prefix solution (type integer, units 1/100 pct), and add something to the IE name to point out the scale: it's what we already do in cases of fixed-point export in IPFIX (e.g. flowDurationMilliseconds/flowDurationMicroseconds)

Cheers,

Brian

On Oct 20, 2010, at 1:24 PM, Paul Aitken wrote:

> * Should we define "deci", "centi", "micro" and "milli" types as integers with 1, 2, 3 and 6 decimal places respectively?
> 
> * Converted to floating point? Though clearly arbitrary floating point precision isn't needed in this case.
> 
> Feedback appreciated...
> 
> Thanks,
> P.
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix