Subject: Re: [IPFIX] IANA IPFIX registry

From: Paul Aitken <[email-masked]>
Date: Thu, 07 Oct 2010 19:15:44 +0100

Brian,

There's currently no way to know what was added to the registry when,
which I think will be important in future for the reasons below.

So I'd like to see something added ASAP.

It could be as simple as recording the date and a list of fields added, 
modified or removed.

BTW, I do plan on reviewing the IE doctors draft.

P.

On 07/10/10 14:43, Brian Trammell wrote:
> Hi, Paul,
>
> Good idea. Have a look at the recently submitted
> draft-trammell-ipfix-ie-doctors; we don't currently specify
> versioning, but specifying (or, if we want to bring versioning online
> in less time than it takes to publish a draft, explaining and
> referencing) a policy for that would fit very nicely in a future
> version thereof...
>
> Cheers,
>
> Brian
>
> --- On Oct 7, 2010, at 3:36 PM, Paul Aitken wrote: ---
>
> Dear all,
>
> I've been requesting new IPFIX Information Elements from IANA. And I
> realised that there's a problem: there are no details of changes in
> the registry.
>
> So I think that the registry should include a version number and
> revision history that's updated with each new field.
>
> Then one can claim their implementation is compatible with v123, and
> quickly see what needs to be done to be compatible with v456.
>
> Or an exporter and a collector can quickly and easily be compared to
> ensure they support the same elements, or at least a common set of
> elements required for a particular application.
>
> P.
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Brian Trammell <[email-masked]>
Date: Thu, 7 Oct 2010 15:43:58 +0200

Hi, Paul,

Cheers,

Brian

--- On Oct 7, 2010, at 3:36 PM, Paul Aitken wrote: ---

Dear all,

P.