Subject: [IPFIX] Fwd: I-D Action:draft-akhter-ipfix-perfmon-00.txt

From: Al Morton <[email-masked]>
Date: Mon, 18 Oct 2010 10:32:37 -0400

>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-akhter-ipfix-perfmon-00.txt

Hi Aamer,

I gave this a look-over, and have the following comments:

- I think you've done a good job describing the sequence number
roll-over problem, I was checking to be sure this was covered.

- I think a slightly different loss triad is what you want here.
   Instead of:
>        4.1.1.  perfPacketLoss . . . . . . . . . . . . . . . . . . . .  6
>        4.1.2.  perfPacketExpected . . . . . . . . . . . . . . . . . .  8
>        4.1.3.  perfPacketLossRate . . . . . . . . . . . . . . . . . .  9

I think 4.1.1 should be the observed packet count.
When you combine this in a ratio with the number of expected packets,
you get the packet loss ratio.

So, I suggest:
OLD
4.1.  Transport Layer

4.1.1.  perfPacketLoss

    Name:  perfPacketLoss

    Description:  The packet loss metric reports the number of individual
       packets that were lost in the reporting interval.

NEW
4.1.  Transport Layer

4.1.1.  perfPacketCount

    Name:  perfPacketCount

    Description:  The packet count metric reports the number of individual
       packets that arrived at the observation point during the reporting
       interval.    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

other edits are needed in 4.1.1, but let's see if we're
on the same page. :-)

Also, I suggest
OLD
4.1.3.  perfPacketLossRate
NEW
4.1.3.  perfPacketLossRatio
as we've done elsewhere, including IPPM and PMOL.

interesting draft,
Al

---

From: Shingo KASHIMA <[email-masked]>
Date: Fri, 29 Oct 2010 18:08:00 +0900

Hi Aamer and all,

Your draft is fine for me.

At last NMRG Netflow/IPFIX workshop in Maastricht,
I have presented Qcast system for IPTV/RTP quality
monitoring with IPFIX/PSAMP.
http://www.ietf.org/proceedings/78/slides/NMRG-4.pdf
This system uses Enterprise-specific Information Elements 
as mentioned in page12.

Regards,
Shingo

On Mon, 18 Oct 2010 10:32:37 -0400
Al Morton <[email-masked]> wrote:

> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
> 

-- 
Shingo KASHIMA <[email-masked]>
NTT Information Sharing Platform Lab.