Subject: [IPFIX] Draft Standard version of RFC5102

From: Benoit Claise <[email-masked]>
Date: Sun, 27 Mar 2011 16:35:25 +0200

Dear all,

This list is way shorter.
Next to http://www.rfc-editor.org/errata_search.php?rfc=5102, only one 
issue.

        5.10.1. octetDeltaCount

    Description:
       The number of octets since the previous report (if any) in
       incoming packets for this Flow at the Observation Point.  The
       number of octets includes IP header(s) and IP payload.
    Abstract Data Type: unsigned64
    Data Type Semantics: deltaCounter
    ElementId: 1
    Status: current
    Units: octets

In the case of Ethernet II encapsulation would this byte count 
totalinclude the 14 bytes associated with the L2 header + L3 header + 
L4header + payload or just L3 header + L4 header + payload
The latter is what's implemented.
The spec says "packets" not "frames", but  it would be a good idea to be 
more explicit.

Note that there are multiple Count related IEs.

Regards, Benoit.

---

From: Brian Trammell <[email-masked]>
Date: Sun, 27 Mar 2011 16:50:05 +0200

Hi, Benoit,

I thought it was obvious (from IP headers and IP payload) that L2 and below were not represented here. (This is also what appears to be implemented in each of the checked implementations tested at the interop in Prague)

Cheers,

Brian

On Mar 27, 2011, at 4:35 PM, Benoit Claise wrote:

> Next to http://www.rfc-editor.org/errata_search.php?rfc=5102, only one issue.
> 5.10.1.  octetDeltaCount
> 
>    Description:
> In the case of Ethernet II encapsulation would this byte count total include the 14 bytes associated with the L2 header + L3 header + L4 header + payload or just L3 header + L4 header + payload 
> The spec says "packets" not "frames", but  it would be a good idea to be more explicit. 
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Benoit Claise <[email-masked]>
Date: Sun, 27 Mar 2011 16:53:19 +0200

Hi Brian,

I'm not really pushing for this one. This is what I have in my notes.

Regards, Benoit.

---

From: Brian Trammell <[email-masked]>
Date: Sun, 27 Mar 2011 17:04:53 +0200

Hi, Benoit,

In any case, the IANA registry is canonical, in preference to 5102; any IE errata should be fixed there first. 5102 should probably be updated to say that the core IPFIX data model is described by IANA, and IANA wins in case of conflict.

(Something to consider here, too, is if we want something like the IE Doctors lifecycle to be included in a 5102bis... Something to discuss for Tuesday...)

Regards,

Brian