Subject: [IPFIX] RTP media stream template?

From: Hendrik Scholz <[email-masked]>
Date: Wed, 07 Dec 2011 17:16:00 +0100

Hi!

Is anybody working on a template and related IEs for RTP media streams?
I am happy to contribute and/or author the needed documents.

The use cases for this include active VoIP components which handle
RTP streams and want to provide data records as well as passive
monitoring systems which are build to monitor RTP streams.
IEs include general RTP information (source, destination, codec)
as well as IP transport quality (jitter, packet loss, ..) and
higher-level metrics such as R-Factor and MOS value where available.

The template should allow both data records on entire streams (i.e.
part of calls minutes or even hours long) as well as fixed time slices
such as 10 seconds to allow monitoring with a high granularity.

Regards,
 Hendrik

-- 
VOIPFUTURE GmbH   Wendenstraße 4   20097 Hamburg   Germany
Phone +49 40 688 900 163    Fax +49 40 688 900 199
Email [email-masked]   Web http://www.voipfuture.com

CEO Jan Bastian
Commercial Court AG Hamburg   HRB 109896
VAT ID DE263738086

---

From: Carter Bullard <[email-masked]>
Date: Wed, 7 Dec 2011 11:30:44 -0500

Hey Hendrik,
Argus has RTP specific flow records, with its own IEs for reporting attributes
and metrics for the media streams.   The argus sensor does RTP discovery
on the fly, generating the extended flow attributes without configuration.

The argus DSRs provide the RTP specific information, such as codec, as
well as jitter, ( adjusting for silence suppression when encountered ), loss
and out of order indications, and the argus-client aggregation deals with
handling both entire streams and fixed/variable time slices, no problem.

Argus is not IPFIX, but you may find the argus approach useful.

http://qosient.com/argus

Carter

Carter Bullard
CEO/President
QoSient, LLC
150 E 57th Street Suite 12D
New York, New York  10022

+1 212 588-9133 Phone
+1 212 588-9134 Fax

On Dec 7, 2011, at 11:16 AM, Hendrik Scholz wrote:

> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>