Subject: [IPFIX] IPFIX processId uniqueness

From: Paul Aitken <[email-masked]>
Date: Wed, 13 Mar 2013 11:26:38 +0000

Dear IPFIX experts,

RFC5102 defines two processId IEs: meteringProcessId and 
exportingProcessId. And we could expect more *ProcessId IEs in future.

Are these expected or required to be unique?

Do we allow that a single process can both meter and export, therefore 
they are not unique?

What about the case of multiple CPUs, where although the processes are 
unique, the processIDs happen to be identical?

Thanks,
P.

---

From: Brian Trammell <[email-masked]>
Date: Wed, 13 Mar 2013 09:42:45 -0400

Hi, Paul,

These appear to me to be completely implementation-dependent, and are used to scope metadata reporting within an observation domain. I can't think of a useful application of comparison among epId and mpId, so I'm not sure why you'd need to enforce process ID uniqueness across multiple process ID IEs. Because of the implementation-specificness, the CP, for example, shouldn't presume that an MP an EP are the same (host OS) process just because their epId and mpId match, but that's okay because I can't see why the CP would ever have to deduce that anyway.

Regards,

Brian

On 13 Mar 2013, at 7:26, Paul Aitken <[email-masked]> wrote:

> Dear IPFIX experts,
> 
> RFC5102 defines two processId IEs: meteringProcessId and exportingProcessId. And we could expect more *ProcessId IEs in future.
> 
> Do we allow that a single process can both meter and export, therefore they are not unique?
> 
> What about the case of multiple CPUs, where although the processes are unique, the processIDs happen to be identical?
> 
> Thanks,
> P.
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: "Tarun Saxena (tasaxena)" <[email-masked]>
Date: Wed, 13 Mar 2013 14:32:19 +0000

There are implementations where exporting and metering processes are same, as well those where they are different.

It would be nice to have the two independent of each other. They can be same or different based on the dynamic assignment.

There could be a problem in case if exporting and metering processes are running on different hardware and end up with the same pId. In that case it can be left to the implementation to decide if it wants to distinguish between the two by reserving some bits, as the RFC does not mandate the way in which processId is framed.

Thanks
Tarun

-----Original Message----- 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Aitken (paitken)
Sent: Wednesday, March 13, 2013 4:57 PM
To: IETF IPFIX Working Group
Subject: [IPFIX] IPFIX processId uniqueness

Dear IPFIX experts,

Thanks,
P.