Subject: (IPng 6627) LDAP draft problem... (fwd from IPsec)

From: Dan McDonald <[email-masked]>
Date: Mon, 12 Oct 1998 17:04:02 -0700 (PDT)

I should have dropped this off on this list too.  The draft in question is:

	draft-ietf-ipsec-vpn-policy-schema-00.txt 

It blatantly doesn't learn any lessons about colons and IPv6 addresses.

Dan

===================== (Cut up to and including here.) =====================
Forwarded message:

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Oct 1998 10:42:48 +0100

Right, I spotted this in a draft schema a few weeks ago and told the
authors. I think we have caught it in time, and I'm sure the IESG
will lean on the proposed Policy WG to avoid this trap.

  Brian

Dan McDonald wrote:
> >From [email-masked]  Mon Oct 12 10:24:11 1998
> Delivery-Date: Mon, 12 Oct 1998 10:24:11 -0700
> From: Dan McDonald <danmcd@Eng>
> Message-Id: <[email-masked]>
> Subject: LDAP draft problem...
> To: [email-masked]
> Date: Mon, 12 Oct 1998 10:17:16 -0700 (PDT)
> X-Legal-Disclaimer: Please note that the information being provided does not
>                     constitute a warranty or a modification of any agreement
>                     you may have with Sun Microsystems, Inc., its subsidiaries
>                     or its customers.
> X-Mailer: ELM [version 2.4 PL25]
> MIME-Version: 1.0
> Content-Type: text/plain; charset=US-ASCII
> Content-Transfer-Encoding: 7bit
> Sender: [email-masked]
> Precedence: bulk
> 
> You've missed something important...
> 
> > NAME      SourceIPAddressRange
> > DESC      Source IP addresses to which the policy applies
> > EQUALITY caseExactIA5Match
> > SYNTAX    IA5String
> > SINGLE-VALUED
> > FORMAT    SourceIPAddressRange is of the following form: three colon (':')
> >           separated strings denoting a range of IP addresses. The
> >           following formats are currently defined
> >
> >
> >           1:<IPv4Address>:<CIDRPrefixLength>
> >                   The IP v4 address is in dotted decimal format. The
> >                   CIDRPrefixLength is the number of unmasked leading bits.
> >                   A packet matches the condition if the unmasked
> >                   bits on the packet are identical to the unmasked bits on the
> >                   condition.
> >
> >
> >           2:<IPv4Address>:<IPv4Address>
> 
> <SNIP!>
> 
> What about IPv6 addresses?  Using a colon as a separator will break in the
> presence of IPv6 addresses.  I don't even see IPv6 addressed in this document
> at all.
> 
> Dan
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------