Subject: (IPng 6592) Re: Base API : IPv4 Compatible Addresses :: and ::1

From: David Borman <[email-masked]>
Date: Tue, 6 Oct 1998 10:40:07 -0500 (CDT)

Jim,

> From: Jim Bound IPv6 Technical Leader UNIX Engineering Internet Group <[email-masked]>
> Subject: (IPng 6588) Base API : IPv4 Compatible Addresses :: and ::1
> Date: Tue, 06 Oct 1998 10:20:45 -0400
> ...
>
> All four steps listed are performed, in order.
> --------------------------------------------
>
> Here is the proposed text to replace the last sentence above and fix the
> IN6_IS_ADDR_V4COMPAT macro:
>
> ---------------------------------------------
> All four steps listed are performed, in order.  Also note that the IPv6
> hex addresses "::" and "::1" MUST NOT be treated as an IPv4-compatible
> address to generate a query for a Host Name, and HOST_NOT_FOUND MUST be
> returned and a query of the Host Name not performed.

Shouldn't that be "address", not "Host Name"?

> Also for the macro in section 6.7 IN6_IS_ADDR_V4COMPAT MUST return
> false for "::" and "::1".
> ---------------------------------------------
>
> Please comment.  I did this as the simplest fix.  

There is no reason why a query for ::1 should be *required* to fail.
A query for :: can be required to fail, but as long as ::1 is the
IPv6 loopback address, it should be able to succeed.  Something more
like:

  All four steps listed are performed, in order.  Also note that the IPv6
  hex addresses "::" and "::1" MUST NOT be treated as IPv4-compatible
  addresses,  and if the address is "::", HOST_NOT_FOUND MUST be
  returned and a query of the address not performed.
 
  Also for the macro in section 6.7 IN6_IS_ADDR_V4COMPAT MUST return
  false for "::" and "::1".

			-David Borman, [email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jim Bound IPv6 Technical Leader UNIX Engineering Internet Group <[email-masked]>
Date: Tue, 06 Oct 1998 13:16:28 -0400

Dave,

I think this is really excellent and appreciate your clarity.  I will
put this in the spec unless I hear significant objections.  I have
gotten offline input folks like Dave's proposal too.

-----------------------------------
 
Also for the macro in section 6.7 IN6_IS_ADDR_V4COMPAT MUST return
false for "::" and "::1".
-----------------------------------

thanks
/jim

---

From: [email-masked] (Sam Manthorpe)
Date: Tue, 6 Oct 1998 16:37:42 -0700 (PDT)

David Borman wrote:
> IPv6 loopback address, it should be able to succeed.  

Hmm.  Is there an officially recognised `name' for ::1, such as
localhost?  How about localipnode?

-- Sam

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Sam Manthorpe, SGI.  tel: (650)933-2856 fax: (650)932-2856  [email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------