Subject: AW: Usage of IPv6 flow label

From: Metzler Jochen <[email-masked]>
Date: Thu, 16 Nov 2000 11:04:12 +0100

Can you explain to me what the matter with DiffServ is?
I assumed that DiffServ makes use of the ToS field and
not of the flow label?
-- jochen

	-----Ursprüngliche Nachricht-----
	Von:	Francis Dupont [SMTP:[email-masked]]
	Gesendet am:	Donnerstag, 16. November 2000 10:58
	An:	Jun-ichiro itojun Hagino
	Cc:	Hesham Soliman (EPA); Metzler Jochen; Ipng (E-Mail)
	Betreff:	Re: Usage of IPv6 flow label 

	 In your previous mail you wrote:

	   	flow label field is not part of AH calculation, but as RSVP already
	   	requires it to be end-to-end (not hop-by-hop) i think we shouldn't
	   	rewrite it in transit.
	   
	=> I don't read your argument as you. I'll say it should not be rewritten
	in transit if RSVP is in use. A DiffServ edge router can rewrite it
	in some situation (it is supposed to know what is RSVP and do the right
	thing). Don't forget that in the real world RSVP is not end-to-end and
	is managed by smart edge routers, this comes more from practice (the end
	user doesn't know how to use RSVP, the edge router manager knows) than
	from deep design...

	Regards

	[email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Francis Dupont <[email-masked]>
Date: Thu, 16 Nov 2000 13:25:12 +0100

=> a part of this comes from a collision with a discussion initiated
by Thomas Eklund about DSCP and flow label marking...
The notion of edge routers is in the DiffServ architecture not in
the IntServ/RSVP one, and the same for the idea to mark packets
by edge routers and to use marks on core routers, but of course
these ideas can be (and are) used by RSVP too.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Nov 2000 13:27:34 -0600

As far as I know neither diffserv nor intserv/RSVP know anything
about the flow label field.

  Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org
Non-IBM email: [email-masked]

---

From: Jun-ichiro itojun Hagino <[email-masked]>
Date: Fri, 17 Nov 2000 06:14:16 +0900

>about the flow label field.

	RSVP has a reference to flow label, in RFC2205 section A.9.

itojun

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 20 Nov 2000 15:54:37 -0600

>         RSVP has a reference to flow label, in RFC2205 section A.9.

Wow. So it does, in defining the possible fields for a FilterSpec.
That still doesn't help us use it though.

Incidentally there is a bug in RFC 2205 - it still has the flow label
24 bits long, instead of 20.

  Brian

---

From: Jim Bound <[email-masked]>
Date: Tue, 21 Nov 2000 01:04:04 -0500

brian,

what is very cool in our implementation is we don't need the filter spec
just the flow spec.  also no having to look in the packet for ipv6, and
its part of the sockaddr_in6, and it works with our OTB IPv6 base api.

I would like to encourage all vendors to show up at Sun connectathon
with an IPv6 RSVP implementation to test.  The stuff works.

/jim