Subject: Sample config for cisco routers

From: "Enno Rey" <[email-masked]>
Date: Mon, 20 Nov 2000 00:19:31 +0100

Hi,

I'm currently preparing a presentation about IPv6. For the practical part,
there will be a either a 2503 (running c2500-p-mz.v6) or a 3620 (running
c3620-tipv6-mz.19990308) involved. I'm not able to find any sample
configuration on cco.
Anybody got any pointers?

Thanks & regards,

Enno Rey

ereyix.urz.uni-heidelberg.de
PGP 74C0 C7E1 3875 E4EB 9B75  8B9D 5E2D 3178 685B F222

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Enno Rey" <[email-masked]>
Date: Mon, 20 Nov 2000 11:43:22 +0100

Hi,

thanks to all who replied. I think I got enough input to get them up &
running.

As I said: Thanks

& regards,

Enno Rey

[email-masked]
PGP 74C0 C7E1 3875 E4EB 9B75  8B9D 5E2D 3178 685B F222

---

From: "huaning\(bii\)" <[email-masked]>
Date: Tue, 21 Nov 2000 15:02:52 +0800

Hi , all .
This is a sample config on my Cisco router (7507),
including Tunnel , BGP+ , IPv6 Addr. 
I would be very happy if it can make any help.

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 7507B
!
boot system flash:rsp-pv-mz.19991126
enable secret 5 $1$TG5.$kdmpBGQVLdebrKWwDJi./0
!
username 7507A password 7 104D000A061843
!
!
!
!
ip subnet-zero
ip cef
ip name-server 202.112.10.37
!
ipv6 unicast-routing
!
!
interface Tunnel100
 description tunnel100 7507B g0/0/0
 no ip address
 no ip directed-broadcast
 ipv6 enable
 ipv6 address 3FFE:510:0:FFFF::4/127
 tunnel source GigabitEthernet0/0/0
 tunnel destination 203.128.134.1
 tunnel mode ipv6ip
!
interface Tunnel101
 description tunnel101 
 no ip address
 no ip directed-broadcast
 ipv6 enable
 ipv6 address 3FFE:510:FFFF::1/126
 tunnel source GigabitEthernet0/0/0
 tunnel destination 203.178.140.204
 tunnel mode ipv6ip
!
interface Tunnel1010
 no ip address
 no ip directed-broadcast
!
interface GigabitEthernet0/0/0
 ip address 202.204.22.193 255.255.255.192
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 load-interval 30
 negotiation auto
 ipv6 enable
 ipv6 address 3FFE:510:1::/64
!
interface GigabitEthernet1/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 load-interval 30
 shutdown
 negotiation auto
!
interface FastEthernet4/0/0
 ip address 202.112.42.90 255.255.255.252
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 half-duplex
!
interface Serial4/1/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip route-cache distributed
 no ip mroute-cache
 no keepalive
 no fair-queue
 no arp frame-relay
!
interface Serial4/1/0.16 point-to-point
 ip address 203.128.132.2 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no arp frame-relay
 frame-relay interface-dlci 16
!
interface Serial4/1/1
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 shutdown
!
interface Serial4/1/2
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 shutdown
!
interface Serial4/1/3
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 shutdown
!
router bgp 10109
 neighbor 3FFE:510:FFFF::2 remote-as 2500
 no neighbor 3FFE:510:FFFF::2 activate
 !
 address-family ipv6
 neighbor 3FFE:510:FFFF::2 activate
 neighbor 3FFE:510:FFFF::2 prefix-list bii-in in
 neighbor 3FFE:510:FFFF::2 prefix-list bii-filter1 out
 network 3FFE:510:1::/64
 aggregate-address 3FFE:510::/32 summary-only
 exit-address-family
!
ip classless
ip route 0.0.0.0 0.0.0.0 202.112.42.89
ip route 203.128.128.0 255.255.224.0 203.128.132.1
no ip http server
!
!
!
line con 0
 exec-timeout 0 0
 password 7 07032458430C100B47
 login
 transport input none
line aux 0
line vty 0 5
 exec-timeout 0 0
 password 7 011F0310560E0F0172
 login
!
end

 _________________________________________________
    Hua Ning
    BII Group Holdings Ltd,
    11F China Merchants Tower,
    No.2 Dong Huan Nan Lu, Chao Yang District,
    Beijing,China
    Zip Code: 100022
    Tel:+86-10-65660290-223
    Fax:+86-10-65660297
_________________________________________________