Subject: RE: Usage of IPv6 flow label

From: "Thomas Eklund" <[email-masked]>
Date: Mon, 4 Dec 2000 21:41:11 +0100

Jim whats CE bits?

-- thomas

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jim Bound
> Sent: den 4 december 2000 18:41
> To: Steve Deering
> Cc: Francis Dupont; Brian E Carpenter; [email-masked];
> [email-masked]'; [email-masked]
> Subject: Re: Usage of IPv6 flow label 
> 
> 
> 
> >>In the future I can see two cases:
> >> - the flow label is set by the source (first camp)
> >> - the flow label is set by an edge router (with the 
> DiffServ definition
> >>   of what is an edge router) because the source box (or 
> its user) is
> >>   too dumb to deal with QoS/..., according to the edge 
> router manager.
> 
> >If the Flow Label is set by something other than the source node, how
> >do you guarantee its uniqueness, over the topological scope in which
> >it must be unique?  Do you need to invent a protocol between 
> the routers
> >on a LAN to divvy up the Flow label space?  What happens when the LAN
> >partitions, then routers in the different partitions assign duplicate
> >Flow Labels, and then the partition heals?
> 
> Obviously I agree with Steve and this is a killer point.  
> Recall in dec
> when we pushed the CE bit and it would only work exactly as 
> Steve states
> won't work above.  It never got used or deployed.  It needs 
> to come from
> the source and honored by the routers.
> 
> /jim
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Jim Bound <[email-masked]>
Date: Mon, 04 Dec 2000 21:01:59 -0500

thomas,

It was the Congestion Experienced bits defined by Raj Jain at Digital.
Close to the ECN bits from Sally but not as robust.

/jim