Subject: ping6 -R

From: "marcelo" <[email-masked]>
Date: Thu, 26 Apr 2001 15:35:12 +0200

Is there any way to implement a -R option (record route) in ping6, as it was
in IPv4?
Thanks,
marcelo bagnulo

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Dave Marquardt <[email-masked]>
Date: 26 Apr 2001 09:36:40 -0500

"marcelo" == marcelo  <[email-masked]> writes:
marcelo> Is there any way to implement a -R option (record route) in
marcelo> ping6, as it was in IPv4?  Thanks, marcelo bagnulo

IPv6 doesn't have the record route option, AFAIK.

-- 
Dave Marquardt
Sun Microsystems, Inc.
Austin, TX
+1 512 401-1077

---

From: "John Spence" <[email-masked]>
Date: Thu, 26 Apr 2001 08:09:06 -0700

You can also give your xterm a title.  That usually looks like -T "my title
here" in the xterm command.  It might be a little nicer to have ipfstat
display the hostname, but this gives you a pretty good solution as well.

Spence

---

From: "John Spence" <[email-masked]>
Date: Thu, 26 Apr 2001 09:12:38 -0700

My apologies.  My comments were a response to another list (ipfilter) I
subscribe to that appeared
in the eMail right above yours in my mail client - I mis-clicked.  My bad.

Spence

---

From: [email-masked]
Date: Fri, 27 Apr 2001 16:25:55 +0900

> Is there any way to implement a -R option (record route) in ping6, as it was

An idea "Record Route for IPv6 (RR6)" has been proposed.
#This idea was presented at the 49th San Diego meeting.

Please see 
http://www.ietf.org/internet-drafts/draft-kitamura-ipv6-record-route-00.txt

And, I have implemented and verified this idea.
Of course, "ping6 -R" has been implemented.

If you would like to try my implementation.
Please let me know.

Regards,
Hiroshi