Subject: NAPT - dynamic allocation

From: "Emanuel Moreira" <[email-masked]>
Date: 6 Apr 2001 11:59:31 -0000

Would'nt it be useful to have dinamical alocation of translation addresses in NAPT (Microsoft)? Then LAN's that don't need to be entirely connected to the IPv4 world would only have some IPv4 global addresses for translation and so save a lot of money. 
Thanks 
Emanuel Moreira

_____________________________________________________________
O e-mail preferido dos portugueses http://www.portugalmail.pt

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Brian Zill" <[email-masked]>
Date: Fri, 6 Apr 2001 17:25:57 -0700

Hi Emanuel,

> Would'nt it be useful to have dinamical alocation of 
> translation addresses in NAPT (Microsoft)? Then LAN's that 
> don't need to be entirely connected to the IPv4 world would 
> only have some IPv4 global addresses for translation and so 
> save a lot of money.

Yes, that would be a nice feature.  The NAT-PT box would then behave
more like a traditional NAT, in that you could save external addresses
in exchange for diminished inbound connectivity.

Our NAPT implementation is a pure research project, and we haven't had
the time to really do anything with it for over a year.  It was a
proof-of-concept more than anything else.  So it's unlikely that we'll
be adding dynamic allocation of translation addresses anytime soon.  But
the source is included in the download, so if you want to add that
capability, go ahead!

--Brian

> -----Original Message-----
> From: Emanuel Moreira [mailto:[email-masked]]
> Sent: Friday, 06 April, 2001 05:00
> To: Brian Zill; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: NAPT - dynamic allocation
> 
> 
> Would'nt it be useful to have dinamical alocation of 
> translation addresses in NAPT (Microsoft)? Then LAN's that 
> don't need to be entirely connected to the IPv4 world would 
> only have some IPv4 global addresses for translation and so 
> save a lot of money. 
> 
> Thanks 
> 
> Emanuel Moreira
>

---

From: "Tom Vivian" <[email-masked]>
Date: Tue, 10 Apr 2001 09:22:57 +0100

Anything that reduces dependence on Ipv4 seems like a good idea. 
It always struck me as an anomaly that Ipv4 is relied on by any 
IPv6 implementation. 

Here in the group developing Microsoft Mobile Explorer for 
Feature Phones, we have an IPv4 stack that will be changed 
to IPv6 at some point and it is far from certain that any 
IPv4 will be present in the networks it will have to operate in, 
so dependency on IPv4 may restrict the amount of existing 
Microsoft code we can re-use from other groups. 

Tom Vivian
Wireless Telephony Group Europe.

> From: Brian Zill 
> Sent: Saturday, April 07, 2001 1:26 AM
> To: Emanuel Moreira; [email-masked]; [email-masked];
> Subject: RE: NAPT - dynamic allocation
> 
> 
> Hi Emanuel,
> 
> ---
> You are currently subscribed to msripv6-users as: 
> [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 
>