Subject: ad hoc list created to discuss v6 usage measurement

From: "Perry E. Metzger" <[email-masked]>
Date: 01 Dec 2001 03:45:33 -0500

I've been trying to get a bunch of statistics together on v6 usage
growth and have found that few people are collecting serious
statistics. I thought I'd start a small discussion on the subject --
accurate statistics are important to demonstrate that v6 is indeed
deploying and that people should spend time and money on preparing and
deploying their own networks.

I've set up an ad hoc list, "[email-masked]" to host the
discussion. Subscribe via [email-masked].

Perry
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Jim Fleming" <[email-masked]>
Date: Sat, 1 Dec 2001 12:25:34 -0600

When people use alternate TLDs, they are labeled "alt" and people
declare that those people are not connected to *THE* Internet.
The "alt people" are ridiculed for having a small share of the market.
Some people tell the "alt people" to run along and find another sand-box
to play in. This does not seem to happen with IPv6 sales people.

It has been confirmed by IPv6 users that they are not connected to
the Internet. IPv4 systems can not talk to native IPv6 systems. It would
appear that IPv6 is some sort of "alt protocol" movement. The IPv6
people have their own root-servers, yet, ICANN and the IETF claim
that there can only be one true-root. IPv6 sales people do not seem to
be concerned about this. IPv6 sales people also do not seem to be
concerned about the IPv6 Privacy Problem.

While all of this is going on, IPv4 users are quite happy and can now
expand their addressing with no change required to the equipment that
connects them. The .BIZ TLD is now considered not to be "alt", it once
was. It appears that the "consensus" of the Internet community is to move
forward with the evolution of IPv4. There is a lot of room for expansion.
The "alt protocol" people appear to be determined to fragment the
Internet.

It is unclear why ICANN and the IETF do not declare that
there is "one true protocol" along with their "one true root".
Maybe that would lead to the declaration that there is
"one true address space" ?

Jim Fleming
http://www.IPv8.info

---

From: ryan elson <[email-masked]>
Date: Sat, 01 Dec 2001 13:39:50 -0500

it would be nice if address space were a little more free.  Does it make sense to anyone that
$100 is a fair price for a lousy name?  IPv4 and IPv6 both be damned, the US government seems to
think that it can only run tld's, the ignorant company (well this used to be the case) named
internic thought it could run a monopoly from this.  Both the IETF and ICANN be damned.  Same
with the W3C and all organisations that have been invented to make the internet.  Do you know
how bleak the future of the world looks right now?  We are going to eventually spend more
resources tearing down our little mistakes than it will take to build new things.  The emphasis
is not being put on good design, but rather, backwards compatability and stupid multi-platform
standards.  The W3C must've lacked that vision when they meddled with internet standards enough
to make the job of a webdesigner something closer to rocket science since they have to learn 5
languages just to scrape by (flash, java, asp/cold fusion, COM+, html/dhtml/xml).  It's
completely rediculous.  These organisations are supposed to make things better and instead the
only thing they accomplish is to thwart future progress by not thinking of the future quite
enough.  So here's a thanks to the moron that pushed IPv4 to become the internet when they
should have realized that the limits on address space could easily be surpassed, here's to the
idiots at the w3c who can't even get browsers to support alpha transparancy, or the idiots who
invented flash which has a high learning curve only because of it's poorly designed buggy
interface.  It is beyond me why some animations in flash require a 600mhz computer, seems a
little wasteful on processing power for the limited amount of effects that are produced by it.
The computers we have today are capable of so much more, why is it that the best thing we are
able to do when it comes to getting new standards is shooting ourselves in the foot?
You know your mistakes are going to come and bite you in the ass sooner or later.  Make things
dynamic enough so that they NEVER need to be changed, do not use any constants (for instance,
maximum addresses) at all.  I read all of what is contributed on this list, I think it is
irresponsible of ipng to consider doing anything less if they want to be taken seriously.  I
don't take things seriously when your ip protocol is not flexible enough to adapt to different
situations rather than have to tear apart an entire network just to get a new protocol on it.
It's too late with IPv4, and it's too late with IPv6 it seems...your minds are already set, you
don't think that however 100 billion addresses will not be all in use sometime?  Is it so
inconceivable?  Well then I hope you enjoy bearing the responsibility of not being so much of a
professional in your recommendations for the IP protocol when people are busy ripping down your
networks half a decade down the road because of something that should have been properly
designed.  Shame on the idiots who made that mistake in the past with IPv4, shame on the idiots
who are making the same mistake again.

---

From: "Jim Fleming" <[email-masked]>
Date: Sat, 1 Dec 2001 13:05:04 -0600

Perhaps Theodore Geisel, Dr. Seuss' inventor, had the best advice,
albeit not from The C@t in the Hat: 

"You have brains in your head. You have feet in your shoes. You can steer yourself any direction you choose."
- Dr. Seuss

Jim Fleming
http://www.ddj.com/articles/search/search.cgi?q=fleming
Oct93: The C+@ Programming Language

---

From: Pekka Savola <[email-masked]>
Date: Sat, 1 Dec 2001 21:05:44 +0200 (EET)

Hi,

Please keep Jim Fleming in Cc: in threads initiated by Mr. Fleming.  That 
way our filters have better chance of "storing" these threads to where 
they belong to.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 03 Dec 2001 10:53:25 +0100

Yes, it is really slow to filter out stuff with the string "Jim Fleming"
in the message body.

   Brian

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 3 Dec 2001 08:40:05 -0600

When you design protocols with 128 bit address fields, and then you
proceed to place non-routable, random numbers, in the right-most 64 bits
of each field, that results in 16 bytes of the 40 byte header being wasted.
Those wasted bytes help to slow networks down and increase the need
for bandwidth. Such protocols will not likely be desired by people who
pay for bandwidth and people who like performance computing. While
such designs might be interesting academic exercises, and might be useful
in landing large government grants based on some artificial need for more
bandwidth, they are not considered engineering progress for the commercial
sector which builds networks that real people use in everyday life, especially
in the United States of America.

Jim Fleming
http://www.IPv8.info
IPv16....One Better !!

---

From: Damien Mascré <[email-masked]>
Date: Mon, 3 Dec 2001 23:12:13 +0100

Don't forget that the low 8 bytes are not always
ramdomly choosed and that having a rigid format
for the packet is cute because the routers
can handle the packets more faster, and so,
it results in an increased bandwidth....

> -----Message d'origine-----
> De : [email-masked]
> [mailto:[email-masked]]De la part de Jim Fleming
> Envoyé : lundi 3 décembre 2001 15:40
> À : Brian E Carpenter; [email-masked]
> Objet : Re: "one true protocol"
>
>

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 3 Dec 2001 16:25:59 -0600

This may help...
http://www.dot-biz.com/IPv4/Tutorial/

The Netfilter Project: Packet Mangling for Linux 2.4
http://netfilter.samba.org

Jim Fleming
http://www.IPv8.info
IPv16....One Better !!

---

From: ryan elson <[email-masked]>
Date: Mon, 03 Dec 2001 17:35:12 -0500

Well I think sending useless information is sending useless
information...period.
If it is some filling that is needed to make routers more efficient, couldn't
there be a device within the router that actually gives the packet it's useless
filling?  Why bother have that useless filling at all?  Why not just have
computers send out a forced size packet and then build the routing around that
size (which could be increased or decreased if needed), so why the useless
filling?  I think it would be much more efficient if everything inside that
packet contained tangeable, useful information, don't you?  I think things are
heading in a direction we are going to regret, albeit not right away in the
future, perhaps even beyond out own lifetimes (or maybe even during them) but I
think the only limitation to IP protocol are the limitations groups that
construct newer revisions place on them.  Why limit things at all and why
facilitate the trasmission of junk?