Subject: RE: Feedback from 3GPP about draft-wasserman

From: Hughes John-CJH023 <[email-masked]>
Date: Tue, 11 Dec 2001 16:32:07 -0800

Hi Margaret,

I agree with you that the router advertisement will be different for each PDP context, after all the RA is the mechanism by which the MS is notified of the prefix which it may use and if /64 is being assigned on a per PDP context basis then each prefix must be different. 

However for each IPv4 address, there can only be 64k (well 2^16) prefixes where 6to4 is being used. So it is still the case that with 6to4, each IPv4 global address allows 64k PDP contexts per APN to be supported. Having n IPv4 addresses, will allow n x 64k PDP contexts to be supported per APN.

I echo a comment by Brian, 6to4 is intended to be a transition mechanism and is not intended for sites with >30 or 40 million users. When IPv6 in 3GPP is that successful where an operator has >30 million IPv6 PDP Contexts, there should exist native IPv6 connections.

I do not see your draft preventing the use of 6to4, so long as an operator does not plan using 6to4 as a long term strategy.

Regards,
John

> >Well, all terminals attached to a given APN will receive the 
> same router
> >advertisements from the GGSN, so having two IPv4 global addresses per
> >APN would simply mean that each primary PDP context would 
> get two 6to4
> >addresses, but the limit will still be 64k primary PDP 
> contexts per APN.
> 
> Why would all terminals attached to a given APN receive the 
> same router
> advertisements?  Won't there be multiple PDP contexts associated with
> a given APN?  If so, the GGSN should be sending different router 
> advertisements for each PDP context, each containing the prefix(es) 
> assigned to that particular PDP context.
> 
> Since each prefix will be assigned to one (and only one) PDP 
> context, I
> think that you will have the possibility of assigning 64K 
> 6to4 addresses
> per PDP context, not per APN.
> 
> Am I misunderstanding something?
> 
> Margaret
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Juan-Antonio Ibanez <[email-masked]>
Date: Wed, 26 Dec 2001 17:58:26 +0100

Hi John and Margaret,

Late reply, but I have been traveling quite a lot lately...

You are right, RAs will of course be per PDP context. What I had in mind
(though it's not what I wrote in my hasty reply) is that all terminals
attached to a given APN would receive RAs with the same upper 48 bits.
But it was without considering that we could allocate a x/ IPv4 address
to an APN, with x<32, as suggested by Brian, and thus raise the limit to
2^(32-x) times 64k PDP contexts per APN when using 6to4 (though one
could wonder whether this is totally in line with RFC 3056). So I guess
I agree that the limit is not strictly 64k PDP contexts per APN.

BR,
Juan

-- 
----------------------------------------------
  Juan-Antonio Ibanez
  Ericsson Mobile Data Design AB
  Gothenborg - Sweden
  Tel.:  +46 31 344 1828 (mobile)
  Email: [email-masked]
----------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------