Subject: Re: "one true protocol"

From: ryan elson <[email-masked]>
Date: Mon, 03 Dec 2001 20:14:09 -0500

Subject: Re: "one true protocol"
From: ryan elson <[email-masked]>
To: [email-masked]
Date: Mon, 03 Dec 2001 17:35:12 -0500

Well I think sending useless information is sending useless
information...period.
If it is some filling that is needed to make routers more efficient, couldn't
there be a device within the router that actually gives the packet it's useless
filling?  Why bother have that useless filling at all?  Why not just have
computers send out a forced size packet and then build the routing around that
size (which could be increased or decreased if needed), so why the useless
filling?  I think it would be much more efficient if everything inside that
packet contained tangeable, useful information, don't you?  I think things are
heading in a direction we are going to regret, albeit not right away in the
future, perhaps even beyond out own lifetimes (or maybe even during them) but I
think the only limitation to IP protocol are the limitations groups that
construct newer revisions place on them.  Why limit things at all and why
facilitate the trasmission of junk?

Damien Mascré wrote:

> Don't forget that the low 8 bytes are not always
> ramdomly choosed and that having a rigid format
> for the packet is cute because the routers
> can handle the packets more faster, and so,
> it results in an increased bandwidth....
>
> > -----Message d'origine-----
> > De : [email-masked]
> > [mailto:[email-masked]]De la part de Jim Fleming
> > Envoyé : lundi 3 décembre 2001 15:40
> > À : Brian E Carpenter; [email-masked]
> > Objet : Re: "one true protocol"
> >
> >
> > When you design protocols with 128 bit address fields, and then you
> > proceed to place non-routable, random numbers, in the right-most 64 bits
> > of each field, that results in 16 bytes of the 40 byte header
> > being wasted.
> > Those wasted bytes help to slow networks down and increase the need
> > for bandwidth. Such protocols will not likely be desired by people who
> > pay for bandwidth and people who like performance computing. While
> > such designs might be interesting academic exercises, and might be useful
> > in landing large government grants based on some artificial need for more
> > bandwidth, they are not considered engineering progress for the commercial
> > sector which builds networks that real people use in everyday
> > life, especially
> > in the United States of America.
> >
> > Jim Fleming
> > http://www.IPv8.info
> > IPv16....One Better !!
> >
> >
> > ----- Original Message -----
> > From: "Brian E Carpenter" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Monday, December 03, 2001 3:53 AM
> > Subject: Re: "one true protocol"
> >
> >
> > > Yes, it is really slow to filter out stuff with the string "Jim Fleming"
> > > in the message body.
> > >
> > >    Brian
> > >
> > > Pekka Savola wrote:
> > > >
> > > > Hi,
> > > >
> > > > Please keep Jim Fleming in Cc: in threads initiated by Mr.
> > Fleming.  That
> > > > way our filters have better chance of "storing" these threads to where
> > > > they belong to.
> > > >
> > > --------------------------------------------------------------------
> > > IETF IPng Working Group Mailing List
> > > IPng Home Page:                      http://playground.sun.com/ipng
> > > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > > Direct all administrative requests to [email-masked]
> > > --------------------------------------------------------------------
> > >
> >
> > --------------------------------------------------------------------
> > IETF IPng Working Group Mailing List
> > IPng Home Page:                      http://playground.sun.com/ipng
> > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > Direct all administrative requests to [email-masked]
> > --------------------------------------------------------------------
> >
>
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------

---

From: ryan elson <[email-masked]>
Date: Mon, 03 Dec 2001 20:30:26 -0500

My own internet protocol?  If people were not so ignorant towards YOUR internet
protocol they might just think twice of scrapping it instead of paying for the same
stuff OVER and OVER and over again.  Any of you getting bribed to handle things this
way?  Is it your job to limit things?  Keep innovation under wraps?  No wonder there
are people you don't want contributing to your list.
You guys, microsoft, hardware manufacturers, you are all in bed with each other I
swear to god.

David Terrell wrote:

> On Mon, Dec 03, 2001 at 08:14:09PM -0500, ryan elson wrote:
> Speaking of facilitating the transmission of junk:
> Would you please stop carrying on conversations with Jim Fleming
> on the ipng list?  If you want your own internet protocol, go set
> up your own mailing list.
>
> --
> David Terrell            | "... a grandiose, wasteful drug war that will never
> [email-masked]             | be won as long as so many Americans need to
> Nebcorp Prime Minister   | anesthetize themselves to get through the day."
> http://wwn.nebcorp.com/  |  -Camille Paglia