Subject: IP Tunnel MIB

From: "Daniel Feldman" <[email-masked]>
Date: Sun, 2 Dec 2001 15:22:01 +0200

Dear IPNG and L2TP groups,
	RFC 2667 deals with IP Tunnel MIB, which is needed for the L2TP
MIB. However, it only supports IPv4:

"Finally, this MIB does not support tunnels over non-IPv4 networks
(including IPv6 networks).  Management of such tunnels  may be supported
by other MIBs."

	Is there any work on such an MIB? It is required for having L2TP
over IPv6...

	Thanks in advance,

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Daniel Feldman
System Engineer, IC4IC Ltd.
office: +972(4)959-4644 ext. 121
mobile: +972(55)990-299
fax:    +972(4)959-4944
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Daniel Feldman" <[email-masked]>
Date: Sat, 8 Dec 2001 08:11:41 +0200

Sorry, I wasn't on the L2TPext list back in March...

The minimal modification that RFC2667 should suffer in order to be IPv6
compatible would be, of coarse, having the IP address fields changed
from 32 to 128 bits. Another possible change would be including the Flow
Label field to the TunnelIfEntry (it includes now LocalAddress,
RemoteAddress, EncapsMethod, HopLimit, Security and TOS). TOS can be
used as traffic class, so just a name change there.

-----Original Message-----
From: W. Mark Townsley [mailto:[email-masked]]
Sent: Saturday, December 08, 2001 2:45 AM
To: Daniel Feldman
Cc: [email-masked]; [email-masked]
Subject: Re: [L2tpext] IP Tunnel MIB

Daniel Feldman wrote:
>         Is there any work on such an MIB? 

Not that I know of.

> It is required for having L2TP
> over IPv6...

I pinged the list back in March about L2TP over IPv6 and received
nothing but
deafening silence. I would hope that any changes in the MIB to support
L2TP over
IPv6 would be very, very, minimal.

> _______________________________________________
> L2tpext mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: Klausberger Walter <[email-masked]>
Date: Wed, 12 Dec 2001 18:37:14 +0100

Well, I didn't want to offend anyone and people surely did a good job, but I
still think that the IP Tunnel MIB is a bit too static and fit for LNS, but
not so well for a RADIUS driven LAC.

I really would like to see an example for a RADIUS controlled LAC that
supports Tunnel MIB.

regards
- walter

> From: Evan Caves [mailto:[email-masked]]
> Sent: Tuesday, December 11, 2001 1:18 AM
> To: W. Mark Townsley
> Cc: Klausberger Walter; 'Daniel Feldman'; [email-masked];
> [email-masked]
> W. Mark Townsley wrote:
> >Hi Walter.
> >The L2TP MIB we have today, which for the record is the MIB 
> for RFC2661 L2TP
> >over IPv4, has available for extensive review by this group 
> as well as the MIB
> >Doctors whose time is not easy to come by and blessing 
> sometimes difficult to
> >achieve. It has been a long and tedious process that I would 
> hate to turn on its
> >ear at this point and try to repeat from square zero.
> >
> >As you have mentioned, L2TPv3 will require significant MIB 
> changes in order to
> >support multiple L2 transports. 
> >
> I think you mean different payloads. The MIB in its current form is 
> structured to support multiple L2 transports. I
> would suspect that the effort involved is about the same as it was 
> tearing apart the L2TP protocol spec to
> create base and payload specs.
> 
> evan
> -
> 
>