Subject: RE: draft-rajahalme-ipv6-flow-label-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 20 Dec 2001 16:26:54 +0100

>   | - Or assume that the host distributes different flows 
  > to different default
  >   | routers. How will you guarantee that the routers will 
  > not pick the same flow
  >   | label values (which would be a problem if the flows go 
  > to the same
  >   | destination)?
  >   | 
  >   | - Or what if the host is "dumb" only with some flows, 
  > but will assign flow
  >   | label values for some other flows. How will you 
  > synchronize the flow label
  >   | setup in the host and the router?
  > 
  > Any of these can be handled by administrative control if 
  > necessary (the
  > first few bits in the flow label identify the source - 0 -> 
  > original host,
  > 1, 2, .. N identify a router).
  > 
  > Smart routers are possible, not necessarily smart though.
  > 

=> Sorry but this is very unrealistic. Setting the flow 
label at the default router, pretty much rules
out the multiple default router case for a realistic
scenario. I don't think that should be allowed. The node
initiating the connection is the node with most information
about it's flow and it should be the one setting it. Let's
not try to buit any more dependencies on the default routers. 

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Thu, 20 Dec 2001 23:02:49 +0700

Date:        Thu, 20 Dec 2001 16:26:54 +0100
    From:        "Hesham Soliman (ERA)" <[email-masked]>
    Message-ID:  <[email-masked]>

  | => Sorry but this is very unrealistic.

It wasn't meant to be realistic, just an example to show it can be done.

  | Setting the flow label at the default router, pretty much rules
  | out the multiple default router case for a realistic
  | scenario.

Yes.

  | I don't think that should be allowed.

Huh?   What shouldn't be allowed?   Not having multiple default
routers?   That is, you're saying everyone must have more than one?
That would be rather ambitious.

  | The node initiating the connection is the node with most information
  | about it's flow and it should be the one setting it.

I agree completely, it should be.   That isn't the question however.

  | Let's not try to buit any more dependencies on the default routers. 

I agree as well.

But, if I have only one default router, and I have a lot of applications
that know nothing about setting flow labels (which pretty much describes all
the IPv6 code that exists at the minute that Im aware of), are you telling
me that I am to be prohibited from having the router do classification and
set the flow label to some intelligent choice ?

Note: no-one is proposing (that I am aware of) mandating that it work
this way - the issue is more of whether we should be prohibiting it.
Personally, I like to prohibit as little as possible, unless there's
a very good reason - and that someone (or some group) can't figure out
how they'd sanely use it, isn't good enough.

kre